IPB

Welcome Guest ( Log In | Register )

9 Pages V  < 1 2 3 4 > »   
Reply to this topicStart new topic
MAREO 3.0 Released!, and discussion topic ...
kwanbis
post Mar 4 2006, 06:19
Post #26





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



QUOTE (goodlookin @ Mar 4 2006, 05:10 AM)
Thanks for asking, however I don't understand what "user defined variables" are and what they are used for.  I'm just trying to learn as much as I can about MAREO's options before I start transferring all of my CDs.  If I don't understand what something is, I have no way of knowing if it's an option that I could use or not.

suppose you want to add a comment with the date to each encoded file, (i'm now thinking of adding a @date@ and @time@ vars, but lets continue as now, when they don't exist). In lame, that is done by adding: --tc <comment> so, how do i do it without editing the ini files?

PARAMETERS = -V5 --vbr-new --ignore-tag-errors --ta "@artist@" --tl "@album@"
--tt "@title@" --tn "@track@" --ty "@year@" --tg "@genre@" --tc "@1@" "@source@" "@dest@"

then, at eac's Compression options dialog box, under the External Compression tab, i configure the Additional command line options as:

mareo.ini %s %d "%a" "%g" "%t" "%n" %y "%m" 2006-03-04

then, 2006-03-04 is replaced whenever it says @1@.

but, believe me 99.99% of the time, people don't use them. I don't use them.


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
Jesus_Freak
post Mar 4 2006, 06:23
Post #27





Group: Members
Posts: 17
Joined: 4-March 06
Member No.: 28251



QUOTE (kwanbis @ Mar 4 2006, 01:14 AM)
QUOTE (Jesus_Freak @ Mar 4 2006, 05:11 AM)
Could I perhaps get an IP address to get to the address that way? It almost seems as if my DNS servers (verizons) cannot resolve the name for some reason. So maybe an actual IP address might solve the problem.

200.58.113.89
*


Arg!
No luck.
I did a tracert and the connection starts timing out 16 hops in, right after it hits 200.41.63.190.
Just plain werid

JF
Go to the top of the page
+Quote Post
GHammer
post Mar 4 2006, 11:25
Post #28





Group: Members
Posts: 224
Joined: 11-May 03
From: China
Member No.: 6546



I have all encoders and tools in a directory listed in the PATH on XP.
If I open a command window and type lame, for example, I get LAME

Using ENCODER = lame.exe in the ini I get only an error

NOT FOUND: lame.exe ... **ERROR**
EXECUTION **ERROR**

Same for mac, wvpack, etc.
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 4 2006, 12:36
Post #29





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



Have you tried restarting the computer and try again after you insert the new PATH values?
Well, shouldn't be like that, but who knows...it's Windows we're talking about.
Go to the top of the page
+Quote Post
GHammer
post Mar 4 2006, 13:53
Post #30





Group: Members
Posts: 224
Joined: 11-May 03
From: China
Member No.: 6546



After copying the encoders to the MAREO directory I can execute.

I find that my mp3gain process is never run, no error, just nothing fires at all.

Also, if the selection name has an '/' in it, the resulting directory structure is changed. MAREO should look for such characters and subsititute and underscore or blank for them.
Go to the top of the page
+Quote Post
kwanbis
post Mar 4 2006, 15:57
Post #31





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



QUOTE (GHammer @ Mar 4 2006, 10:25 AM)
I have all encoders and tools in a directory listed in the PATH on XP.
If I open a command window and type lame, for example, I get LAME
Using ENCODER = lame.exe in the ini I get only an error

you MUST specify the full path, like c:\encoders\lame.exe

QUOTE (GHammer @ Mar 4 2006, 12:53 PM)
I find that my mp3gain process is never run, no error, just nothing fires at all.

Also, if the selection name has an '/' in it, the resulting directory structure is changed. MAREO should look for such characters and subsititute and underscore or blank for them.

you should post the relevant part of your INI file, and your LOG file.


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
goodlookin
post Mar 5 2006, 04:22
Post #32





Group: Members
Posts: 24
Joined: 20-February 06
Member No.: 27923



Thanks for the "user variable" lesson Kwanbis, it cleared it up for me. You don't know how much it means to us "newbies" that you guys take the time to explain even the simple stuff to us ... and I know that the others appreciate it just as much as I do. smile.gif
Go to the top of the page
+Quote Post
kwanbis
post Mar 5 2006, 04:48
Post #33





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



my pleasure. another example i could add is, for example, in EAC, %x means last album track number. it is currently unsupported in MAREO, but if you pass it as the 10th parameter as here:

mareo.ini %s %d "%a" "%g" "%t" "%n" %y "%m" %x

you can then use the value in the hole INI file, as @1@

this is another example.

Same for some rippers, like dbpoweramp, that support other non-standard (for mareo) parameters, like dbpoweramp, that supports "comments" passing, you could again pass them as: the 10th parameter.


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
GHammer
post Mar 5 2006, 17:40
Post #34





Group: Members
Posts: 224
Joined: 11-May 03
From: China
Member No.: 6546



To follow up to my earlier, incomplete post:
I found my error was to enclose the path and executable name in quotes.
Remove the quotes and the encoders are found and executed fine.

I am unable to get mp3gain to run however. No error, it simply is never called as far as I can see.

Thanks for any help.

Here's the section of the INI that creates an MP3, then should run mp3gain:

CODE
; ---------------------------------------------------------------------------------------------------------------------------
; MP3 LAME: best MP3 encoder: http://www.rarewares.org/mp3.html
; ---------------------------------------------------------------------------------------------------------------------------
FULLNAME = D:\Transcode\@artist@\@album@\@artist@ - @track@ - @title@.mp3
ENCODER = D:\Program Files\Exact Audio Copy\Encoders\lame.exe
PARAMETERS = -V5 --vbr-new --noreplaygain --ignore-tag-errors --ta "@artist@" --tl "@album@" --tt "@title@" --tn "@track@" --ty "@year@" --tg "@genre@" "@source@" "@dest@"
ONLYIFLAST = FALSE

; ---------------------------------------------------------------------------------------------------------------------------
; MP3gain: TRACK Mode: mp3 normalizer: http://www.rarewares.org/mp3.html
; ---------------------------------------------------------------------------------------------------------------------------
FULLNAME = NONE
ENCODER = D:\Program Files\Exact Audio Copy\Encoders\mp3gain.exe
PARAMETERS = /p /k /r /s s D:\Transcode\@artist@\@album@\@artist@ - @track@ - @title@.mp3
ONYLYIFLAST = FALSE


EDIT
The problem was the ONLYIFLAST misspelled in the INI. There is another in the default INI as well. Fixing that solved the problem.

This post has been edited by GHammer: Mar 5 2006, 17:46
Go to the top of the page
+Quote Post
goodlookin
post Mar 5 2006, 18:01
Post #35





Group: Members
Posts: 24
Joined: 20-February 06
Member No.: 27923



Thank you for the additional "user variable" info Kwanbis! I really appreciate it ... and if you think of anything else, you know where to find me ... laugh.gif
Go to the top of the page
+Quote Post
kwanbis
post Mar 5 2006, 18:02
Post #36





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



good catch. I just fixed it. I'm taking a 15 days vacations, so i don't be replying probably for that long. Thanks to all.


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
goodlookin
post Mar 6 2006, 05:14
Post #37





Group: Members
Posts: 24
Joined: 20-February 06
Member No.: 27923



When using MAREO to encode FLAC & an iTunesEncode ACC file, you can delete the file in Itunes after encoding and just keep the one in your "@dest@" folder by using the iTunesEncode -d option, but is there a way to keep the iTunes file & delete the one in the "@dest@" folder?

iTunesEncode says the output (or the @dest@) file is optional, and if you omit it, the file is in your iTunes directory only (which is what I'm trying to obtain) but when I do it this way in conjunction with MAREO, I get an error and MAREO hangs & won't continue until I hit the enter key.

Any ideas?
Thanks a bunch smile.gif
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 6 2006, 05:42
Post #38





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



What was the error?
Could you post your mareo.log here?
And please use the codebox tag for the log. =)

CODE
[codebox]Your mareo.log file content[/codebox]
Go to the top of the page
+Quote Post
goodlookin
post Mar 6 2006, 06:49
Post #39





Group: Members
Posts: 24
Joined: 20-February 06
Member No.: 27923



I know why I'm getting an error in MAREO ... it's because I deleted the @dest@ from the portion MAREO.ini that pertains to iTunesEncode. Per iTunesEncode, if you don't specify an output file (which, I thought was the @dest@ file), then iTunes only leaves a copy of the file in the iTunes Library. However, MAREO errors out if it doesn't see a @dest@ file, so I need to try to find another way to accomplish it. Anyway, here is a copy of the MAREO log file that I get when I don't use the @dest@. The error is in the Processing Order 3. (I hope I've used the CODE BOX" correctly ... I have't been here that long & I've never used it before. crying.gif )

CODE

MAREO - Multiple Applications Runner for EAC and Others - GPL Licensed
3 beta - Copyright 2003-2006 by Kwanbis - http://www.webearce.com.ar/
Developed with Borland Delphi (info @ http://borland.com/delphi/)

*** Received Command Line ***

"C:\Program Files\Audio Conv Progs\Mareo\mareo.exe" Mareo.ini "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav" "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.mp3" "Alan Jackson" "Who I Am" "Who I Am" "5" 1994 "Country" "

*** Parsed Parameters ***

IniFileName (%1) = Mareo.ini
@source@ (%2) = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav
@dest@ (%3) = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.mp3
@artist@ (%4) = Alan Jackson
@album@ (%5) = Who I Am
@title@ (%6) = Who I Am
@track@ (%7) = 5
@year@ (%8) = 1994
@genre@ (%9) = Country

*** INI Parameters ***

LogToScreen = TRUE
LogToFile = TRUE
RenameFirstFile = TRUE
DeleteWavFile = TRUE


*** PROCESSING ENCODER ORDER # 1 ***

ENCODER Extension = flac

TEMPORAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.flac
TEMPORAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp
TEMPORAL Name Only = Atmp7!1!5

FINAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC\ Who I Am.flac
FINAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC
FINAL Name Only = Who I Am

Run Only If Last = FALSE

EXECUTING: C:\Program Files\Audio Conv Progs\Flac\Flac.exe -5 "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav" -o "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.flac" -T artist="Alan Jackson" -T album="Who I Am" -T title="Who I Am" -T tracknumber="5" -T date="1994" -T genre="Country" -T COMMENT="FLAC" ... EXECUTION SUCCESS!!

DIRECTORY "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC" allready exists.

DELETING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC\ Who I Am.flac ... SUCCESS!!

RENAMING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.flac => D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC\ Who I Am.flac ... SUCCESS!!



*** PROCESSING ENCODER ORDER # 2 ***

ENCODER Extension = mp3

TEMPORAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.mp3
TEMPORAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp
TEMPORAL Name Only = Atmp7!1!5

FINAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3\ Who I Am.mp3
FINAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3
FINAL Name Only = Who I Am

Run Only If Last = FALSE

EXECUTING: C:\Program Files\Audio Conv Progs\Lame\lame.exe -V2 --vbr-new --add-id3v2 --pad-id3v2 --ignore-tag-errors --ta "Alan Jackson" --tl "Who I Am" --tt "Who I Am" --tn "5" --ty "1994" --tg "Country" --tc "MP3-LAME" "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav" "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.mp3" ... EXECUTION SUCCESS!!

DIRECTORY "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3" allready exists.

DELETING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3\ Who I Am.mp3 ... SUCCESS!!

RENAMING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.mp3 => D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3\ Who I Am.mp3 ... SUCCESS!!



*** PROCESSING ENCODER ORDER # 3 ***

ENCODER Extension = m4a

TEMPORAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.m4a
TEMPORAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp
TEMPORAL Name Only = Atmp7!1!5

FINAL Full Name = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC\ Who I Am.m4a
FINAL Path Only = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC
FINAL Name Only = Who I Am

Run Only If Last = FALSE

EXECUTING: C:\Program Files\Audio Conv Progs\ITunesEncode\ItunesEncode.exe -e "AAC Encoder" -a "Alan Jackson" -l "Who I Am" -t "Who I Am" -n 5 -y "1994" -g "Country" -c "AAC-iTunesEncode" -i "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav" ... EXECUTION SUCCESS!!

DIRECTORY "D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC" allready exists.

RENAMING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.m4a => D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC\ Who I Am.m4a ... **ERROR**

DeleteWaveFile is TRUE.
DELETING: D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\0-Temp\Atmp7!1!5.wav ... SUCCESS!!

*** DONE ***

1 errors ocurred. Press any key to end.



Any ideas about how to delete the destination file (only for the iTunesEncode processing) other than the way I tried?

Thanks so much for your help.

Moderation: Remove unnecessary quote and converted CODE to CODEBOX.

This post has been edited by Synthetic Soul: Mar 6 2006, 08:05
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 6 2006, 07:29
Post #40





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



QUOTE (goodlookin @ Mar 6 2006, 12:49 PM)
(I hope I've used the CODE BOX" correctly ... I have't been here that long & I've never used it before.  crying.gif )

You used

CODE
Your log.

Instead of

CODE
Your log.
Use this to put very long texts like mareo.log. wink.gif

Remember that next time. =)

Regarding workaround, try setting FULLNAME to the same directory and naming format that iTunes uses.
Put back @dest@ to iTunesEncode parameters, and then try again.
I don't know what will happen, so don't ask. wink.gif
Go to the top of the page
+Quote Post
awnm
post Mar 6 2006, 22:47
Post #41





Group: Members
Posts: 27
Joined: 31-March 05
Member No.: 21080



QUOTE (goodlookin @ Mar 6 2006, 03:49 PM)
Per iTunesEncode, if you don't specify an output file (which, I thought was the @dest@ file), then iTunes only leaves a copy of the file in the iTunes Library.  However, MAREO errors out if it doesn't see a @dest@ file

I'm trying to accomplish the same thing - leaving the file in the iTunes managed library, and not creating another file - via Foobar's Convertor (see question here). It seems that the various apps (MAREO, Foobar) all expect an output file and fail if there isn't one - despite it being a valid iTunesEncode command line.

It's an interesting idea, but I'm not sure about the suggestion for putting the FULLNAME into the same directory path as the iTunes library - that would be pretty hard to manage as the iTunes library path and song name are not always easy to predict, given special character translations etc.

The best solution I can come up with is to direct all output, eg @dest@, to a temporary folder somewhere and just delete everything in that folder periodically...or even automatically using a command at the end of the encoding process.
Go to the top of the page
+Quote Post
Larry
post Mar 9 2006, 06:56
Post #42





Group: Members
Posts: 4
Joined: 9-March 06
Member No.: 28357



I've setup EAC to rip FLAC and mp3 (Lame 3.97b2) pretty much using the beginners guide from the slim devices site. I created profiles in EAC for each, and indivually each one seems to work fine.

My ripping strategy is to rip to FLAC for Squeezebox3 playback and mid quality mp3 for portable use. MAREO seems to be the tool that lets you automate this process within EAC. The system runs Windows XP Pro w/ 2GB of memory. When I run EAC configured for MAREO, I get a Windows error pop-up after a track is extracted that says, "mareo.exe has encountered a problem and needs to close. We are sorry for the inconvenience." When I check my music folders, it seems to be creating the WAV files but the mp3 and FLAC files aren't being created. By all accounts, it appears that MAREO isn't executing properly.

In EAC if I explicitly include the entire path of the mareo.ini file in the external compression - additional command line options it no longer gives me the Windows XP error, but it still doesn't execute LAME or FLAC.

I'll post some of the relevant config info. Can someone tell me what I'm doing wrong? I've tried all sorts of variations where I include more quoted stuff in the mareo.ini file and also moving the LAME.exe and FLAC.exe into the mareo folder, but I end up with the same results.


EAC external compression program path: C:\Program Files\Exact Audio Copy\mareo\mareo.exe

EAC external compression additional command line option: C:\Program Files\Exact Audio Copy\mareo\mareo.ini %s %d "%a" "%g" "%t" "%n" %y "%m"

Delete WAV after compression: not checked

FLAC external compressor command line when used without MAREO:

-6 -V -T "artist=%a" -T "title=%t" -T "album=%g" -T "date=%y" -T "tracknumber=%n" -T "genre=%m" -T comment="%e" -T "comment=EAC (Secure Mode)" %s --replay-gain

LAME external compressor command line when used without MAREO:

-V 4 --vbr-new --add-id3v2 --pad-id3v2 --ta "%a" --tt "%t" --tg "%m" --tl "%g" --ty "%y" --tn "%n" %s %d


MAREO.INI file:

LogToScreen = TRUE
LogToFile = TRUE
RenameFirstFile = TRUE
DeleteWavFile = TRUE

---------------------------------------------------------------
; MP3 LAME: best MP3 encoder: http://www.rarewares.org/mp3.html
---------------------------------------------------------------
FULLNAME = D:\Larry\My Documents\My Music\EAC Ripped\mp3\@artist@\@album@\@track@ @title@.mp3

ENCODER = C:\Program Files\Exact Audio Copy\LAME 3.97b2\lame.exe

PARAMETERS = -V 4 --vbr-new --add-id3v2 --pad-id3v2 --ta "@artist@" --tt "@title@" --tg "@genre@" --tl "@album@" --ty "@year@" --tn "@track@" "@source@" "@dest@"

ONLYIFLAST = FALSE
;
---------------------------------------------------------------
; FLAC: most supported lossless encoder: http://www.rarewares.org/lossless.html
---------------------------------------------------------------
FULLNAME = D:\Larry\My Documents\My Music\EAC Ripped\flac\@artist@\@album@\@track@ @title@.flac

ENCODER = C:\Program Files\FLAC\flac.exe

PARAMETERS = -6 -V -T artist="@artist@" -T title="@title@" -T album="@album@" -T date="@year@" -T tracknumber="@track@" -T genre="@genre@" -T comment="EAC (Secure Mode)" "@source@" --replay-gain

ONLYIFLAST = FALSE

EOF
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 9 2006, 10:36
Post #43





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



You're not, by chance, using MAREO 3.0 Beta with the new mareo.ini structure of MAREO 3.0 Final, right...?
I haven't tested anything, but if I come across a successful setup of FLAC and LAME, I'll post here.
Go to the top of the page
+Quote Post
Larry
post Mar 9 2006, 15:10
Post #44





Group: Members
Posts: 4
Joined: 9-March 06
Member No.: 28357



Downloaded it earlier this week.

I believe it's the final version of 3.0
Go to the top of the page
+Quote Post
goodlookin
post Mar 9 2006, 20:41
Post #45





Group: Members
Posts: 24
Joined: 20-February 06
Member No.: 27923



I'm using EAC & MAREO 3 to encode to FLAC for lossless, LAME Mp3, and iTunes ACC/m4a. Here are my settings -- hope this helps!

Note: Be sure you are using the "MP3" button to start EAC encoding rather than the "WAV" button.



In EAC/Compression Options/External Compression:

Set the "Parameter passing scheme:" to: User Defined Encoder
Set the "Use file extension:" to the first encoder extension used in your MAREO.ini file (ie .flac)
Set the "Program, including path, used for compression" to your Mareo.exe path.
Set the "Additional command line options:" (I use these options): Mareo.ini %s %d "%a" "%g" "%t" "%n" %y "%m" "%c"
Add ID3 tag: unchecked
Delete WAV after compression: unchecked

Here's my MAREO.ini file:
CODE
MAREO.ini file:  I'm encoding to FLAC for lossless, LAME Mp3, and iTunes ACC/m4a, but if you don't want the iTunes files, just begin each line in that section with semi-colens.


; MAREO.ini (Ver 3) (My Mareo.ini Version) --- (M)ultiple (A)pplications (R)unner for (E)AC and (O)thers.
;Using MAREO 3, FLAC 1.1.2a & LAME 3.97b2, and iTunesEncode

; Literal           From             Replacing Value
; @source@          Parameter # 2    FULL temporal Source File Name
; @dest@            Parameter # 3    FULL temporal Destination File Name
; @artist@          Parameter # 4    CD Artist Name
; @album@           Parameter # 5    CD Name
; @title@           Parameter # 6    Track (Song) Name
; @track@           Parameter # 7    Track (song) Number
; @year@            Parameter # 8    Year of the CD release
; @genre@           Parameter # 9    CD's Music Genre
; @1@ .. @nn@       Parameter # 10+  User Definenable

; @ownpath@         MAREO finds out  the full path to MAREO, without the the ending backslash
; @finalfullname@   MAREO finds out  the final full name of the encoded file.
; @finalpathonly@   MAREO finds out  the final path to where the encode file will end
; @finalnameonly@   MAREO finds out  the final name only of the encoded file (with NO extension)
; @tmpfullname@     MAREO finds out  the full temporal name with the encoder extension
; @tmppathonly@     MAREO finds out  the full temporal path, without the ending backslash
; @tmpnameonly@     MAREO finds out  the temporal name (with NO extension)
; @newext@          MAREO finds out  the file extension without the dot (ex: MP3)

; -----------------------------------------------------------------------------------
; DOES MAREO NEEDS TO LOG TO THE SCREEN?
; -----------------------------------------------------------------------------------
LogToScreen = TRUE

; -----------------------------------------------------------------------------------
; DOES MAREO NEEDS TO LOG TO A TXT FILE?
; -----------------------------------------------------------------------------------
LogToFile = TRUE

; -----------------------------------------------------------------------------------
; MAREO RENAMES THE FIRST ENCODED FILE (TRUE) OR THE CD RIPPER DOES (FALSE)?
; -----------------------------------------------------------------------------------
RenameFirstFile = TRUE

; -----------------------------------------------------------------------------------
; DOES MAREO DELETES THE WAV FILE AFTER ENCODING (TRUE) OR THE CD RIPPER DOES (FALSE)?
; -----------------------------------------------------------------------------------
DeleteWavFile = TRUE


; ====================================================================================
; LOSSLESS ENCODERS
; ====================================================================================

; ------------------------------------------------------------------------------------
; FLAC: most supported lossless encoder: http://www.rarewares.org/lossless.html
; ------------------------------------------------------------------------------------
FULLNAME = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\1 Songs-FLAC\ @title@.flac
ENCODER = C:\Program Files\Audio Conv Progs\Flac\Flac.exe
PARAMETERS = -5 "@source@" -o "@dest@" -T artist="@artist@" -T album="@album@" -T title="@title@" -T tracknumber="@track@" -T date="@year@" -T genre="@genre@" -T COMMENT="FLAC"
ONLYIFLAST = FALSE

------------------------------------------------------------------------------------
; Apple Lossless (w/iTunesEncode): http://www.rarewares.org/aac.html
; ------------------------------------------------------------------------------------
; FULLNAME = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\3 Songs-iTEncode-Lossless\ @title@.m4a
; ENCODER = C:\Program Files\Audio Conv Progs\ITunesEncode\ItunesEncode.exe
; PARAMETERS = -d -e "Lossless Encoder" -a "@artist@" -l "@album@" -t "@title@" -n @track@ -y "@year@" -g "@genre@" -c "Lossless-iTunesEncode" -i "@source@" -o "@dest@"
; ONLYIFLAST = FALSE

; ===================================================================================
; LOSSY ENCODERS
; ===================================================================================

; -----------------------------------------------------------------------------------
; MP3 LAME: best MP3 encoder: http://www.rarewares.org/mp3.html
; -----------------------------------------------------------------------------------
FULLNAME = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\2 Songs-LAME-mp3\ @title@.mp3
ENCODER = C:\Program Files\Audio Conv Progs\Lame\lame.exe
PARAMETERS = -V2 --vbr-new --add-id3v2 --pad-id3v2 --ignore-tag-errors --ta "@artist@" --tl "@album@" --tt "@title@" --tn "@track@" --ty "@year@" --tg "@genre@" --tc "MP3-LAME" "@source@" "@dest@"
ONLYIFLAST = FALSE

; ------------------------------------------------------------------------------------
; AAC/MP4 iTunes (w/iTunesEncode) -- files in Songs Dir only (does not leave a copy in iTunes)
; ------------------------------------------------------------------------------------
; FULLNAME = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC\ @title@.m4a
; ENCODER = C:\Program Files\Audio Conv Progs\ITunesEncode\ItunesEncode.exe
; PARAMETERS = -d -e "AAC Encoder" -a "@artist@" -l "@album@" -t "@title@" -n @track@ -y "@year@" -g "@genre@" -c "AAC-iTunesEncode" -i "@source@" -o "@dest@"
; ONLYIFLAST = FALSE

; ------------------------------------------------------------------------------------
; AAC/MP4 iTunes (w/iTunesEncode) -- files in BOTH Songs & iTunes folders
; ------------------------------------------------------------------------------------
FULLNAME = D:\Data\My Documents\3-1 My Music\0-0 Songs-MAREO\4 Songs-iTEncode-ACC\ @title@.m4a
ENCODER = C:\Program Files\Audio Conv Progs\ITunesEncode\ItunesEncode.exe
PARAMETERS = -e "AAC Encoder" -a "@artist@" -l "@album@" -t "@title@" -n @track@ -y "@year@" -g "@genre@" -c "AAC-iTunesEncode" -i "@source@" -o "@dest@"
ONLYIFLAST = FALSE

; ------------------------------------------------------------------------------------

EOF


This post has been edited by goodlookin: Mar 9 2006, 20:45
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 10 2006, 13:18
Post #46





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



Bug Found

See if you guys could reproduce this error I had.
Apparently, MAREO 3.0 couldn't properly create a directory with a few periods in its name.
Please note that this isn't the case with an older version I also used, MAREO 2.1.2.

This is from my mareo.ini :

CODE
LogToScreen = TRUE
LogToFile = TRUE
RenameFirstFile = TRUE
DeleteWavFile = TRUE

;====
;LAME
;====
FULLNAME = D:\My Music\MP3\@artist@ - @album@\@track@ - @title@.mp3
ENCODER = C:\encoders\lame.exe
PARAMETERS = -V2 --vbr-new -Y --ignore-tag-errors --ta "@artist@" --tl "@album@" --tt "@title@" --tn "@track@" --ty "@year@" --tg "@genre@" "@source@" "@dest@"
ONLYIFLAST = FALSE

;======
;Lancer
;======
FULLNAME = D:\My Music\Vorbis\@artist@ - @album@\@track@ - @title@.ogg
ENCODER = C:\encoders\oggenc2.exe
PARAMETERS = -q 4 "@source@" -o "@dest@" -a "@artist@" -l "@album@" -t "@title@" -N "@track@" -d "@year@" -G "@genre@"
ONLYIFLAST = FALSE

FULLNAME = NONE
ENCODER = C:\encoders\vorbisgain.exe
PARAMETERS = "D:\My Music\Vorbis\@artist@ - @album@\@track@ - @title@.ogg"
ONLYIFLAST = FALSE

;====
;FLAC
;====
FULLNAME = D:\My Music\FLAC\@artist@ - @album@\@track@ - @title@.flac
ENCODER = C:\encoders\flac.exe
PARAMETERS = -5 "@source@" -o "@dest@" -T artist="@artist@" -T album="@album@" -T title="@title@" -T tracknumber="@track@" -T date="@year@" -T genre="@genre@"
ONLYIFLAST = FALSE

With this mareo.ini, I ripped 'Craig David - The Story Goes...' CD; please note the trailing periods.
Ripping one track, I was greeted with an error message.
Apparently, vorbisgain didn't work, said it couldn't find the file to be processed.

Looking at the mareo.log, I was kinda surprised.
Please note that I only include the important part of the log.

CODE
*** PROCESSING ENCODER ORDER # 1 ***

FINAL Full Name = D:\My Music\MP3\Craig David - The Story Goes..\01 - All The Way.mp3
FINAL Path Only = D:\My Music\MP3\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\MP3\Craig David - The Story Goes.." does NOT exists, creating ... SUCCESS!!

RENAMING: D:\eac_wavs\0tmp!58)5.mp3 => D:\My Music\MP3\Craig David - The Story Goes.\01 - All The Way.mp3 ... SUCCESS!!


*** PROCESSING ENCODER ORDER # 2 ***

FINAL Full Name = D:\My Music\Vorbis\Craig David - The Story Goes..\01 - All The Way.ogg
FINAL Path Only = D:\My Music\Vorbis\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\Vorbis\Craig David - The Story Goes.." does NOT exists, creating ... SUCCESS!!

RENAMING: D:\eac_wavs\0tmp!58)5.ogg => D:\My Music\Vorbis\Craig David - The Story Goes.\01 - All The Way.ogg ... SUCCESS!!


*** PROCESSING ENCODER ORDER # 3 ***

EXECUTING: C:\encoders\vorbisgain.exe "D:\My Music\Vorbis\Craig David - The Story Goes...\01 - All The Way.ogg" ... EXECUTION **ERROR**


*** PROCESSING ENCODER ORDER # 4 ***

FINAL Full Name = D:\My Music\FLAC\Craig David - The Story Goes..\01 - All The Way.flac
FINAL Path Only = D:\My Music\FLAC\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\FLAC\Craig David - The Story Goes.." does NOT exists, creating ... SUCCESS!!

RENAMING: D:\eac_wavs\0tmp!58)5.flac => D:\My Music\FLAC\Craig David - The Story Goes.\01 - All The Way.flac ... SUCCESS!!

So, is it just a case where MAREO ends up omitting some periods?
Wrong.

Here's the mareo.log after I run a second rip of the same disc of the same track.
Note that this time I had four errors and that I didn't delete the resulting files and directories from the first run.

CODE
*** PROCESSING ENCODER ORDER # 1 ***

FINAL Full Name = D:\My Music\MP3\Craig David - The Story Goes..\01 - All The Way.mp3
FINAL Path Only = D:\My Music\MP3\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\MP3\Craig David - The Story Goes.." allready exists.

RENAMING: D:\eac_wavs\0tmp!)!3!.mp3 => D:\My Music\MP3\Craig David - The Story Goes.\01 - All The Way.mp3 ... **ERROR**


*** PROCESSING ENCODER ORDER # 2 ***

FINAL Full Name = D:\My Music\Vorbis\Craig David - The Story Goes..\01 - All The Way.ogg
FINAL Path Only = D:\My Music\Vorbis\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\Vorbis\Craig David - The Story Goes.." allready exists.

RENAMING: D:\eac_wavs\0tmp!)!3!.ogg => D:\My Music\Vorbis\Craig David - The Story Goes.\01 - All The Way.ogg ... **ERROR**


*** PROCESSING ENCODER ORDER # 3 ***

EXECUTING: C:\encoders\vorbisgain.exe "D:\My Music\Vorbis\Craig David - The Story Goes...\01 - All The Way.ogg" ... EXECUTION **ERROR**


*** PROCESSING ENCODER ORDER # 4 ***

FINAL Full Name = D:\My Music\FLAC\Craig David - The Story Goes..\01 - All The Way.flac
FINAL Path Only = D:\My Music\FLAC\Craig David - The Story Goes..
FINAL Name Only = 01 - All The Way

DIRECTORY "D:\My Music\FLAC\Craig David - The Story Goes.." allready exists.

RENAMING: D:\eac_wavs\0tmp!)!3!.flac => D:\My Music\FLAC\Craig David - The Story Goes.\01 - All The Way.flac ... **ERROR**

The strange thing from this log is that MAREO knew a directory existed, but it didn't delete the file inside (which is MAREO's behaviour should it find a file with the same name and directory as @finalfullname@).
Instead, it only tried to make a new one, but strangely failed.

When I looked into the directory which MAREO created from the first run, guess what...
Here's the directory for LAME encoded 'Craig David - The Story Goes...'.

D:\My Music\MP3\Craig David - The Story Goes\

Yes, there's no trailing period there.
The same goes for the Vorbis and FLAC encodes.

It seems that when MAREO printed this in the log :

CODE
DIRECTORY "D:\My Music\MP3\Craig David - The Story Goes.." allready exists.

It actually referred to D:\My Music\MP3\Craig David - The Story Goes\ but it attempted to delete D:\My Music\MP3\Craig David - The Story Goes..\01 - All The Way.mp3, which didn't exist (and thus deletion failed but no notice or warning), and attempted to put 01 - All The Way.mp3 into D:\My Music\MP3\Craig David - The Story Goes.\, which actually referred to D:\My Music\MP3\Craig David - The Story Goes\ instead (read the first mareo.log and you'll understand why I think this was the case, and not because D:\My Music\MP3\Craig David - The Story Goes.\ wasn't there), and failed since there existed the same file and MAREO actually couldn't overwrite it, thus the error ensued.

I hope kwanbis will come back sooner and address this issue properly... =/

This post has been edited by sh1leshk4: Mar 10 2006, 13:21
Go to the top of the page
+Quote Post
Larry
post Mar 10 2006, 15:23
Post #47





Group: Members
Posts: 4
Joined: 9-March 06
Member No.: 28357



Got MAREO 3.0 working.

The problems and solutions...

MAREO wasn't executing because I had "EAC Options" - "Tools" - "Do not open external compressor window" checked, and at the same time had "LogToScreen = TRUE" in the mareo.ini file. Once I changed this value to "FALSE", MAREO started to execute. Things got better, but not entirely correct.

The mareo log file showed that everything worked 100% without any errors. However, my first file generated (the mp3 one) didn't exist even though the log file said it did. I went back and changed the mareo.ini file entry:

RenameFirstFile = TRUE to
RenameFirstFile = FALSE

This lets EAC rename the first file converted. Eureka! It now works.
Edit/Delete Message
Go to the top of the page
+Quote Post
kwanbis
post Mar 11 2006, 12:18
Post #48





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



QUOTE (awnm @ Mar 6 2006, 09:47 PM)
QUOTE (goodlookin @ Mar 6 2006, 03:49 PM)
Per iTunesEncode, if you don't specify an output file (which, I thought was the @dest@ file), then iTunes only leaves a copy of the file in the iTunes Library.  However, MAREO errors out if it doesn't see a @dest@ file

I'm trying to accomplish the same thing - leaving the file in the iTunes managed library, and not creating another file - via Foobar's Convertor (see question here). It seems that the various apps (MAREO, Foobar) all expect an output file and fail if there isn't one - despite it being a valid iTunesEncode command line.


have you tried using the "FULLNAME = NONE" option? (its 8am, just got from a 19 hours trip, so maybe i'm wrong)


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
kwanbis
post Mar 11 2006, 12:22
Post #49





Group: Developer (Donating)
Posts: 2362
Joined: 28-June 02
From: Argentina
Member No.: 2425



didn't expected so many complains wink.gif ... i would try to take a quick look tomorrow at whats not already fixed. biggrin.gif


--------------------
MAREO: http://www.webearce.com.ar
Go to the top of the page
+Quote Post
sh1leshk4
post Mar 11 2006, 12:31
Post #50





Group: Members
Posts: 403
Joined: 2-October 04
Member No.: 17436



No-no, not 'complaints', they're 'bug reports'.
Since this is the only way we can support software devs aside from monetary issues... =b

Welcome back, btw. =)
Where have you been to?

This post has been edited by sh1leshk4: Mar 11 2006, 12:32
Go to the top of the page
+Quote Post

9 Pages V  < 1 2 3 4 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 22:29