IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
New spam measures at the wiki, read if you get blocked
Jan S.
post Dec 19 2005, 11:49
Post #1





Group: Admin
Posts: 2549
Joined: 26-September 01
From: Denmark
Member No.: 21



I just installed some software for the wiki which should help combat the spammers that have hit us hard in recent weeks.
This could potentially also block normal users though that shouldn't happen. If you get blocked at the wiki post here and I'll look into it.
Go to the top of the page
+Quote Post
Frank Bicking
post Dec 19 2005, 22:28
Post #2





Group: Super Moderator
Posts: 1830
Joined: 24-July 02
From: Berlin, Germany
Member No.: 2776



I'm getting blocked and only see the "Precondition Failed" message.

It happens with Opera 9.0p1, Firefox 1.5, and Internet Explorer 6.0. I'm not behind a firewall (neither personal nor hardware), router, or proxy.

Can I provide you with any further information?
Go to the top of the page
+Quote Post
Garf
post Dec 19 2005, 22:42
Post #3


Server Admin


Group: Admin
Posts: 4884
Joined: 24-September 01
Member No.: 13



Seems a bug in Opera was the cause, causing you to get IPbanned (which prevented the other browsers from fixing it).
Go to the top of the page
+Quote Post
Frank Bicking
post Dec 19 2005, 22:46
Post #4





Group: Super Moderator
Posts: 1830
Joined: 24-July 02
From: Berlin, Germany
Member No.: 2776



Thanks for your fast response.

Any idea about how to fix this? (apart from switching to Firefox which I don't intend do)
Go to the top of the page
+Quote Post
Garf
post Dec 19 2005, 22:48
Post #5


Server Admin


Group: Admin
Posts: 4884
Joined: 24-September 01
Member No.: 13



Will work around this issue on our side.
Go to the top of the page
+Quote Post
Jan S.
post Dec 19 2005, 22:54
Post #6





Group: Admin
Posts: 2549
Joined: 26-September 01
From: Denmark
Member No.: 21



Try now please.
Go to the top of the page
+Quote Post
Frank Bicking
post Dec 20 2005, 01:28
Post #7





Group: Super Moderator
Posts: 1830
Joined: 24-July 02
From: Berlin, Germany
Member No.: 2776



It works now.

Good job, thanks smile.gif
Go to the top of the page
+Quote Post
rutra80
post Dec 20 2005, 03:44
Post #8





Group: Members (Donating)
Posts: 810
Joined: 12-September 03
Member No.: 8821



QUOTE (Garf @ Dec 19 2005, 11:42 PM)
Seems a bug in Opera was the cause
*

Is Opera dev team aware of that bug? If not, could you please report it to them or write some details here or on PM so I can report it?

This post has been edited by rutra80: Dec 20 2005, 03:45
Go to the top of the page
+Quote Post
Jan S.
post Dec 20 2005, 07:40
Post #9





Group: Admin
Posts: 2549
Joined: 26-September 01
From: Denmark
Member No.: 21



QUOTE (rutra80 @ Dec 20 2005, 03:44 AM)
QUOTE (Garf @ Dec 19 2005, 11:42 PM)
Seems a bug in Opera was the cause
*

Is Opera dev team aware of that bug? If not, could you please report it to them or write some details here or on PM so I can report it?
*


Header 'TE' present but TE not specified in 'Connection' header
Go to the top of the page
+Quote Post
rutra80
post Dec 21 2005, 07:28
Post #10





Group: Members (Donating)
Posts: 810
Joined: 12-September 03
Member No.: 8821



Reported.
I got the following reply from one of the Opera devs:
QUOTE
AFAICT, Opera 9 (as well as v4-v8) always sends TE in the Connection 
header.

Do you know if the user you refer to was using a proxy?

It could be that the proxy replaced the Connection header with it's own 
Connection header, without taking into account the other headers named in 
it, and forwarded all the other headers. Opera is AFAIK one of the few 
clients that uses the TE header (Neither Mozilla nor MSIE 6 does)

I replied that the user is not behind proxy nor router nor firewall (that's what Frank_Bicking said). I also gave a link to this thread, it seems that more details would be useful...

This post has been edited by rutra80: Dec 21 2005, 07:29
Go to the top of the page
+Quote Post
Garf
post Dec 21 2005, 10:48
Post #11


Server Admin


Group: Admin
Posts: 4884
Joined: 24-September 01
Member No.: 13



If it's any help, in the docs of the anti-spam software it is claimed that this is a bug in Opera 8.01 and that it was fixed in 8.02.
Go to the top of the page
+Quote Post
rutra80
post Dec 21 2005, 14:21
Post #12





Group: Members (Donating)
Posts: 810
Joined: 12-September 03
Member No.: 8821



Hmm, then with Opera 9.0p1, which Frank used, there shouldn't be a problem.

This post has been edited by rutra80: Dec 21 2005, 14:21
Go to the top of the page
+Quote Post
Andavari
post Jan 7 2006, 11:15
Post #13





Group: Members
Posts: 935
Joined: 3-June 02
From: USA
Member No.: 2204



I'm using WinXP with the Windows Firewall and I get the "Precondition Failure" page rather I enable or disable my proxy filtering software CookieCop. I can't follow any links posted in threads, etc., that go to the wiki.

I'm blocked using the following browsers:
Opera 8.51 (with proxy enabled)
Mozilla Suite v1.7.12 (with proxy enabled, and disabled)
Internet Explorer 6 SP2 (proxy disabled)

I don't know if this is of any use, however with CookieCop v2.2 (the last free version) enabled it sticks this into the beginning of pages (.htm):
CODE
<script language="JavaScript" type="text/javascript">
<!-- hide

function CCop_errorsuppressor(){return true;}
window.onerror=CCop_errorsuppressor;

var ccAllowPopup = 0;
var ccTimer = 0;
var ccNetscape = 0;
var CCop_WindowOpen=window.open;

window.open=CCop;

if( navigator.appName == 'Netscape' )
{
    ccNetscape = 1;
    document.captureEvents(Event.MOUSEDOWN);
}

function CCop_keypress( e  )
{
    if( ccNetscape )
    {
 if( parseFloat( navigator.appVersion )>=5.0 )
 {
     if( e.altKey || e.ctrlKey )
   ccAllowPopup = 1;    
 } else {
     if( (e.modifiers & Event.ALT_MASK) || (e.modifiers & Event.CONTROL_MASK) )
   ccAllowPopup = 1;    
 }

    } else {
 if( window.event.ctrlKey || window.event.altKey )
     ccAllowPopup = 1;
    }
}

function CCop_NoUnload( ){};
function CCop_OnUnload( )
{
    window.onunload=CCop_NoUnload;
    window.onbeforeunload=CCop_NoUnload;
}


function CCop_Reset( )
{
    ccAllowPopup = 0;
    window.clearTimeout( ccTimer );
}

function CCop_mousedown( )
{
    ccAllowPopup = 1;
    ccTimer = window.setTimeout("CCop_Reset()",1000);
    return true;
}

document.onkeydown = CCop_keypress;
document.onmousedown = CCop_mousedown;

function CCop( href, windowname, features, replace )
{
    if( ccAllowPopup == 1 )
    {
 ccAllowPopup = 0;
 if( features )
     return( CCop_WindowOpen(href, windowname, features, replace) );

 return( CCop_WindowOpen(href, windowname) );
    }

    window.status= "Pop-up blocked (CTRL + click to override): " + href;

    if( ccNetscape == 0 )
    {
 //do not modify the line below
   
    }
    return null;
} //-->
</script>

Edit: I'm using Opera 8.51, but I typed in 8.50.

This post has been edited by Andavari: Jan 7 2006, 11:18


--------------------
Complexity of incoherent design.
Go to the top of the page
+Quote Post
Jan S.
post Jan 7 2006, 11:45
Post #14





Group: Admin
Posts: 2549
Joined: 26-September 01
From: Denmark
Member No.: 21



You were banned as it sees you as proxy. It should work again now but it will ban you again if you use proxy again.
Go to the top of the page
+Quote Post
Andavari
post Jan 7 2006, 16:13
Post #15





Group: Members
Posts: 935
Joined: 3-June 02
From: USA
Member No.: 2204



QUOTE (Jan S. @ Jan 7 2006, 04:45 AM)
It should work again now but it will ban you again if you use proxy again.
*

Honestly it doesn't matter then, I just won't use the wiki.


--------------------
Complexity of incoherent design.
Go to the top of the page
+Quote Post
Andavari
post Jan 7 2006, 23:27
Post #16





Group: Members
Posts: 935
Joined: 3-June 02
From: USA
Member No.: 2204



The solution is really simple.

If anyone is using an adblocking/filtering program that is setup in a browser as a proxy server input the following into the network settings under "Do not use proxy server for..." or something similiar to that description:
wiki.hydrogenaudio.org


--------------------
Complexity of incoherent design.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 12:24