IPB

Welcome Guest ( Log In | Register )

16 Pages V  « < 14 15 16  
Reply to this topicStart new topic
WMPTSE, WMP plug-in allows extended tag support
MaB_fr
post Mar 7 2007, 16:42
Post #376





Group: Members
Posts: 196
Joined: 30-October 05
Member No.: 25458



QUOTE (tempnegro @ Mar 7 2007, 05:46) *
Ohmygosh! a temporary negro hath found the (temporary) solution to the flac seeking bug

Using Illuminable's latest beta, I discovered accidently that if you have the flac files in an .m3u (no matter what #ext format or just simple listing) seeking actually WORKS AS INTENDED. Why this is I have no clue, and just proves more of microsofts lack of understanding

but yea, start making playlists if you want to seek in WMP11 biggrin.gif



I already knew this trick...

The fact is, your playlist must be tiny for this "hack" to work.

Don't hope to make it work with more than 20 tracks in the playlist...

It's just an "emergency" workaround for me...not a usable one.


But good try though smile.gif


MaB_fr
Go to the top of the page
+Quote Post
man
post Apr 3 2007, 14:48
Post #377





Group: Members
Posts: 51
Joined: 16-April 03
From: Paris
Member No.: 6007



Hi There,

I was impressed by the new Media Center coming with Vista, especially from ergonomic point of view.

Because WMPTSE exists, I then decided to give it a try.
The result is really great, all my 10k WavPack files have been loaded successfully.
Merci beaucoup MaB_fr smile.gif !

The few pbs I face were mentionned previously in this threat :
- Seeking does not work huh.gif ,
- %year% tag is not considered (so sad, Vista MC has a view based on Year),
- The loading phase took quite some time.

A small question : for Album Artists tags, should I tag %Album Artist% or %AlbumArtist% or something else ? I'm using foobar for Tags management.

Edit : typo

This post has been edited by man: Apr 3 2007, 14:49
Go to the top of the page
+Quote Post
man
post Apr 5 2007, 10:46
Post #378





Group: Members
Posts: 51
Joined: 16-April 03
From: Paris
Member No.: 6007



QUOTE (man @ Apr 3 2007, 05:48) *
A small question : for Album Artists tags, should I tag %Album Artist% or %AlbumArtist% or something else ? I'm using foobar for Tags management.


OK, I found the answer from the present topic, p.5 :

QUOTE (MaB_fr @ Jan 25 2006, 19:54) *
(...)
On a second note, i, once and for all, will expose here the standard i rely on for the tagging politics :

---- For every APEv2 tagged files (wavpack, monkey audio, etc...) -----
The correspondances are :
APETag => WMP Entry

"Title" => Title
"Subtitle" => WM/Subtitle
"Artist" => Author
"Album" => WM/AlbumTitle
"AlbumArtist" => WM/AlbumArtist
"Publisher" => WM/Publisher
"Conductor" => WM/Conductor
"Composer" => WM/Composer
"Comment" => MoreInfo
"Year" => WM/Year
"Track" => WM/TrackNumber
"Genre" => WM/Genre
"Lyrics" => WM/Lyrics
"Copyright" => Copyright
"Publicationright" => WM/Publisher
"ISRC" => WM/MCDI
"Buy URL" = > BuyNow
"Publisher URL" => ProviderURL


---- For every FLAC tagged files -----
The correspondances are :
FLACTag => WMP Entry

"TITLE" => Title
"ALBUMARTIST" => WM/AlbumArtist
"ALBUM" => WM/AlbumTitle
"TRACKNUMBER" => WM/TrackNumber
"ARTIST" => Author
"PERFORMER" => WM/AlbumArtist
"COPYRIGHT" => Copyright
"ORGANIZATION" => WM/Publisher
"DESCRIPTION" => MoreInfo
"GENRE" => WM/Genre
"LOCATION" => ProviderURL
"ISRC" => WM/MCDI
"YEAR" => WM/Year
"COMPOSER" => WM/Composer
"CONDUCTOR" => WM/Conductor
"PUBLISHER" => WM/Publisher


---- For every Vorbis tagged files -----
The correspondances are :
Vorbis tag => WMP Entry

"TITLE" => Title
"ALBUMARTIST" => WM/AlbumArtist
"ALBUM" => WM/AlbumTitle
"TRACKNUMBER" => WM/TrackNumber
"ARTIST" => Author
"PERFORMER" => WM/AlbumArtist
"COPYRIGHT" => Copyright
"ORGANIZATION" => WM/Publisher
"DESCRIPTION" => MoreInfo
"GENRE" => WM/Genre
"LOCATION" => ProviderURL
"ISRC" => WM/MCDI
"YEAR" => WM/Year

I used the doc available on the net...If someone found any mistake or wants some modification (it will be argumented then), you're free to try smile.gif

Until further notice, these standards are CASE-SENSITIVE (as all format documentation want it to be).
Which means that non-standard formatting of tag name (like "album" for every file, or "Album" for vorbis tagged files) are NOT handled !

It may enlights some problems....

MaB_fr


Could be usefull to put it on Wiki wink.gif
Go to the top of the page
+Quote Post
MaB_fr
post Apr 13 2007, 19:39
Post #379





Group: Members
Posts: 196
Joined: 30-October 05
Member No.: 25458



QUOTE
Could be usefull to put it on Wiki wink.gif


Right, will do it as soon as i have a home internet connexion (j've just emigrated from france to canada, so i'm kind of messy right now).

Just wait a bit.

MaB_fr
Go to the top of the page
+Quote Post
ruediger05
post Apr 14 2007, 19:57
Post #380





Group: Members
Posts: 4
Joined: 10-January 06
Member No.: 27008



Mysterious...

I take the same file (ogg vorbis) and play it in WMP11 on two different PCs. My oggcodecs from illminable got the same version number. One PC runs XP pro SP2 with WMPTSE 1.2. Another runs Vista and I downloaded the 1.4 of WMPTSE. With the 1st PC everything is fine, but the latter only recognises the TITLE and the GENRE tag. Therefore I uninstalled WMPTSE and installed the 1.2 but this didn't solve the problem. What is the matter?
Go to the top of the page
+Quote Post
MaB_fr
post Apr 15 2007, 22:04
Post #381





Group: Members
Posts: 196
Joined: 30-October 05
Member No.: 25458



QUOTE (ruediger05 @ Apr 14 2007, 19:57) *
Mysterious...

I take the same file (ogg vorbis) and play it in WMP11 on two different PCs. My oggcodecs from illminable got the same version number. One PC runs XP pro SP2 with WMPTSE 1.2. Another runs Vista and I downloaded the 1.4 of WMPTSE. With the 1st PC everything is fine, but the latter only recognises the TITLE and the GENRE tag. Therefore I uninstalled WMPTSE and installed the 1.2 but this didn't solve the problem. What is the matter?



I would say Vista...I may be biased though (i don't own Vista and don't want to).


Ogg & Vista users, any simillar behaviour ?

MaB_fr
Go to the top of the page
+Quote Post
Mangix
post Apr 15 2007, 22:10
Post #382





Group: Members
Posts: 587
Joined: 26-February 06
Member No.: 28077



i have a question. why doesn't WMPTSE find the "Date" tag on my WavPack files? I have the tag on the file but WMPTSE doesn't display it. foobar2000 displays it just fine.
Go to the top of the page
+Quote Post
MaB_fr
post Apr 17 2007, 22:02
Post #383





Group: Members
Posts: 196
Joined: 30-October 05
Member No.: 25458



QUOTE (Mangix @ Apr 15 2007, 22:10) *
i have a question. why doesn't WMPTSE find the "Date" tag on my WavPack files? I have the tag on the file but WMPTSE doesn't display it. foobar2000 displays it just fine.


As you can see in WMPTSE source code, it does handle date...

The only problem with WMP11 is that WM/Year seems to be a read only tag...

I'm always trying to figure how to workaround this.

The problem is specific to WMP11, and i very much like to know why...

If i get some sort of answer or a solution, you'll hear me screaming "eureka" on this forum...

MaB_fr
Go to the top of the page
+Quote Post
Trix
post May 19 2007, 02:09
Post #384





Group: Members
Posts: 1
Joined: 19-May 07
Member No.: 43584



I'm using Windows Vista 32bit, and trying to get .ogg to show up my library. Using WMPTSE, .ogg files still do not show up in my library. They play fine in WMP. I am using CCCP in order to play the files. Does the codec matter? I believe that pack uses ffdshow to play the files. In anycase, any help in getting WMP 11 to index my .ogg files would be greatly appreciated.
Go to the top of the page
+Quote Post
strahler
post Jun 11 2007, 22:22
Post #385





Group: Members
Posts: 6
Joined: 13-October 06
Member No.: 36315



I can play and seek in flac file in wmp11 on a win XP sp2 but I can not change or even view the tags in flac files.. I have WMPTSE installed and all but it still doenst work.. very sad because WMP11 would be really good if this would work.. anybody experienceing the same problems? dunno what to do 0o
Go to the top of the page
+Quote Post
man
post Jun 24 2007, 21:56
Post #386





Group: Members
Posts: 51
Joined: 16-April 03
From: Paris
Member No.: 6007



Hi there,

3 little points:

1. I'm using Vista Media Center & WMP 11. By using WMPTSE, all my 11k WavPack files are recognized, except 44 of them. I noticed they all include a question mark '?' in the title. Seems to be a bug.

2. I recently discovered a similar plug-in then WMPTSE, "Tag Support Plugin for Media Player 1.1", see link hereunder. Any link between them ? Amazing point: This plug-in also have problem with Dates & Tracklenght.
link

3. I red in some previous posts of this threat that you may produce a specific version for WMP11. Is this still planned ?

Thanx again for this nice plug-in.

This post has been edited by man: Jun 24 2007, 21:57
Go to the top of the page
+Quote Post
demkun
post Jun 25 2007, 09:51
Post #387





Group: Members
Posts: 17
Joined: 18-January 07
Member No.: 39780



I'm afraid I've got nowhere with this plugin sad.gif
Did everything as per guide, think I used version 1.2. Got half of my flacs recognised by WMP11/MCE, but then WMP crashed. Have done a clean reinstall of everything, including different versions of this plugin, WMP can play now play flacs, but nothing is recognised in media library, hence nothing on MCE.

I've read all the guides and forum here and on WMPlugins.com, but have got nowhere. Will try again later, maybe withthe plugin referred to above, but any tips would be appreciated. Using Vista Ultimate, 32 bit, up to date.
If I still can't get it going, I'll convert my flacs to mp3, but would rather not for the work involved - am sure that my mp3s would be transparent to me anyway.

This post has been edited by demkun: Jun 25 2007, 09:58
Go to the top of the page
+Quote Post
MaB_fr
post Jul 8 2007, 03:02
Post #388





Group: Members
Posts: 196
Joined: 30-October 05
Member No.: 25458



QUOTE (man @ Jun 24 2007, 21:56) *
Hi there,

3 little points:

1. I'm using Vista Media Center & WMP 11. By using WMPTSE, all my 11k WavPack files are recognized, except 44 of them. I noticed they all include a question mark '?' in the title. Seems to be a bug.

2. I recently discovered a similar plug-in then WMPTSE, "Tag Support Plugin for Media Player 1.1", see link hereunder. Any link between them ? Amazing point: This plug-in also have problem with Dates & Tracklenght.
link

3. I red in some previous posts of this threat that you may produce a specific version for WMP11. Is this still planned ?

Thanx again for this nice plug-in.


Thanks for the detailed bug report...If every one could be as such, my life would be easier...

I'll check the source for a question mark handling and let you know...

Dates are read only on WMP11...Why...i don't know...report to Microsoft, petition, or whatever could change this status...Track length is handled by the DirectShow plug-in (or supposed to...most of them do it, but it seems there's a bug in WMP11 strangely disabling this...any paranoid 'MS wrongdoing for media supremacy' there ? smile.gif)

I didn't get a huge positive feedback on a specific Vista version of WMPTSE, so it is not planned...
May be i should make a poll on HA, but i m afraid to bore the board...

The 'other' plug-in has different functionalities, some believe it uses my code...i do not care. Choose whatever suits you better.

MaB_fr
Go to the top of the page
+Quote Post
man
post Jul 10 2007, 19:56
Post #389





Group: Members
Posts: 51
Joined: 16-April 03
From: Paris
Member No.: 6007



Thx for your answer Mab. I carry on point per point tongue.gif

1. Even more precisely about my question mark pb, I think it happens when there is a space before, eg. "What do you mean ?" whereas "What do you mean?" seems working better. Not sure thought.

2. Well the 'other plug-in' is so much close to yours in its comportment, on both quality and pbs, that I would be surprised it does not use the same code basis. I was expecting an answer from you like 'yes, I did this other plug-in as well in association with blah'. On my side I will definitely stick with the original, ie. yours wink.gif . Besides, it does not handle artist/album artist propely.

3. As for the WMP11 dedicated plug-in, I tell you I would like it very much. The present scanning time is quite slow on my 11k wv files... I red previously you were not interested that much with vista. If you liked MCE, I would be surprised to see you not apreciate VMC after a serious try. I found it better on several points, starting by the music management and global ergonomy.

Oh last point: I found the tone of your last post a bit 'bored' if I may say. Please beleive your plug-in is appreciated *a lot*, and allow me to play with VMC without transcoding from wv to wma lossless (I tried -shame on me-, but the result was so bad I gave up)

This post has been edited by man: Jul 10 2007, 20:16
Go to the top of the page
+Quote Post
aragon127
post Oct 24 2007, 18:31
Post #390





Group: Members
Posts: 5
Joined: 23-March 06
Member No.: 28751



Has anyone managed to get it to work with Vista & WMP11?

I had it working fine with XP and when I upgraded to Vista it won't show FLAC files. It's pretty weird, at first it wouldn't pick up any flac files, but APE were picked up fine. So I cleared my library and reloaded it. Now a few of the FLAC files show up, but not all.

A few album art's work in WMP but none work in media center. I even used the cover art fixer program. Any suggestions?

It's a shame because the audio in Vista is a vast improvement over XP.
Go to the top of the page
+Quote Post
73ChargerFan
post Mar 29 2008, 08:01
Post #391





Group: Members
Posts: 38
Joined: 19-December 06
Member No.: 38813



MaB_fr,

Are you still developing this, and will there be a new version soon...
I'm now using madFlac with WMP11 and it seems to work well.

Always hopeful,
73ChargerFan
Go to the top of the page
+Quote Post
entrecour
post Jun 11 2008, 08:00
Post #392





Group: Members
Posts: 4
Joined: 12-September 07
Member No.: 46995



Hi MaB_fr,

I am having trouble getting WMPTSE to work under WMP11 / Vista 32. I have registered the DLL and generally followed the instrucstion found at http://www.losslessaudioblog.com/wmpmce-lossless-guide/

Are you still supporting this plug-in? This seems to be the only way to get tags read properly via WMP so it would be a great loss if it were abandoned.

Hoping you can help.
Go to the top of the page
+Quote Post
EvtK
post Feb 7 2009, 22:46
Post #393





Group: Members
Posts: 14
Joined: 7-February 09
Member No.: 66739



Hello,

I use WMP 11 in combination with flac files. I have set the options to
write to tags but It won't do. I have tested it as follow:

Media Liberary with only one album containing flac files. I search album
details from media server and I update the tags. Dan I hit the 'change
details in mediafiles' option under 'medialibrary'.

The status bar is telling me it is update and checking the files in the
library and then it is 100% done.

When I look in the folder I can see by the date and time of the files WMP
has NOT changed anything to the FLAC files.

Is there anyway to get it done? Thnx in advance!
Go to the top of the page
+Quote Post
Tim De Baets
post Oct 14 2009, 16:43
Post #394


Author of WMPCDText


Group: Developer
Posts: 393
Joined: 13-August 07
Member No.: 46161



Users who are experiencing/have experienced problems with WMPTSE might be interested to hear that I have written a similar plug-in: WMP Tag Plus. WMP Tag Plus adds MPEG4, FLAC, Vorbis and WavPack metadata support to WMP, and addresses most of the shortcomings of WMPTSE. For example, it will set the track length for files of these formats, which fixes the 'seeking bug' and makes seeking possible when playing these files from within the library. WMP Tag Plus also allows you to use the Advanced Tag Editor to edit the tags of MPEG4, FLAC, Vorbis and WavPack files.

More information at the WMP Tag Plus thread.
Go to the top of the page
+Quote Post

16 Pages V  « < 14 15 16
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th July 2014 - 08:42