IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Itunesencode, Tagging & Itunes - Help!
ultravista
post Oct 15 2005, 15:47
Post #1





Group: Members
Posts: 36
Joined: 1-August 03
Member No.: 8117



I am trying to figure out how to properly use (to my taste) itunesencode when transcoding FLAC or APE to .m4a.

For those of you familiar with Itunes, when it encounters a file without tags, or tags it doesn't understand, it writes the converted songs to "Unknown Artist" & "Unknown Album" folders in your target directory.

If the tags are understood, it writes it to "Artist" and "Album Title". Make sense?

I can't seem to get the strings right in Itunedencode.exe to have Itunes read the tags and output to the unique directory of the artists and album title?

When transcoding several albums at a time, every song gets dumped into the same directory. It makes isolating and defining 100+ songs a bitch.

Any ideas? Is this possible or am I doing something wrong?
Go to the top of the page
+Quote Post
halbatross
post Oct 31 2005, 02:01
Post #2





Group: Members
Posts: 8
Joined: 31-October 05
Member No.: 25465



At first I could not get this little gem to work based on my understanding of the included Readme.txt. But now it works awesomely, -with tags, in iTunes 6.013 even! - Using both fb2k .83 OR .9 beta10.

Not sure if this is proper but it works very well for me now.

The detailed info which follows (under ENCODER SETTINGS below) is for version .83.

For version .9 beta10 there are minor differences. There are less options to set (i.e. the output directory, which is temporary - for the wav files, is set via the playlist context menu under 'Convert'. This is specified either after you select 'Convert to...' or by selecting 'Convert to same directory').

Also different in .9 beta10, on the main page of the 'Converter' preferences (named 'Diskwriter' in version 0.83) is the 'Output file names' section which is probably irrelevant if the source files are tagged. (For me the resulting filenames were based on the tags of my flac and ogg sources, so I left this section at the default settings). Generally, I tried to mirror the .83 options for .9 and ignored (or kept the "defaults" on) any other options offered in .9 that weren't in .83.

(Please pardon the lack of screenshots.)


ENCODER SETTINGS: (note the quote marks)

Encoder: Point to iTunesEncode.exe, which I have in fb2k program folder.
Extension: wav
Parameters: -e "AAC Encoder" -a "%artist%" -l "%album%" -t "%title%"
-g "%genre%" -y %date% -n %tracknumber% -i %s -o %d

Format: Lossy
Highest BPS: 16
Tag: None

Leave next two boxes UNchecked:
('Pass floating point..', and
'encoder requires accurate length')

Display name:
iTunes encoder

Generic settings:
Check Only 'Hide console window'


THEN ON MAIN PAGE OF DISKWRITER SETTINGS:

Output directory: UNcheck both 'Always ask before writing' AND 'Same as source file directory'.
-Specify path for a Temp directory i.e. F:\Temp

Output filename formatting: Leave default (i.e. $num(%_diskwriter_index%,3)bla bla ...)

Output presets: Select 'Commandline Encoder: iTunes encoder'

Check 'Ask before writing'

Output bit depth: 16
Dither: Never

Check 'Keep lossless sources at original bitdepth'

Processing: Nothing checked in this section

Check 'Don't expand loops'

Thread priority: Optional (I left at default and it worked well)

**iTunes program must be running.
***Set iTunes import options correctly. Also I have Keep Music folder organized and
copy files to iTunes Music folder when adding to Library both checked in Advanced iTunes settings in iTunes 6.013

Let me know if u need the screenshots - I have them.
hal2000 a + warpm a i l d o+ ne t.
Go to the top of the page
+Quote Post
schnittlich
post Nov 4 2005, 02:31
Post #3





Group: Members
Posts: 72
Joined: 14-January 03
Member No.: 4575



hello - i have things setup as stated above, using foobar2000 v.83 and itunes v6.013, and am getting all of the final files in my itunes directory in a folder structure of unknown artist -> unkown album.

here is the string i am using in foobar2000:

-e "Lossless Encoder" -a "%artist%" -l "%album%" -t "%title%" -g "%genre%" -c "%comment%" -y %date% -n %tracknumber% -i %s -o %d

am i doing something wrong?

brett

This post has been edited by schnittlich: Nov 4 2005, 04:21
Go to the top of the page
+Quote Post
Otto42
post Nov 4 2005, 06:00
Post #4





Group: Members
Posts: 1075
Joined: 15-October 03
From: Memphis, TN
Member No.: 9323



QUOTE (schnittlich @ Nov 3 2005, 08:31 PM)
hello - i have things setup as stated above, using foobar2000 v.83 and itunes v6.013, and am getting all of the final files in my itunes directory in a folder structure of unknown artist -> unkown album.
*

Turn on "Keep my iTunes library organized".

When the song is first encoded in iTunes, it doesn't have any tags. So iTunes sticks it in those Unknown folders. After tagging, iTunes will move it if you have iTunes set to do so.


--------------------
http://ottodestruct.com
Go to the top of the page
+Quote Post
schnittlich
post Nov 4 2005, 06:12
Post #5





Group: Members
Posts: 72
Joined: 14-January 03
Member No.: 4575



can you tell me what the %s and %d at the end of the string mean?

-i %s -o %d

thanks,

brett
Go to the top of the page
+Quote Post
clintb
post Nov 4 2005, 06:20
Post #6





Group: Members
Posts: 182
Joined: 4-July 02
From: Sunnyvale, CA
Member No.: 2472



QUOTE (schnittlich @ Nov 3 2005, 11:12 PM)
can you tell me what the %s and %d at the end of the string mean?

-i %s -o %d

thanks,

brett
*

Both of those are variables from Foobar's Diskwriter module.
%s = temporary input file
%d = output file name

I don't know if iTunesEncode supports pipes, but if it doesn't you need the "%s". I'm using it with my config.

This post has been edited by clintb: Nov 4 2005, 06:22
Go to the top of the page
+Quote Post
schnittlich
post Nov 4 2005, 06:31
Post #7





Group: Members
Posts: 72
Joined: 14-January 03
Member No.: 4575



i have turned on both "keep itunes music folder organized" and "copy files to itunes music folder when adding to library".

but

i still get the files in a directory called unknown artist -> unknown album.

what am i doing wrong?

thanks again,

brett

This post has been edited by schnittlich: Nov 4 2005, 06:34
Go to the top of the page
+Quote Post
halbatross
post Nov 5 2005, 13:43
Post #8





Group: Members
Posts: 8
Joined: 31-October 05
Member No.: 25465



QUOTE (schnittlich @ Nov 4 2005, 01:31 AM)
i have turned on both "keep itunes music folder organized" and "copy files to itunes music folder when adding to library". 

but

i still get the files in a directory called unknown artist -> unknown album.

what am i doing wrong?

thanks again,

brett
*


What exactly are you transcoding?
Like, what is the source filename and type (ie flac,ape,mp3,etc..), and what tags does it have? But I suspect the file may be tag-less because I experienced a similar issue when I converted a classical music mp3 file which had no tags.

You can mail me a copy of the file to test, if you like. See bottom of my earlier post.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 08:30