IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3 >  
Reply to this topicStart new topic
Game Audio Decoder 1.07 released., foo_sc68.dll is now foo_game.dll
Borisz
post May 12 2006, 18:59
Post #26





Group: Members
Posts: 381
Joined: 27-September 03
Member No.: 9041



QUOTE (oshah @ May 11 2006, 21:58) *
There are no notable changes for foo_game 1.08. The new functionality planned for 1.08 split off from foo_game to become its own new plugin, foo_m1.

That plugin would be one my favorite things ever, but:
CODE
Unable to open item for playback (Unsupported file format):
"D:\Mame\FoxM1\foobar\zupapa.fm1"


I did pretty much everything according to the guide. Even extracted a blank new m1.dll setup from emuhype into the default used directory, and it still didnt work.


--------------------
http://evilboris.sonic-cult.net/346/
Sega Saturn, Shiro!
Go to the top of the page
+Quote Post
rutra80
post May 12 2006, 22:30
Post #27





Group: Members (Donating)
Posts: 810
Joined: 12-September 03
Member No.: 8821



QUOTE (oshah @ May 12 2006, 13:59) *
Rutra80, I forgot to tell you, I gave up on this plugin a couple of weeks ago. Sorry, but it doesn't look like I'm qualified to take this on. sad.gif
The first shot I had at creating an octamed plugin led to a plugin that couldn't even start. It looks like loads of work is needed to make OctaMED work in a foobar2000/VC++2005 environment.
The Octamed SDK is completely useless--it uses its own playback engine to playback MED files (how awfully nice of them </sarcasm>), which is great for programmers that don't know the difference between a WAV and PCM, but absolutely useless for Foobar2000, which needs to access the output audio.
If anyone wants to pick up where I left off, I will be more than glad to send my present sources to them.

Bah, that's bad news. Thank you for trying though.
crying.gif
Go to the top of the page
+Quote Post
oshah
post May 13 2006, 13:27
Post #28





Group: Members
Posts: 53
Joined: 24-June 05
Member No.: 22934



QUOTE (Borisz @ May 12 2006, 18:59) *
That plugin would be one my favorite things ever, but:

Unable to open item for playback (Unsupported file format):
"D:\Mame\FoxM1\foobar\zupapa.fm1"

I did pretty much everything according to the guide. Even extracted a blank new m1.dll setup from emuhype into the default used directory, and it still didnt work.


Do you have a list file for that game? If not you'll have to write an lst yourself or add song tags to the fm1 file.

CODE
<?xml version="1.0"?>
<foo_m1 version="1.0"
  xmlns="http://shexec32.serveftp.net/Files/foo_m1_v1.0.xsd">
  <RomPath>C:\Mame\Roms</RomPath>
  <GameName>zupapa</GameName>
  <song ID="0" num="34"><title>Zupapa track 34</title></song>
  <song ID="1" num="35"><title>Zupapa track 35</title></song>
  <song ID="2" num="36"><title>Zupapa track 36</title></song>
  <!-- etc. -->
</foo_m1>
Go to the top of the page
+Quote Post
Borisz
post May 14 2006, 23:29
Post #29





Group: Members
Posts: 381
Joined: 27-September 03
Member No.: 9041



Oh, with games that have existing listings, it works.

It seems that I need to move the volume slider under Normalization to get any sound though. Also, ticking normalizing on or off seems to have no effect, and whatever I set the volume sliders to, their effect will only kick in after I restart foobar.


--------------------
http://evilboris.sonic-cult.net/346/
Sega Saturn, Shiro!
Go to the top of the page
+Quote Post
oshah
post May 15 2006, 17:06
Post #30





Group: Members
Posts: 53
Joined: 24-June 05
Member No.: 22934



QUOTE (Borisz @ May 14 2006, 23:29) *
Oh, with games that have existing listings, it works.

Unfortunately, unless you have an existing listing, or can provide track information through song tags, foo_m1 will reject the file.
In a future version, I will add support for the numsongs attribute, which will save you from having to type out all those <song> nodes. But foo_m1 cannot work without having some kind of track information present.

QUOTE (Borisz @ May 14 2006, 23:29) *
It seems that I need to move the volume slider under Normalization to get any sound though. Also, ticking normalizing on or off seems to have no effect

Which version of m1.dll do you have (ie. what is its size and timestamp)? It doesn't sound like you have the same version as me.
In the 0.77 M1 release, the volume sliders are known not to work (only the normalize checkbox works), but I never encountered a situation where the normalize checkbox didn't work.

QUOTE (Borisz @ May 14 2006, 23:29) *
Whatever I set the volume sliders to, their effect will only kick in after I restart foobar.

Like in foo_game, all options are designed to take effect after you restart playback (Apart from the fadeout option, which takes effect immediately, but that's a bug).
Go to the top of the page
+Quote Post
Borisz
post May 16 2006, 13:44
Post #31





Group: Members
Posts: 381
Joined: 27-September 03
Member No.: 9041



I have the latest m1.dll.

(What I mean is that turning the normalize tickbox on/off has no effect.) <-- edit: nevermind this, it works. The music I was listening to just didn't need any normalization and thus I found no differences.


And I need to move the volume slider under Normalization away from 0 to get any sound. In fact, that slider controls the overall volume level of the plugin.

This post has been edited by Borisz: May 16 2006, 13:45


--------------------
http://evilboris.sonic-cult.net/346/
Sega Saturn, Shiro!
Go to the top of the page
+Quote Post
wangyi6854
post Oct 20 2008, 14:40
Post #32





Group: Members
Posts: 21
Joined: 6-March 05
Member No.: 20404



Hi, oshah,

Please recompile the plugin for it's not compatible with foobar2000 0.96.

Thanks very much!
Go to the top of the page
+Quote Post
deus-ex
post Oct 20 2008, 20:35
Post #33





Group: Members
Posts: 294
Joined: 9-September 04
From: Earth
Member No.: 16882



QUOTE (wangyi6854 @ Oct 20 2008, 14:40) *
Please recompile the plugin for it's not compatible with foobar2000 0.96.

Latest version 1.08 works fine here. Please verify.


--------------------
Best regards
deus-ex (MODLAND co-admin: ftp://ftp.modland.com)
Go to the top of the page
+Quote Post
kode54
post Oct 20 2008, 22:07
Post #34





Group: Admin
Posts: 4693
Joined: 15-December 02
Member No.: 4082



QUOTE (deus-ex @ Oct 20 2008, 12:35) *
QUOTE (wangyi6854 @ Oct 20 2008, 14:40) *

Please recompile the plugin for it's not compatible with foobar2000 0.96.

Latest version 1.08 works fine here. Please verify.

Maybe not under Vista?
Go to the top of the page
+Quote Post
wangyi6854
post Oct 25 2008, 13:17
Post #35





Group: Members
Posts: 21
Joined: 6-March 05
Member No.: 20404



QUOTE (kode54 @ Oct 21 2008, 05:07) *
QUOTE (deus-ex @ Oct 20 2008, 12:35) *

QUOTE (wangyi6854 @ Oct 20 2008, 14:40) *

Please recompile the plugin for it's not compatible with foobar2000 0.96.

Latest version 1.08 works fine here. Please verify.

Maybe not under Vista?


Maybe. My system is server 2008 64bit. Foobar2000 is 0.9.6 beta1. When foobar2k starts, it says
CODE
Failed to load DLL: foo_game.dll, reason: This component is not compatible with this version of Windows and needs to be recompiled with a newer version of the foobar2000 SDK; please contact the author of this component to obtain an updated version of this component.
Go to the top of the page
+Quote Post
zyrill
post Nov 19 2008, 03:09
Post #36





Group: Members
Posts: 27
Joined: 10-March 04
Member No.: 12619



could anybody upload the plugin somewhere please? all the download links are dead!
Go to the top of the page
+Quote Post
wangyi6854
post Nov 19 2008, 03:14
Post #37





Group: Members
Posts: 21
Joined: 6-March 05
Member No.: 20404



QUOTE (zyrill @ Nov 19 2008, 10:09) *
could anybody upload the plugin somewhere please? all the download links are dead!

Use a proxy. I can't access the site directly too.
Go to the top of the page
+Quote Post
jahpal
post Nov 19 2008, 04:42
Post #38





Group: Members
Posts: 233
Joined: 9-May 06
From: Orlando,Florida
Member No.: 30580



oshah i can get this plugin , somethings wrong with the page , i can`t download. THANK YOU...
Go to the top of the page
+Quote Post
deus-ex
post Nov 19 2008, 19:59
Post #39





Group: Members
Posts: 294
Joined: 9-September 04
From: Earth
Member No.: 16882



QUOTE (jahpal @ Nov 19 2008, 04:42) *
oshah i can get this plugin , somethings wrong with the page , i can`t download. THANK YOU...
It's available at MODLAND ever since of course. wink.gif

CODE
ftp://ftp.modland.com/pub/players/Windows/Foobar2000%20v0.9/input%20plugins/Foo_Game%20v1.08.rar


--------------------
Best regards
deus-ex (MODLAND co-admin: ftp://ftp.modland.com)
Go to the top of the page
+Quote Post
jahpal
post Nov 20 2008, 06:01
Post #40





Group: Members
Posts: 233
Joined: 9-May 06
From: Orlando,Florida
Member No.: 30580



i did not find it . unless i can read or dont know what im looking 4...
Go to the top of the page
+Quote Post
zyrill
post Nov 20 2008, 10:00
Post #41





Group: Members
Posts: 27
Joined: 10-March 04
Member No.: 12619



QUOTE (deus-ex @ Nov 19 2008, 10:59) *
It's available at MODLAND ever since of course. wink.gif
CODE
ftp://ftp.modland.com/pub/players/Windows/Foobar2000%20v0.9/input%20plugins/Foo_Game%20v1.08.rar

Thanks a bunch for making it available - but what is modland and how would we have known that it was available there of course? tongue.gif
Go to the top of the page
+Quote Post
deus-ex
post Nov 20 2008, 21:01
Post #42





Group: Members
Posts: 294
Joined: 9-September 04
From: Earth
Member No.: 16882



QUOTE (jahpal @ Nov 20 2008, 06:01) *
i did not find it . unless i can read or dont know what im looking 4...
Here's the very same link I posted previously. Just click on the word download, your Browser should handle it from there for you.

Foo_Game v1.08: download

QUOTE (zyrill @ Nov 20 2008, 10:00) *
Thanks a bunch for making it available - but what is modland and how would we have known that it was available there of course? tongue.gif

If you'd browse the path of the download link I posted upward a bit you'd eventually find this:

CODE
      __  ___               __ __                      __
    //  \/   \             |  |  |  .: welcome to :.  |  |
   |          |  _____   __|  |  |  _____   _____   __|  |
..:|          |// ,   |// ,   |  |// ,   |//     |// ,   |:..
   |___,__,__/|______/|______/|__|____,__|____,__|______/

Welcome to Modland - probably the largest module archive in the world.
Currently there are 375095 modules online in 294 different formats,
old and new! If you're a module freak like myself, feel free to download!
If you have no idea what a module is, then you're in the wrong place!

Contribute! Upload your modules into /upload (please sort them into
subfolders). If you find any duplicates or other errors, or if you are
looking for a specific module, please send a mail!

Admin: Daniel Johansson, coma@modland.com
Co-admin: deus-ex@modland.com

Feel free to browse the folders, there's lots of valuable content to discover. Enjoy your stay.
Also notice my signature containing a link to MODLAND's main folder, btw.


--------------------
Best regards
deus-ex (MODLAND co-admin: ftp://ftp.modland.com)
Go to the top of the page
+Quote Post
jahpal
post Nov 21 2008, 04:29
Post #43





Group: Members
Posts: 233
Joined: 9-May 06
From: Orlando,Florida
Member No.: 30580



THANK YOU Bro. i could get to the page but i did not see any of that mess on the page .; got it with the LINK thanks once again...
Go to the top of the page
+Quote Post
Borisz
post Dec 10 2008, 20:25
Post #44





Group: Members
Posts: 381
Joined: 27-September 03
Member No.: 9041



QUOTE (wangyi6854 @ Oct 25 2008, 13:17) *
Maybe. My system is server 2008 64bit. Foobar2000 is 0.9.6 beta1. When foobar2k starts, it says
CODE
Failed to load DLL: foo_game.dll, reason: This component is not compatible with this version of Windows and needs to be recompiled with a newer version of the foobar2000 SDK; please contact the author of this component to obtain an updated version of this component.

Confirming the issue on foobar 096 final, on Vista Ultimate SP1.

Can anybody contact the author for an update? I'm mainly looking for a Westwood AUD player, the only other one I know of is for Foobar 0.8.


--------------------
http://evilboris.sonic-cult.net/346/
Sega Saturn, Shiro!
Go to the top of the page
+Quote Post
wangyi6854
post Dec 11 2008, 01:49
Post #45





Group: Members
Posts: 21
Joined: 6-March 05
Member No.: 20404



QUOTE (Borisz @ Dec 11 2008, 03:25) *
QUOTE (wangyi6854 @ Oct 25 2008, 13:17) *

Maybe. My system is server 2008 64bit. Foobar2000 is 0.9.6 beta1. When foobar2k starts, it says
CODE
Failed to load DLL: foo_game.dll, reason: This component is not compatible with this version of Windows and needs to be recompiled with a newer version of the foobar2000 SDK; please contact the author of this component to obtain an updated version of this component.

Confirming the issue on foobar 096 final, on Vista Ultimate SP1.

Can anybody contact the author for an update? I'm mainly looking for a Westwood AUD player, the only other one I know of is for Foobar 0.8.

Game audio player can also play .aud file.
Go to the top of the page
+Quote Post
Borisz
post Jan 3 2009, 16:10
Post #46





Group: Members
Posts: 381
Joined: 27-September 03
Member No.: 9041



QUOTE (wangyi6854 @ Dec 11 2008, 01:49) *
Game audio player can also play .aud file.

I could not find an up to date version of that (is that also foo_game?), but this plugin has been updated and plays all my AUD files fine on the latest version of foobar.


--------------------
http://evilboris.sonic-cult.net/346/
Sega Saturn, Shiro!
Go to the top of the page
+Quote Post
wangyi6854
post Jan 4 2009, 01:58
Post #47





Group: Members
Posts: 21
Joined: 6-March 05
Member No.: 20404



QUOTE (Borisz @ Jan 3 2009, 23:10) *
QUOTE (wangyi6854 @ Dec 11 2008, 01:49) *

Game audio player can also play .aud file.

I could not find an up to date version of that (is that also foo_game?), but this plugin has been updated and plays all my AUD files fine on the latest version of foobar.

Yes, the latest version works fine.
Go to the top of the page
+Quote Post
Sim's
post Feb 5 2009, 09:59
Post #48





Group: Members
Posts: 1
Joined: 5-February 09
Member No.: 66625



Foo_m1 doesn't work, it's very strange because the plugin worked fine 3 weeks before. Now i can't create .fm1 file. Even if I have a file, Foobar is not to able to play it.

This post has been edited by Sim's: Feb 5 2009, 10:31
Go to the top of the page
+Quote Post
Cutter
post Feb 21 2009, 14:06
Post #49





Group: Members
Posts: 272
Joined: 3-December 03
Member No.: 10152



The plugin crashes foobar here.

foobar2000 v0.9.6.3 beta 1
M1 0.7.7
Windows XP SP3
VC++ 2008 Redistribuable

CODE
Opening track for playback: "D:\fm1lists\mslug3.fm1"
(foo_m1 DBGMSG 0) Writing data to temp file
(foo_m1 DBGMSG 0) Start parsing XML
(foo_m1 DBGMSG 0) numTracks (0) and numsongs (100) differ
(foo_m1 DBGMSG 0) End of XML parsing
(foo_m1 DBGMSG 0) Temp file removed
(foo_m1 DBGMSG 0) Opening D:\roms, mslug3
(foo_m1 DBGMSG 0) Loading M1 DLL
(foo_m1 DBGMSG 2) Starting M1
(foo_m1 DBGMSG 0) Initializing M1
(foo_m1 DBGMSG 3) Setting M1 options
(foo_m1 DBGMSG 0) Loading game
(foo_m1 DBGMSG 0) Loading M1 DLL
(foo_m1 DBGMSG 0) DLL is currently in use. Creating a copy in the same directory.
(foo_m1 DBGMSG 0) Starting M1
(foo_m1 DBGMSG 0) Initializing M1
(foo_m1 DBGMSG 3) Setting M1 options
(foo_m1 DBGMSG 0) Loading game
(foo_m1 DBGMSG 0) Acquiring an instance of M1
(foo_m1 DBGMSG 0) The global instance of M1 is available
(foo_m1 DBGMSG 0) Switching to game Metal Slug 3
(foo_m1 DBGMSG 0) Game Selected: Metal Slug 3 (SNK, 2000)
(foo_m1 DBGMSG 0) Location result: 1
(foo_m1 DBGMSG 0) Setting location to D:\roms\mslug3.zip
(foo_m1 DBGMSG 2) Error occurred in M1 callback. Caution, memory has been leaked


This post has been edited by Cutter: Feb 21 2009, 15:27
Go to the top of the page
+Quote Post
Pulstar
post Feb 2 2010, 17:02
Post #50





Group: Members
Posts: 35
Joined: 26-January 10
Member No.: 77550



The internet is such a wonderful place. Noone bothered to mirror the foo_m1 plugin and the author's page is down indefinitely. Does anyone here have a backup copy? I'm tired of having to manually rip the music from the MAME set, and MAME's sound format is a non-starter. Even if it uses an older core if it means less time wasted ripping music I'm all for it. I hope someone here helps.
Go to the top of the page
+Quote Post

3 Pages V  < 1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 20:21