IPB

Welcome Guest ( Log In | Register )

14 Pages V  « < 4 5 6 7 8 > »   
Reply to this topicStart new topic
Toaster for Fb2k, The port of the Winamp Toaster plugin
beto
post Apr 15 2005, 02:34
Post #126





Group: Members (Donating)
Posts: 713
Joined: 8-July 04
From: Sao Paulo
Member No.: 15173



I'm having a strange issue with this plugin. It's not showing in the components list anymore. See below:

http://sites.uol.com.br/disco_virtual/grfi...foo_toaster.JPG

Anyone could help? thanks.


--------------------
http://volutabro.blogspot.com
Go to the top of the page
+Quote Post
hunted
post Apr 15 2005, 03:38
Post #127





Group: Members
Posts: 271
Joined: 26-October 03
From: Seattle, WA, USA
Member No.: 9461



QUOTE (beto @ Apr 14 2005, 05:34 PM)
I'm having a strange issue with this plugin. It's not showing in the components list anymore.
Anyone could help? thanks.
*

Did you check Core>Main menu items to see if you could add it? Sometimes if you remove a component and re-add it, it wont re-add its menu items, or something like that.
Go to the top of the page
+Quote Post
beto
post Apr 16 2005, 14:43
Post #128





Group: Members (Donating)
Posts: 713
Joined: 8-July 04
From: Sao Paulo
Member No.: 15173



Thank you. I refreshed the menu state and now it's working.


--------------------
http://volutabro.blogspot.com
Go to the top of the page
+Quote Post
Blivrail
post Apr 17 2005, 21:49
Post #129





Group: Members
Posts: 15
Joined: 16-February 05
Member No.: 19872



THanks shaneh for such a great plugin! I really like it because it alphablends real nicely.

I am using id3v2 albumcovers - I was wondering if you were able to make a small change to the functionality of toaster, that is, when albumcover is not present for the particular song, a hole (for the cover art) is not shown if cover is to the left of the text. If you don't understand what I mean, I will attach some images.

Thanks
Go to the top of the page
+Quote Post
hunted
post Apr 17 2005, 21:52
Post #130





Group: Members
Posts: 271
Joined: 26-October 03
From: Seattle, WA, USA
Member No.: 9461



QUOTE (Blivrail @ Apr 17 2005, 12:49 PM)
THanks shaneh for such a great plugin!  I really like it because it alphablends real nicely.

I am using id3v2 albumcovers - I was wondering if you were able to make a small change to the functionality of toaster, that is, when albumcover is not present for the particular song, a hole (for the cover art) is not shown if cover is to the left of the text.  If you don't understand what I mean, I will attach some images.

Thanks
*

I would also like to see this, so there isnt a square empty space when there's no art
Also, a command to hide it when visible would be cool, but not very important
Go to the top of the page
+Quote Post
shaneh
post Apr 18 2005, 01:00
Post #131





Group: Members
Posts: 93
Joined: 11-November 04
Member No.: 18068



I will get around to updating this plugin sometime soon, with proper foobar2000 config support rather than .ini saving which will fix heaps of unicode problems. Although Im a bit unsure at the moment how to suport multiple presets when using foobar2000 config routines.

With regards to the empty space, it is possible to have a toast_track.png which will be used if the cover isn't found, but I can add the option to extend the text over if you like.

Im also hoping to add some inline colour encoding support to the ATF text output stuff, though it might be a bit tricky.


--------------------
[url=http://www.myplugins.info/]Music Plugins[/url]
Go to the top of the page
+Quote Post
4nt1
post Apr 18 2005, 03:35
Post #132





Group: Members
Posts: 492
Joined: 3-January 05
Member No.: 18811



erm is it just me or does this not work with the latest msn 7.0
Go to the top of the page
+Quote Post
shaneh
post Apr 18 2005, 04:15
Post #133





Group: Members
Posts: 93
Joined: 11-November 04
Member No.: 18068



It should work fine. Make sure you have the 'what im listening to' feature turned on and arent running any other media players which also update these titles.

It uses similar code to the foo_msn plugin, so if that works there might be something wrong with the configuration of Toaster. It currently has some issues with unicode config paths etc.

You can try the foo_msn plugin from http://www.myplugins.info


--------------------
[url=http://www.myplugins.info/]Music Plugins[/url]
Go to the top of the page
+Quote Post
Blivrail
post Apr 19 2005, 01:14
Post #134





Group: Members
Posts: 15
Joined: 16-February 05
Member No.: 19872



QUOTE (shaneh @ Apr 17 2005, 08:15 PM)
It should work fine. Make sure you have the 'what im listening to' feature turned on and arent running any other media players which also update these titles.

It uses similar code to the foo_msn plugin, so if that works there might be something wrong with the configuration of Toaster. It currently has some issues with unicode config paths etc.

You can try the foo_msn plugin from http://www.myplugins.info
*


What I'm listening to for MSN 7 works fine with toaster.
Go to the top of the page
+Quote Post
mickeymoose88
post Apr 23 2005, 06:11
Post #135





Group: Members
Posts: 4
Joined: 5-September 04
Member No.: 16800



A couple of weeks ago, the msn toaster function was working fine. Now it does not work at all. I've tried foo_msn, as well. Any suggestions on how to fix this. No errors took place. There's simply no interaction between Foobar and Messenger.
Go to the top of the page
+Quote Post
shaneh
post Apr 23 2005, 06:19
Post #136





Group: Members
Posts: 93
Joined: 11-November 04
Member No.: 18068



Did you install any stuffnplug/msgplus/mess.be nonsense? My advice would be to simply uninstall messenger and re-install it again if so. This plugin is for the unmodified MSN Messenger 7.0.0777 and above. If it works for any other hacks or versions, that is a bonus, not a supported environment.

/EDIT: I have confirmed there does seem to be a problem at the moment, although it appears to be an issue with MSN Messenger rather than Toaster. Before blaming Toaster or foo_msn, test with the official MS plugin and WMP to check that is not a problem with Messenger itself. Which it would appear to be.

This post has been edited by shaneh: Apr 23 2005, 06:41


--------------------
[url=http://www.myplugins.info/]Music Plugins[/url]
Go to the top of the page
+Quote Post
mickeymoose88
post Apr 23 2005, 22:07
Post #137





Group: Members
Posts: 4
Joined: 5-September 04
Member No.: 16800



QUOTE
A couple of weeks ago, the msn toaster function was working fine. Now it does not work at all. I've tried foo_msn, as well. Any suggestions on how to fix this. No errors took place. There's simply no interaction between Foobar and Messenger.


I've solved my my MSN problem.
(Note: Although, I didn't use the toaster options for MSN this may prove useful for people unable to get that option working for them)

So here's my dummy explanation:

1. I kept toaster but unchecked all the msn options.
2. Then I got foo_msn off the same site as Toaster and put it in the Foobar components folder. (Link: http://www.myplugins.info/)
3. On MSN, I unchecked the "what I'm listening to" function. My WMP messenger plugin is also disabled.
4. I closed Messenger.
5. Opened Messenger.
6. Checked the "What I'm listening to" function.
7. My title appeared as it should on my MSN display. tongue.gif

It's worth a try for anyone that had my problem. biggrin.gif
Go to the top of the page
+Quote Post
philipshu
post Apr 24 2005, 03:01
Post #138





Group: Members
Posts: 7
Joined: 10-April 05
Member No.: 21357



thanks,
but i still have a ?-? displayed in my "what i am listening to" box
anyone have the same problem?
Go to the top of the page
+Quote Post
aurelio
post Apr 24 2005, 04:32
Post #139





Group: Members
Posts: 60
Joined: 8-June 04
Member No.: 14555



@philipshu
Check that the playing file is tagged properly (at least artist name and track title).
Go to the top of the page
+Quote Post
philipshu
post Apr 24 2005, 06:27
Post #140





Group: Members
Posts: 7
Joined: 10-April 05
Member No.: 21357



i think i have a proper tag,
here is what happened

screenshot

is it because i have a non-English operating system?

moderation: max. for inlined screenshots: ca. 800x600px, 80KB. please use links and/or thumbnails for larger ones. png is usually better than jpeg for screenshots.
Go to the top of the page
+Quote Post
shaneh
post Apr 24 2005, 07:07
Post #141





Group: Members
Posts: 93
Joined: 11-November 04
Member No.: 18068



A non-english operating system may affect Toaster, as it isn't fully unicode compatible yet. Foo_msn should work ok though. Try removing the foo_toaster component completely and just use foo_msn. Toaster may be interfering and setting the wrong information because it can't handle the unicde properly. Just disabling it may not work, because a non-ansi install path causes settings to not be saved properly (in Toaster).

It would appear the updates are working ok, it just isn't TAGZ'ing it properly. What are your configuration settings for foo_msn? (under MSN Now Playing) It should be:

Artist{0} = %artist%
Title{1} = %title%

MSN Format = {0} - {1}

Try playing with those values.


--------------------
[url=http://www.myplugins.info/]Music Plugins[/url]
Go to the top of the page
+Quote Post
Storm
post Apr 24 2005, 15:18
Post #142





Group: Members
Posts: 164
Joined: 9-July 04
Member No.: 15188



I think it looks like he's only displaying the filename in the foobar playlist. So he has to open up the file info window to check if it's tagged.
Go to the top of the page
+Quote Post
philipshu
post Apr 24 2005, 19:18
Post #143





Group: Members
Posts: 7
Joined: 10-April 05
Member No.: 21357



thanks storm,
got the problem fixed,
i'm using foo_msn
Go to the top of the page
+Quote Post
myxomatosis
post Apr 26 2005, 05:34
Post #144





Group: Members
Posts: 45
Joined: 12-August 04
From: Québec, Canada
Member No.: 16215



Works like a charm, excellent plugin!



Great job shaneh, you have all my respect wink.gif

This post has been edited by myxomatosis: Apr 26 2005, 06:12


--------------------
My English sucks... Forgive me :(
Go to the top of the page
+Quote Post
Quiark
post May 1 2005, 15:54
Post #145





Group: Members
Posts: 153
Joined: 5-March 05
Member No.: 20385



I'm looking forward to the new version and meanwhile, I've got an idea:

What about adding an option to show the toaster few seconds after the song starts (e.g. with a delay) and a few seconds before the song ends (just like it is on those music channels).

I think it would look quite cool wink.gif
Go to the top of the page
+Quote Post
Superunknown
post May 1 2005, 18:38
Post #146





Group: Members
Posts: 118
Joined: 4-March 05
Member No.: 20344



and the support for unicode caracters in directories name smile.gif

btw, good idea quiark
Go to the top of the page
+Quote Post
eliazu
post May 1 2005, 19:19
Post #147





Group: Members
Posts: 184
Joined: 10-July 04
Member No.: 15291



QUOTE (myxomatosis @ Apr 26 2005, 06:34 AM)
Works like a charm, excellent plugin!



Great job shaneh, you have all my respect  wink.gif
*


hey man can you upload your toaster preset?
thanx
Go to the top of the page
+Quote Post
benja88
post May 2 2005, 18:41
Post #148





Group: Members
Posts: 1
Joined: 2-May 05
Member No.: 21832



Hello everybody, I've got a problem to display the title in MSN with toaster when I'm listening to a stream.

The title and artist are correctly displayed in the title bar of foobar (stream's tag or something like that i suppose). But in MSN, it shows the name of the stream (ie : "PBB - OGG - 64kbps") dry.gif

Have you got a solution?

Thank you for your help smile.gif

Bye

This post has been edited by benja88: May 3 2005, 07:05
Go to the top of the page
+Quote Post
CJC
post May 16 2005, 20:24
Post #149





Group: Members
Posts: 42
Joined: 9-May 03
Member No.: 6507



I accidently messed up the string of code that reads "Folder.jpg" from the song's path.

Can somebody post their string please?

PS. Does it have to read a specific name like Folder.jpg or can it just take any jpg in the folder?
Go to the top of the page
+Quote Post
synth7
post May 17 2005, 00:07
Post #150





Group: Members
Posts: 196
Joined: 17-February 05
Member No.: 19933



QUOTE (CJC @ May 16 2005, 03:24 PM)
I accidently messed up the string of code that reads "Folder.jpg" from the song's path.

Can somebody post their string please?

PS.  Does it have to read a specific name like Folder.jpg or can it just take any jpg in the folder?
*


$left(%_path%,$strrchr(%_path%,'\'))folder.jpg
Go to the top of the page
+Quote Post

14 Pages V  « < 4 5 6 7 8 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 08:52