IPB

Welcome Guest ( Log In | Register )

20 Pages V  « < 3 4 5 6 7 > »   
Reply to this topicStart new topic
Navigator-Suite Feedback, questions, bug-reports or just chatting
Lyx
post Feb 22 2005, 08:01
Post #101





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Light color-schemes should be declared as non-dark. Dark ones should be declared as dark. If a color-scheme is neither dark nor light, then choose whatever looks best.

Your scheme clearly is a light-scheme. About the special-color: maybe i'm stating the obvious but if you choose yellow foreground on a bright-orange background, then its supposed to look unreadable. That would as well be the case with no color-calculations at all.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
hedge153
post Feb 22 2005, 16:15
Post #102





Group: Members
Posts: 68
Joined: 10-July 04
Member No.: 15261



Hey lyx, very nice config ya made up, thanks for the work you've put into it.
I've found one (very small) bug, in the format display where it displays MP3, if there is no lame version, there is a space left over.
Heres the fixed code: MP3,MP3[' ('%__lame_version%')'],

Oh and heres another bug (not quite so small this time).
Setting enable folders to 1 doesnt seem to have any affect. I had to move the enable_folders=$get(enable_folders) line to global track specific in export to get it to work properly...

This post has been edited by hedge153: Feb 22 2005, 16:18
Go to the top of the page
+Quote Post
Lyx
post Feb 23 2005, 08:06
Post #103





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



QUOTE (hedge153 @ Feb 22 2005, 05:15 PM)
Hey lyx, very nice config ya made up, thanks for the work you've put into it.
I've found one (very small) bug, in the format display where it displays MP3, if there is no lame version, there is a space left over.
Heres the fixed code: MP3,MP3[' ('%__lame_version%')'],

Thanks, will be fixed in next version along with the missing space between bitrate and VBR-files.

QUOTE
Oh and heres another bug (not quite so small this time).
Setting enable folders to 1 doesnt seem to have any affect. I had to move the enable_folders=$get(enable_folders) line to global track specific in export to get it to work properly...
*

This is very weird. It should not make a difference, because the track-specific line is just a comment - it doesn't do anything and it shouldn't make a difference where its exported. The seperation of trackspecific and nontrackspecific is purely for cosmetical reasons, so that when ui columns gets global nontrackspecific vars that its easy for me to make use of it.
I will investigate why this happens when i've got some time, but honestly, this is just weird and i dont have the slightest clue yet.

edit: found a quick-fix for it - i dunno why it was necessary to put a seperator-char before the first exported var, but it works*shrugs*

This post has been edited by Lyx: Feb 23 2005, 08:09


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
mobyduck
post Feb 23 2005, 17:59
Post #104





Group: Members
Posts: 573
Joined: 24-April 03
From: Italy
Member No.: 6159



Hi Lyx.

Enjoying your Navigator. biggrin.gif

I noticed a little glitch: using CLASSIC theme, when you select the currently playing song artist and title info are hardly visible (quality is fine, though).

Can you fix it?

Thanks.

Alessandro

This post has been edited by mobyduck: Feb 23 2005, 17:59
Go to the top of the page
+Quote Post
Lyx
post Feb 24 2005, 13:06
Post #105





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



QUOTE (mobyduck @ Feb 23 2005, 06:59 PM)
I noticed a little glitch: using CLASSIC theme, when you select the currently playing song artist and title info are hardly visible (quality is fine, though).

Can you fix it?

I know about it, but its not that easy to fix while keeping the selected tracks looking obvious in light AND dark color-schemes. It's on my to-do list, but i don't know if a solution to this will be in the next release.

edit: bah, i dont even know my own code anymore after the recent optimizations. Easier than i thought. Fixed in next version.

This post has been edited by Lyx: Feb 24 2005, 13:31


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
mobyduck
post Feb 24 2005, 14:34
Post #106





Group: Members
Posts: 573
Joined: 24-April 03
From: Italy
Member No.: 6159



QUOTE (Lyx @ Feb 24 2005, 04:06 AM)
Easier than i thought. Fixed in next version.
Appreciate your efforts. Thank you.

Alessandro
Go to the top of the page
+Quote Post
Tomacco_Boy
post Feb 26 2005, 16:37
Post #107





Group: Members
Posts: 71
Joined: 23-July 04
From: Australia
Member No.: 15689



I dont know if this has been posted, but the play date column doesnt seem to work\display anything since v1.02.


--------------------
You're talking to my guy all wrong... It's the wrong tone. Say it again, and i'll stab you in the face with a soldering iron!
Go to the top of the page
+Quote Post
Lyx
post Feb 26 2005, 16:44
Post #108





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Support for play_date and play_time has been dropped at 1.1.0. Only last_played is supported now(and not just displayed, i'm also doing some nifty calculations with it - see the screenshot on the formatting site for an example)

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
Tomacco_Boy
post Feb 26 2005, 22:09
Post #109





Group: Members
Posts: 71
Joined: 23-July 04
From: Australia
Member No.: 15689



Thanks for the info Lyx, looking forward to the next release and keep up the great work. cool.gif


--------------------
You're talking to my guy all wrong... It's the wrong tone. Say it again, and i'll stab you in the face with a soldering iron!
Go to the top of the page
+Quote Post
hedge153
post Feb 27 2005, 03:58
Post #110





Group: Members
Posts: 68
Joined: 10-July 04
Member No.: 15261



QUOTE (Tomacco_Boy @ Feb 27 2005, 07:39 AM)
Thanks for the info Lyx, looking forward to the next release and keep up the great work.  cool.gif
*

Hey lyx could you explain to me what the $char(6) in your code, and the $replace functions its used in, actually do?
Go to the top of the page
+Quote Post
Lyx
post Feb 27 2005, 04:11
Post #111





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Its a workaround to translate various color-formats from one syntax into another. Overally, there are 4 different color-formats in fb2k - the standard unselected-only version and the standard unselected+selected..... multiplied by 2 by ui_columns color-translations between the global vars and columns. Since fb2k and ui_columns do not automatically translate from one format into another, i'm doing it manually.

Next version will probably only contain minor bugfixes (like the small glitches mentioned in the recent days). It will probably stay for some weeks like this, because 1.1.0 burned me out and i need a break - besides, i'm currently sick and have some fever.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
dano
post Mar 8 2005, 12:11
Post #112





Group: Members (Donating)
Posts: 395
Joined: 2-March 04
Member No.: 12414



Hi Lyx,
Could you make the replaygain info in album mode optional like the PERFORMER, CONDUCTOR, PUBLISHER, ENCODEDBY tags?
And maybe add support for COUNTRY ? Or maybe let the user deceide what special metatags he wants to have?
Go to the top of the page
+Quote Post
Lyx
post Mar 10 2005, 14:13
Post #113





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



QUOTE (dano @ Mar 8 2005, 01:11 PM)
Hi Lyx,
Could you make the replaygain info in album mode optional like the PERFORMER, CONDUCTOR, PUBLISHER, ENCODEDBY tags?
And maybe add support for COUNTRY ? Or maybe let the user deceide what special metatags he wants to have?
*


I do plan to make it configurable whats shown in the metadata matrix(so that you can tailor it to your needs), but it probably won't be in the next version - which will only fix minor bugs.
Currently i'm not planning to support COUNTRY.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
dano
post Mar 10 2005, 14:28
Post #114





Group: Members (Donating)
Posts: 395
Joined: 2-March 04
Member No.: 12414



I meant the A l b u m - M o d e column, not the Metadata-Matrix.
Go to the top of the page
+Quote Post
Lyx
post Mar 11 2005, 14:34
Post #115





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Ah, now i understand what you meant. I'll make it so that when an album does not contain replaygain-tags then the albummode-column will no longer show "no replaygain info" but instead use the space for other info.

- Lyx

edit: does someone have an idea how to replace the ugly arrow at the now-playing track with something more nice looking? I cannot come up with something better which also looks neutral in various color-schemes, so i'd be grateful for proposals how to improve it.

This post has been edited by Lyx: Mar 11 2005, 14:36


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
anishbenji
post Mar 11 2005, 17:47
Post #116





Group: Members (Donating)
Posts: 94
Joined: 26-March 02
Member No.: 1624



I've replaced the arrow with this animation

>
>>
>>>
>>>>

Here is the code from the pos. column:
CODE
$if($or(%_isplaying%,%_ispaused%),
%_standard_color_high%$select($mod(%_time_elapsed_seconds%,6),>      ,>>    ,>>>  ,>>>>,$pad_right(%_playlist_number%,4))
,
$if($strcmp(%_days_since_play%,0),%_standard_color_low%▷)
$char(9)%_standard_color_low%$pad_right(%_playlist_number%,4)
)


Oh BTW, I think Navigator is really cool... Thanks!
Anish

Edit: Added rest of Pos. code for clarity

This post has been edited by anishbenji: Mar 11 2005, 17:53
Go to the top of the page
+Quote Post
beto
post Mar 11 2005, 21:48
Post #117





Group: Members (Donating)
Posts: 713
Joined: 8-July 04
From: Sao Paulo
Member No.: 15173



IMO it's not so ugly. Personally I don't think this is such a problem... I would concentrate on the bugs already reported (lack of space on the VBR string for instance) but that's just me.

I noticed in your code that you use for some text (monkey's audio, for instance) the ` character (as in monkey`s audio) in the album-mode code. I tried to change that for the ' character but apparently this messes up the entire code and nothing is visible anymore (except a bunch of ????? characters). Reverting to the older ` character does not restore the views and you have to import the configuration all over again.

Do you know if this is a constraint of columns_ui itself? I noticed that it also happens with other consigurations as well.

Anyway, I love your work and am looking forward for the next release.


edit: bad english

This post has been edited by beto: Mar 11 2005, 21:50


--------------------
http://volutabro.blogspot.com
Go to the top of the page
+Quote Post
Lyx
post Mar 12 2005, 01:06
Post #118





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



@anish:
Simple yet effective - probably too easy for me to think of by myself - thanks :)
- Lyx

QUOTE (beto @ Mar 11 2005, 10:48 PM)
IMO it's not so ugly. Personally I don't think this is such a problem... I would concentrate on the bugs already reported (lack of space on the VBR string for instance) but that's just me.

Those minor bugs are already fixed and will appear in the next version (probably tomorrow).

QUOTE
I noticed in your code that you use for some text (monkey's audio, for instance) the ` character (as in monkey`s audio) in the album-mode code. I tried to change that for the ' character but apparently this messes up the entire code and nothing is visible anymore (except a bunch of ????? characters). Reverting to the older ` character does not restore the views and you have to import the configuration all over again.

Thats because ' is used in tagz for quotation-purposes. To display a ' you need to "escape" it with a second single quotation-mark - like this: monkey''s audio.

To avoid the need to escape(lazyness), bugsearching when forgetting to escape it(lazyness) and making the code more clear and faster to read(clean code) i use ` instead of '' to avoid the issue completely. But if its important to you, then you can just replace the `s with ''s.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
Lyx
post Mar 12 2005, 16:00
Post #119





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Minor update - changelog is as usual in the first post. Unless you suffer from one of the mentioned bugs there isn't really a need to update.

Backup your custom color-schemes before upgrading.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
miscellanea
post Mar 14 2005, 10:48
Post #120





Group: Members
Posts: 229
Joined: 4-February 05
Member No.: 19579



How about blink-on/-off option for playing song background?


--------------------
Non-profit Netlabel : Bump Foot
http://www.bumpfoot.net/
Go to the top of the page
+Quote Post
Lyx
post Mar 14 2005, 17:23
Post #121





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



Maybe - depends on how much additional code it needs to make it configurable - and if there are other people who as well would like to disable it.

- Lyx


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
dano
post Mar 17 2005, 19:44
Post #122





Group: Members (Donating)
Posts: 395
Joined: 2-March 04
Member No.: 12414



the sorting of rating and playcount should be made with something like $sub(5,%rating%) because the order would then conform to the arrow direction on the top of the column.
Go to the top of the page
+Quote Post
Lyx
post Mar 18 2005, 21:57
Post #123





Group: Members
Posts: 3353
Joined: 6-July 03
From: Sachsen (DE)
Member No.: 7609



QUOTE (dano @ Mar 17 2005, 08:44 PM)
the sorting of rating and playcount should be made with something like $sub(5,%rating%) because the order would then conform to the arrow direction on the top of the column.
*

Those columns sort by playcount, rating, last_played and path_raw

I dont know how to implement your suggestion with a reasonable amount of code while still correctly sorting by last_played. I cannot use days_since_last_play, because for that to work the global string would need to be used while sorting - and this would slow down sorting too much.

If someone can tell me how to do it at acceptable speed, then i will change it in navigator.

- Lyx

This post has been edited by Lyx: Mar 18 2005, 22:00


--------------------
I am arrogant and I can afford it because I deliver.
Go to the top of the page
+Quote Post
edm107
post Mar 23 2005, 03:12
Post #124





Group: Members
Posts: 31
Joined: 24-December 03
Member No.: 10686



My navigator:
Go to the top of the page
+Quote Post
acedriver
post Mar 24 2005, 06:31
Post #125





Group: Members
Posts: 291
Joined: 29-May 04
Member No.: 14390



My custom color. Imported from Azrael

APC
===

$puts(theme_dark,0)

// foreground colors
$puts(standard_color,$rgb(58,79,108))
$puts(special_color,$rgb(132,129,124))
$puts(playing_color,$rgb(222,222,220))
$puts(borders_color,$rgb(233,233,225))

// background colors
$puts(bg_color,$rgb(255,255,249))
$puts(bg_color2,$rgb(248,248,242))

// various symbols used in display
$puts(symbol_seperator,' ')
$puts(symbol_rating,?)



This post has been edited by empeethree: Mar 24 2005, 06:35


--------------------
http://www.last.fm/user/acedriver
Go to the top of the page
+Quote Post

20 Pages V  « < 3 4 5 6 7 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th September 2014 - 23:38