IPB

Welcome Guest ( Log In | Register )

> Upload forum rules

- No over 30 sec clips of copyrighted music. Cite properly and never more than necessary for the discussion.


- No copyrighted software without permission.


- Click here for complete Hydrogenaudio Terms of Service

6 Pages V  « < 4 5 6  
Reply to this topicStart new topic
Changes Made to TAG.EXE, Tags from text file & OptimFrog support
Stone Free
post Jun 11 2012, 15:45
Post #126





Group: Members
Posts: 59
Joined: 24-September 04
From: London
Member No.: 17277



QUOTE (semiflacco @ Feb 21 2012, 01:55) *
- Can anyone please tell me what the return codes are? I've searched and can only find that (as expected) we get non-zero for errors or warnings, but no more detail than that. I've tested with a read-only file and find that it works (great!) and I get an errorlevel of 32 so I'm guessing there is some bitsetting going on, but would really like to distinguish between "Failed to write but no damage done", and "Ooops, just chewed up your file" so my script can respond appropriately.
That sounds suspiciously like the return value of the windows function ShellExecute - http://msdn.microsoft.com/en-us/library/wi...3(v=vs.85).aspx

In that case 32 indicates that the command was succesfull, see the return value section of the above link!

Numbers less than 32 indicate one of the windows Win32API error.

This post has been edited by Stone Free: Jun 11 2012, 15:45
Go to the top of the page
+Quote Post
CoRoNe
post Aug 19 2013, 13:05
Post #127





Group: Members
Posts: 187
Joined: 31-May 05
From: Netherlands
Member No.: 22417



Hi there,

I have a question:
CODE
@ECHO OFF

SET pathToLame="D:\Binaries\lame (MP3 Encoder 3.99.5 using libsndfile 1.0.25, 29022013).exe"
SET pathToTag="D:\Binaries\tag (Tag 2.0.52, command line tagger).exe"

mkdir "%~dp1MUSIC_(mp3)"
:loop
IF "%~1"=="" GOTO end
%pathToLame% -V 5 --nohist --noreplaygain %1 "%~dp1MUSIC_(mp3)\%~n1.mp3" && %pathToTag% --hideinfo --hidetags --fromfile %1 "%~dp1MUSIC_(mp3)\%~n1.mp3"
SHIFT
GOTO loop
:end
PAUSE

While this batch script creates perfectly tagged mp3s in a sub-dir "MUSIC_(mp3)":
CODE
Tag - Automatic Tag from filename
Copyright (c) 2002-2003 Case.  Minor additions by Neil Popham, 2004-2007
Version 2.0.52, Compiled 2007-05-04

D:\Audio_samples\MUSIC_(flac)\MUSIC_(mp3)\sample-1.mp3
Lyrics3 v2.0 tag written.


CODE
@ECHO OFF

SET pathToLame="D:\Binaries\lame (MP3 Encoder 3.99.5 using libsndfile 1.0.25, 29022013).exe"
SET pathToTag="D:\Binaries\tag (Tag 2.0.52, command line tagger).exe"

mkdir "%~dp1..\MUSIC_(mp3)"
:loop
IF "%~1"=="" GOTO end
%pathToLame% -V 5 --nohist --noreplaygain %1 "%~dp1..\MUSIC_(mp3)\%~n1.mp3" && %pathToTag% --hideinfo --hidetags --fromfile %1 "%~dp1..\MUSIC_(mp3)\%~n1.mp3"
SHIFT
GOTO loop
:end
PAUSE
...this code does not.

CODE
Tag - Automatic Tag from filename
Copyright (c) 2002-2003 Case.  Minor additions by Neil Popham, 2004-2007
Version 2.0.52, Compiled 2007-05-04

D:\Audio_samples\MUSIC_(mp3)\sample-1.mp3
Failed to open file.
File time stamp modification failed.
Lame encodes the flac-file to mp3 into "MUSIC_(mp3)", which in this case is 1 directory higher than %~1. This all goes well, but Tag seems to have some difficulties.
Does anyone know what's going on?


--------------------
DC-Bass Source Mod: http://reino.degeelebosch.nl
Go to the top of the page
+Quote Post
CoRoNe
post Aug 21 2013, 20:00
Post #128





Group: Members
Posts: 187
Joined: 31-May 05
From: Netherlands
Member No.: 22417



I'm sorry Synthetic Soul, but now I can't reproduce the issue anymore blink.gif, which is of course good news...so never mind. Mp3's in a parent directory now get properly tagged.


--------------------
DC-Bass Source Mod: http://reino.degeelebosch.nl
Go to the top of the page
+Quote Post
moosehunter
post Jan 20 2014, 11:23
Post #129





Group: Members
Posts: 11
Joined: 10-February 13
Member No.: 106534



I've noticed that when using --fromfile with FLAC files that have multiples of one tag, like multiple artist tags, tag.exe will only copy the first instance of that tag that it finds instead of copying all of the tags. That would be really nice if it were fixed.
Go to the top of the page
+Quote Post

6 Pages V  « < 4 5 6
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 04:18