IPB

Welcome Guest ( Log In | Register )

13 Pages V  « < 8 9 10 11 12 > »   
Reply to this topicStart new topic
foo_dsp_continuator, crossfading plugin
Chaser
post Sep 6 2006, 23:01
Post #226





Group: Members
Posts: 403
Joined: 30-August 04
From: Germany, Bavaria
Member No.: 16641



foo_dsp_continuator unfortunatelly seems to have problems with the latest foobar-beta 0.9.4 beta 1 (http://www.hydrogenaudio.org/forums/index.php?showtopic=48041).

Can you fix this?
Go to the top of the page
+Quote Post
odyssey
post Oct 19 2006, 08:43
Post #227





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



Another request from another thread:

QUOTE (Stuart60611 @ Aug 16 2006, 18:19) *
Now what would be awesome is if continuator could be modified so as to allow it to beat match between tracks predicated on the values of each track's BPM tag!


A great idea IMHO


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
Squeller
post Oct 19 2006, 10:09
Post #228





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



Cpt. Footure Last Active 17th April 2006 - 10:29
G-Lite Last Active 24th June 2006 - 20:17

Afaics the development is discontinued, R.I.P.
But source is open, so if there are any c++ geeks out there... wink.gif
Go to the top of the page
+Quote Post
ScottStek
post Nov 6 2006, 15:58
Post #229





Group: Members
Posts: 1
Joined: 13-August 04
Member No.: 16258



Given the apparent demise of Continuator (which I really, really liked), can anyone recommend a successor?

This is one of the chief reasons I'm staying at foobar2000 v0.8.3.
Go to the top of the page
+Quote Post
aharden
post Nov 6 2006, 18:06
Post #230





Group: Members
Posts: 70
Joined: 3-October 03
From: Harrisburg, PA
Member No.: 9130



I've been using G-Lite's port of Continuator on a 24/7 FB2K 0.9.4.1 instance for a while now without problems. I saw instability problems at the default settings, but once I coaxed fade-in length to 40 ms, it performed fine. I have some 1- to 5-second bumpers in the playlist and they don't cause any problems.


--------------------
Alex Harden * http://alexharden.org
Go to the top of the page
+Quote Post
odyssey
post Jan 18 2007, 16:02
Post #231





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



Is it possible to set it up to just overlap tracks? Appearently it wants to fade-in all tracks - It sounds weird.


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
STALK_ER
post Apr 11 2007, 12:33
Post #232





Group: Members
Posts: 7
Joined: 21-March 07
Member No.: 41690



0.4.1 (2007-04-11): Ported to Foobar2000 0.9.4.2 removed MSXML buggy runtime (caused crash on exit)

modified by XPiS & Alexey Kamaev aka STALK:ER (STALK_ER) biggrin.gif

Download

This post has been edited by STALK_ER: Apr 12 2007, 07:40
Go to the top of the page
+Quote Post
tomthomson
post Apr 11 2007, 12:46
Post #233





Group: Members
Posts: 81
Joined: 4-July 06
From: Erfurt, Germany
Member No.: 32538



thanks for the update - works fine so far
always liked to have a different fade-in length than crossfade length
when skipping through a track theres also no gap - nice

This post has been edited by tomthomson: Apr 11 2007, 12:47
Go to the top of the page
+Quote Post
Ilya P
post Apr 11 2007, 22:34
Post #234





Group: Members
Posts: 22
Joined: 8-April 06
Member No.: 29285



The http://www.crystalidea.com/?q=freeware is now the HOME page of this plug-in.
Go to the top of the page
+Quote Post
Melomane
post Apr 12 2007, 09:47
Post #235





Group: Members
Posts: 643
Joined: 13-January 03
From: Marseille
Member No.: 4552



thank you!

crash when mode is crossfader and fade in lengh <20
no sound after crossfading when fade in lengh <40

please, can you add config page in dsp preset?

This post has been edited by Melomane: Apr 12 2007, 09:50


--------------------
Music is my first love.
Go to the top of the page
+Quote Post
vader897
post Apr 25 2007, 02:34
Post #236





Group: Members
Posts: 68
Joined: 23-December 05
Member No.: 26592



I have just been listening to some music and I had a wicked idea on how to improve continuator.

Continuator is great for playing a list of shuffled songs, however when i set playback mode to default and I listen to an album that is already mixed ie ministry of sound album it sound terrible as its like playing the same song twice at the same time only out of sync.

My idea into fixing this was to implement some logic into the program like this.

IF playback mode = defaut AND next track is in same album as currently playing THEN disable continuator ELSE enable continuator

Or another way of achieving it would be

IF next songs album = current songs album AND track number of next song = track number of current song +1 THEN disable continuator ELSE enable continuator.

I only just thought of this 30sec ago but it would be sweet if implemented because then my foobar would mix when mixing is needed and leave the already mixed songs be. Maybe one day I can work on this but in the mean time anyone feel free to beat me to it.

-vader897
Go to the top of the page
+Quote Post
tom_vienna_at
post Apr 25 2007, 06:32
Post #237





Group: Members
Posts: 148
Joined: 22-July 02
From: Vienna
Member No.: 2729



QUOTE (vader897 @ Apr 25 2007, 03:34) *
IF playback mode = defaut AND next track is in same album as currently playing THEN disable continuator ELSE enable continuator

Or another way of achieving it would be

IF next songs album = current songs album AND track number of next song = track number of current song +1 THEN disable continuator ELSE enable continuator.

-vader897


That would only work if the album is an "already mixed" one. What if you play a "not mixed" album with default playback? According to your idea, that album would be played with disabled Continuator too. Bad idea... or am I getting something wrong?

Tom.


--------------------
Back off haters - strictly love we deal with.
Go to the top of the page
+Quote Post
Melomane
post Apr 25 2007, 17:32
Post #238





Group: Members
Posts: 643
Joined: 13-January 03
From: Marseille
Member No.: 4552



correct logic is:
crossfader is active when
playback mode is shuffle ( track)
or
next track isn't from same album track+1

more here


--------------------
Music is my first love.
Go to the top of the page
+Quote Post
odyssey
post May 18 2007, 02:23
Post #239





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



QUOTE (Melomane @ Apr 25 2007, 18:32) *
correct logic is:
crossfader is active when
playback mode is shuffle ( track)
or
next track isn't from same album track+1

more here

I agree. I would normally not prefer to mix when i listen to any album. I would really like this option too biggrin.gif


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
odyssey
post May 18 2007, 02:55
Post #240





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



I was testing the CONTINUATOR tag, but was unable to get it working (tried with "off", but it still faded, regardless of the "Override mode"). Anyone got it working?

Also, I think that it would be more powerful if you could implement the earlier proposed ability to specify both fadein and fadeout settings. Bumping the old post:

QUOTE (Lyx @ Apr 12 2006, 02:32) *
CONTINUATOR-TAG (backwards-compatible):
overlap (uses default preference-settings)
overlap,threshold_in_dB (uses default fade-lengths)
overlap,threshold_in_dB,fadelen_in_ms_for_both (sets fadelength for both fadeout and fadein - both will have the same value)
overlap,threshold_in_dB,fadeout_in_ms,fadein_in_ms

crossfade (uses default preference-settings)
crossfade,fadelen_in_ms_for_both (sets fadelength for both fadeout and fadein - both will have the same value)
crossfade,fadeout_in_ms,fadein_in_ms

gapkill (alias for "overlap,60")

off (disable continuator for this trackchange)


Note that this is a proposal and not the actual syntax.

This post has been edited by odyssey: May 18 2007, 02:57


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
n0obie4life
post May 30 2007, 08:26
Post #241





Group: Developer
Posts: 151
Joined: 24-April 07
From: Singapore
Member No.: 42842



Is this plugin still being maintained by Ilya P?

If so, is it possible to get it to crossfade even when I change tracks manually? ( Like the SQR Advanced Crossfader for Winamp, http://www.sqrsoft.com.ar/ )


--------------------
:)
Go to the top of the page
+Quote Post
Delftenaar
post Jun 12 2007, 14:06
Post #242





Group: Members
Posts: 6
Joined: 2-April 07
Member No.: 42134



New version works witout erros on my foobar 0.9.4.3 with these settings:



But the fade between songs doesn't seem to work. What am I doing wrong?

This post has been edited by Delftenaar: Jun 27 2007, 17:45
Go to the top of the page
+Quote Post
n0obie4life
post Jun 14 2007, 14:41
Post #243





Group: Developer
Posts: 151
Joined: 24-April 07
From: Singapore
Member No.: 42842



It does work, just not really obvoius.


--------------------
:)
Go to the top of the page
+Quote Post
Delftenaar
post Jun 14 2007, 21:15
Post #244





Group: Members
Posts: 6
Joined: 2-April 07
Member No.: 42134



QUOTE (n0obie4life @ Jun 14 2007, 07:41) *
It does work, just not really obvoius.

Is that a response to my question??
Go to the top of the page
+Quote Post
n0obie4life
post Jun 15 2007, 10:46
Post #245





Group: Developer
Posts: 151
Joined: 24-April 07
From: Singapore
Member No.: 42842



Yes. I hear my songs crossfade at times, it's not *that* obvious.


--------------------
:)
Go to the top of the page
+Quote Post
blubbo
post Jun 15 2007, 11:04
Post #246





Group: Members
Posts: 23
Joined: 20-June 03
Member No.: 7300



QUOTE (Delftenaar)
But the fade between songs doesn't seem to work. What am I doing wrong?
If I have understood this rms drop in dB correctly the song must drop at least this many dBs before the fade will happen. If you decrease this value the fade should be more noticeable. Or you could switch to crossfade which always fades a specified amount of seconds.

Hope this helps.
Go to the top of the page
+Quote Post
Delftenaar
post Jun 15 2007, 11:20
Post #247





Group: Members
Posts: 6
Joined: 2-April 07
Member No.: 42134



QUOTE (blubbo @ Jun 15 2007, 04:04) *
QUOTE (Delftenaar)
But the fade between songs doesn't seem to work. What am I doing wrong?
If I have understood this rms drop in dB correctly the song must drop at least this many dBs before the fade will happen. If you decrease this value the fade should be more noticeable. Or you could switch to crossfade which always fades a specified amount of seconds.

Hope this helps.

It still does not work after adjusting the amount of dBs (decrease). It really does nothing at all! :S. I also switched back to foobar 0.8, since the COLUMNS_UI with newest foobar is not well functioning with my pc (vista-32). I cannot adjust the length of the fields (artist, title, etc..)

This post has been edited by Delftenaar: Jun 15 2007, 11:20
Go to the top of the page
+Quote Post
JamesHunt
post Aug 12 2007, 00:49
Post #248





Group: Members
Posts: 13
Joined: 11-August 07
Member No.: 46140



QUOTE (Delftenaar @ Jun 15 2007, 04:20) *
QUOTE (blubbo @ Jun 15 2007, 04:04) *

QUOTE (Delftenaar)
But the fade between songs doesn't seem to work. What am I doing wrong?
If I have understood this rms drop in dB correctly the song must drop at least this many dBs before the fade will happen. If you decrease this value the fade should be more noticeable. Or you could switch to crossfade which always fades a specified amount of seconds.

Hope this helps.

It still does not work after adjusting the amount of dBs (decrease). It really does nothing at all! :S. I also switched back to foobar 0.8, since the COLUMNS_UI with newest foobar is not well functioning with my pc (vista-32). I cannot adjust the length of the fields (artist, title, etc..)



For me the effect is really obvious if I use settings like CONTINUATOR crossfade[,6500]
I'm using continuator 0.4.1 with Foobar 0.9.4.3 on Windows XP Pro SP2.

Value "off" doesn't work and I haven't noticed that changing threshold value would have any effect.

I'm in trouble trying to figure if fade-in fade-out is fully supported. I have tried setting like:
crossfade[6500,6500] but next track on playlist doesn't really fade-in but overlaps with previous track instead. However, whatever value I have set for fade-in length in continuator control panel is applied.

I checked Wiki Talk page and I think I'm either missing something obvious or something isn't working.

I really wish there would be "continuator for dummies" or any better documentation for this component. It's must have piece for me even without using CONTINUATOR tags. It would just make so much easier to make transitions between studio / live material or if playlist spans multiple genres of music (I'm a DJ).

It would really help usability a lot if override settings could be applied to file via button in continuator settings.
Go to the top of the page
+Quote Post
aharden
post Aug 13 2007, 13:21
Post #249





Group: Members
Posts: 70
Joined: 3-October 03
From: Harrisburg, PA
Member No.: 9130



QUOTE (Delftenaar @ Jun 15 2007, 06:20) *
QUOTE (blubbo @ Jun 15 2007, 04:04) *

QUOTE (Delftenaar)
But the fade between songs doesn't seem to work. What am I doing wrong?
If I have understood this rms drop in dB correctly the song must drop at least this many dBs before the fade will happen. If you decrease this value the fade should be more noticeable. Or you could switch to crossfade which always fades a specified amount of seconds.

Hope this helps.

It still does not work after adjusting the amount of dBs (decrease). It really does nothing at all! :S. I also switched back to foobar 0.8, since the COLUMNS_UI with newest foobar is not well functioning with my pc (vista-32). I cannot adjust the length of the fields (artist, title, etc..)

Two things:
  • I don't understand your choice for fade-in value (6815 ms). I found this value to touchy in my setup of the last Continuator release with FB2k 0.9.4.3. I use 40ms. This should produce an imperceptible fade-in of the new track, which is what I use Continuator for: threshold-based mixing without fades.
  • Make sure you put Continuator at the top of your "Active DSPs" stack, so that the source files aren't being modified by other DSPs before Continuator gets a chance to look at them.


--------------------
Alex Harden * http://alexharden.org
Go to the top of the page
+Quote Post
ThDn
post Aug 20 2007, 06:00
Post #250





Group: Members
Posts: 5
Joined: 4-May 07
Member No.: 43168



Sorry if i sound like a dummy but can anyone tell me the best settings for this plugin? i love trance music tongue.gif
Go to the top of the page
+Quote Post

13 Pages V  « < 8 9 10 11 12 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th July 2014 - 09:07