IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
gapless encodes?, gapless mp3
Larsus
post Jul 29 2003, 15:28
Post #1





Group: Members
Posts: 6
Joined: 29-July 03
Member No.: 8068



Hi All!

I own the Nomad Jukebox 40G. When playing mp3s of music that have no gaps (Pink Floyd, Porcupine Tree, etc.) there is a slight gap of silence between tracks. This bugs me to no end. So, on music that have no gaps I started using BladeEnc with the -nogap option (and use lame for evrything else). Does lame have an option like this or will it be getting this option? It is really nice to hear these albums play back gapless.
Go to the top of the page
+Quote Post
nyarlathotep
post Jul 29 2003, 15:39
Post #2





Group: Members
Posts: 412
Joined: 13-April 03
From: Haut-Médoc FRA
Member No.: 5943



The mp3 format doesn't allow gapless encoding. So there's no real solution if you use a Nomad Jukebox.

If you want to listen to Pink Floyd, Porcupine Tree, etc albums without gaps between tracks, the only solution I know is to encode those albums as a single big track.
Go to the top of the page
+Quote Post
FuRaL
post Jul 29 2003, 16:09
Post #3





Group: Members
Posts: 8
Joined: 17-May 03
Member No.: 6676



QUOTE (nyarlathotep @ Jul 29 2003, 03:39 PM)
If you want to listen to Pink Floyd, Porcupine Tree, etc albums without gaps between tracks, the only solution I know is to encode those albums as a single big track.

... and the other possibility is using a better audio format like Ogg Vorbis or Musepack MPC. These formats are able to encode absolutely gapless and have at the same filesize as an mp3 file much better sound quality!
Go to the top of the page
+Quote Post
nyarlathotep
post Jul 29 2003, 16:17
Post #4





Group: Members
Posts: 412
Joined: 13-April 03
From: Haut-Médoc FRA
Member No.: 5943



QUOTE (FuRaL @ Jul 29 2003, 05:09 PM)
... and the other possibility is using a better audio format like Ogg Vorbis or Musepack MPC. These formats are able to encode absolutely gapless and have at the same filesize as an mp3 file much better sound quality!

My answer was referring to Larsus' question: "I own the Nomad Jukebox 40G...", which implies ha can't use another audio format but mp3 for his Nomad Jukebox.

Everybody here knows that the other possibility is to use another audio format (or foobar2000 to play mp3's).
Go to the top of the page
+Quote Post
Larsus
post Jul 29 2003, 16:52
Post #5





Group: Members
Posts: 6
Joined: 29-July 03
Member No.: 8068



Actually, BladeEnc does provide a gapless solution. I would rather use Lame since it appears that development on the program is continual. BladeEnc is no longer being worked on.

Anyway, BladeEnc is the solution at the moment.
Go to the top of the page
+Quote Post
Larsus
post Jul 29 2003, 16:54
Post #6





Group: Members
Posts: 6
Joined: 29-July 03
Member No.: 8068



...oh. On the JB I can also use wav (too big) or wma (yech)...
Go to the top of the page
+Quote Post
M
post Jul 29 2003, 17:21
Post #7





Group: Members
Posts: 964
Joined: 29-December 01
Member No.: 830



Yes, L.A.M.E. has a --nogap option. The simplest way to use it is with Speek's ALL2LAME frontend (just check the "No Gap" box in the "Gapless encoding" section), since that also automatically configures the necessary --nogapout parameter.

- M.
Go to the top of the page
+Quote Post
Raffles
post Jul 29 2003, 17:42
Post #8





Group: Members
Posts: 33
Joined: 26-July 03
Member No.: 7994



You could rip your cd's as a single file and then encode with Lame.

Using EAC under Action and Copy Range, you'll have a choice between ripping a compressed or uncompressed file.

The result will be a single wav or mp3, which should be just what you want for gapless playback on a portable.

I used this method for The Mars Volta's album "De-loused In the Comatorium", which sounded crap on my MuVo with gaps between the tracks that should have run into each other.

Raf.
Go to the top of the page
+Quote Post
Larsus
post Jul 29 2003, 18:35
Post #9





Group: Members
Posts: 6
Joined: 29-July 03
Member No.: 8068



I'm going to try the --nogap option with A2L. That should also work with RazorLame, yes?

I'd rather not encode the whole CD as 1 file. I'd like to have the ability to change tracks. BladeEnc gave me clean (no ticks) gapless encodes. But, like I said, I'd rather use Lame.

I was putting these CDs onto my JB3 as wavs, which played gapless, but it was taking up too much space.

I'll let you know how that turns out.
Go to the top of the page
+Quote Post
Larsus
post Jul 29 2003, 19:07
Post #10





Group: Members
Posts: 6
Joined: 29-July 03
Member No.: 8068



O.K. It worked!

Now I can use my encoder of choice (Lame) to create gapless mp3s. It's interesting to note that in the list of command parms for Lame --gapless is not listed.

Now I'll A/B the BladeEnc & Lame mp3s.
Go to the top of the page
+Quote Post
DickD
post Jul 30 2003, 07:58
Post #11





Group: Members
Posts: 265
Joined: 12-January 03
Member No.: 4542



You can also get lame 3.90.3 with .APE and .CUE-sheet support from Rarewares. (Also a 'modified' version with added --preset medium and lower ABR presets is available)

EAC can create the WAV or Monkey's (.APE) image and a Cuesheet with artists and titles, then you can use this extended version of Lame to encode.

Instructions are on Nyaochi's website.

The commandline will be something like:
CODE
lame --apeinput --alt-preset standard -t CUESHEET CDImage.ape.cue "%n - %p - %t.mp3" --naming-rule


Gapless is usually a hack. The latest Foobar2000 v0.7 beta is supporting a VBR header type fix to allow you to make regular Lame MP3's play gapless properly, but that's not got portable support for the gapless feature, as it's stored in the VBR Xing/LAME header frame, which portables treat as a silent frame.

--nogap will remove the VBR header if you had a VBR encode, so track length and seeking may be messed up for VBR files if they rely on the Xing/LAME header. lame+APE+CUE by default puts in the VBR headers, but these are treated as valid silent frames by most portable players (fb2k is about the only software player that treats it right), thereby creating a tiny gap, so you need to revert to -t (the default LAME --nogap method) and remove the headers, as in my example commandline above. If it's just track shuffling that matters to you, this shouldn't be a big problem.
Go to the top of the page
+Quote Post
PlastikFabric
post Jan 1 2004, 22:11
Post #12





Group: Members
Posts: 3
Joined: 1-January 04
Member No.: 10863



hi people,

i am currently using CDex Version 1.51 to rip mix cds. Now, i have it set up to use an external decoder ( ALL2LAME ) in order to make use of the nogap feature.

couple of questions:

firstly, with CDex - i rip the cd into wav files. and then use ALL2LAME to code them to mp3's.

the encoding is: 44.1 kHz / 128 kbps / j-stereo MPEG-1 Layer II / qcal=2

This is what ALL2LAME displays when encoding.

is this right? can i not encode anything higher than 128?

also, i seem to have to manually open up ALL2LAME and select the files, rather than CDex picking up the decoder automatically.

i dont mind the 128 kbps, but the main prob is that none of the file information (title, artist, year etc) is retained when ripping it from the cd into wav and then into mp3 - so i need to manually enter in the missing details.

is this something thats unavoidable?

when you rip a cd normally via CDex (using its own lame decoder) it retains all the info, as you would expect it to do.

any tips or hints?

the other problem is that when it decodes from to wav from the cd, it loses the track number - which means its a pain when using ALL2LAME (another case of manually renaming the files).

must be an easier way? (i'm hoping i've missed the obvious)

This post has been edited by PlastikFabric: Jan 1 2004, 22:13
Go to the top of the page
+Quote Post
kasztan
post Jan 1 2004, 23:00
Post #13





Group: Members
Posts: 14
Joined: 27-November 03
Member No.: 10057



QUOTE (PlastikFabric @ Jan 1 2004, 01:11 PM)
the encoding is:  44.1 kHz / 128 kbps / j-stereo MPEG-1 Layer II / qcal=2

i think MPEG-1 Layer III
and it will be better when you look at FAQ - very powerfull guide smile.gif
Go to the top of the page
+Quote Post
saratoga
post Jan 2 2004, 06:26
Post #14





Group: Members
Posts: 5047
Joined: 2-September 02
Member No.: 3264



Rip directly to MP3. Wav files do not support tagging, so if you include wav as a step you will lose metadata. Theres no reason to use ALL2LAME anyway.

Edit: And next time instead of digging up the corpse of an old thread and shoving your thread inside, start a fresh one.

This post has been edited by Mike Giacomelli: Jan 2 2004, 06:26
Go to the top of the page
+Quote Post
PlastikFabric
post Jan 2 2004, 14:10
Post #15





Group: Members
Posts: 3
Joined: 1-January 04
Member No.: 10863



if i rip directly to mp3 and not use all2lame, how can i do so and still retain 'no gap' with the ripping?

sorry for breathing life into this old thread. i just thought it was relevant to what i am aiming to do.

for example, find a combination of programs that will allow me to rip with no gaps.


edit: sorry, i should have made it clear in my original post - that i am ripping cds which i do not wish to have sounds between the tracks. my aim is indentical to what Larsus aimed for.

using cdex and all2lame, i am able to do this - except it is time consuming (because of having to re-enter all the track details) and i can only achieve the 128.

the mp3's are then being transfered onto a Zen player.

This post has been edited by PlastikFabric: Jan 2 2004, 14:54
Go to the top of the page
+Quote Post
DonP
post Jan 2 2004, 15:46
Post #16





Group: Members (Donating)
Posts: 1471
Joined: 11-February 03
From: Vermont
Member No.: 4955



You can encode the whole CD as one file. There is a splitting program MP3Directcut which I believe splits your file up on frame boundaries. So, no gaps.


Personally I don't find the inherent mp3 gap all that bothersome as it is on the order of 1/100 second. Much worse is the large gap due to players that don't start reading the next track until the current one is done. Have the Blade encodes been gapless for you?
Go to the top of the page
+Quote Post
PlastikFabric
post Jan 2 2004, 16:02
Post #17





Group: Members
Posts: 3
Joined: 1-January 04
Member No.: 10863



not tried blade encodes.

but the MP3Directcut program sounds good as an alternative. will try that out now.
Go to the top of the page
+Quote Post
Joe Bloggs
post Jan 2 2004, 16:37
Post #18





Group: Members
Posts: 375
Joined: 29-September 01
Member No.: 55



Um, so what switch do I use to make these sorta-kinda gapless mp3s when directly using Lame.exe? --gapless? --nogapout? --nogap? Help? wacko.gif
Go to the top of the page
+Quote Post
saratoga
post Jan 2 2004, 19:04
Post #19





Group: Members
Posts: 5047
Joined: 2-September 02
Member No.: 3264



MP3s encoded with LAME are normally gapless. AFAIK the --nogap option is depreciated (could be wrong though). If it turns out that --nogap helps, just use it in EAC, CDex or whatever.

Here is what i do: I rip with EAC and preset standard. That produces gapless MP3s. Then to burn them later to a disk I use foobar to make sure the decoder does not introduce a gap.
Go to the top of the page
+Quote Post
saratoga
post Jan 2 2004, 19:06
Post #20





Group: Members
Posts: 5047
Joined: 2-September 02
Member No.: 3264



Ah here we go:

QUOTE
--nogap is useless, deprecated, and hardly supported anywhere.
All recent versions of LAME (3.90 and above if I remember correctly) always write additional gapless playback info (amounts of samples to skip) into LAME tag (unless you disable LAME tag writing). All you need is a player that reads and utilizes info from LAME tag; see the topic linked above for more info.
And again, gapless playback using LAME tags has absolutely nothing to do with --nogap switch.


http://www.hydrogenaudio.org/forums/index....6020&hl=--nogap
Go to the top of the page
+Quote Post
Joe Bloggs
post Jan 3 2004, 11:06
Post #21





Group: Members
Posts: 375
Joined: 29-September 01
Member No.: 55



That wasn't much help--if LAME mp3s were gapless by default Larsus wouldn't have his problem in the first place. I'm having trouble with LAME mp3s in the Nomad Zen NX too--they don't play gaplessly, but there are plenty of other tracks on my player that do!
Go to the top of the page
+Quote Post
Joe Bloggs
post Jan 3 2004, 11:33
Post #22





Group: Members
Posts: 375
Joined: 29-September 01
Member No.: 55



Larsus, what are you doing to make gapless work with your player?
Go to the top of the page
+Quote Post
Peter
post Jan 3 2004, 11:41
Post #23


foobar2000 developer


Group: Admin
Posts: 3293
Joined: 30-September 01
Member No.: 84



Some hardware players "support" --nogap by not resetting their MP3 decoders between tracks. I highly doubt if any hardware player supports LAME tags.
IMO more sane solution would be to upload entire album CD image as one MP3 track, that would work everywhere (but no track titles, starting playback from selected track, etc then).
Go to the top of the page
+Quote Post
Joe Bloggs
post Jan 3 2004, 11:48
Post #24





Group: Members
Posts: 375
Joined: 29-September 01
Member No.: 55



Does (*gasp*) WMA support gapless playback?
Go to the top of the page
+Quote Post
Peter
post Jan 3 2004, 11:52
Post #25


foobar2000 developer


Group: Admin
Posts: 3293
Joined: 30-September 01
Member No.: 84



QUOTE (Joe Bloggs @ Jan 3 2004, 01:48 PM)
Does (*gasp*) WMA support gapless playback?

From what I've heard, yes.
Go to the top of the page
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 15:57