IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
lame conversion seems to cut the displayed file ti
nfz1
post Jun 24 2003, 23:17
Post #1





Group: Members
Posts: 4
Joined: 24-June 03
Member No.: 7380



Hi folks:

I have a wav file that I am converting to mp3 with lame. I am running lame version 3.93 on redhat linux 7.2 from the command line. My wav file is of a 2 hour radio broadcast. When I convert it to mp3 with lame with no parameters like (lame in.wav out.mp3), and play the mp3 in winamp or wmp, it says it is two hours. However the quality was bad so I tried some of the --presets. These flags increased the quality, except all the players say the file is half as long as it is. i.e. (lame --preset fm in.wav out.mp3) makes it sound much better, but playing in winamp or windows media player it says it is an hour long. Playing in a linux player is fine.

Has anyone come across this before? Thanks in advance for your help.
Go to the top of the page
+Quote Post
AstralStorm
post Jun 24 2003, 23:29
Post #2





Group: Members
Posts: 745
Joined: 22-April 03
From: /dev/null
Member No.: 6130



WMP doesn't handle LAME tag, so it won't report correct time on VBR/ABR MP3s created by LAME.

Which Winamp version have you tried?


--------------------
ruxvilti'a
Go to the top of the page
+Quote Post
nfz1
post Jun 24 2003, 23:32
Post #3





Group: Members
Posts: 4
Joined: 24-June 03
Member No.: 7380



I am using winamp 2.77 on win2k (x86). Any ideas on how I could use lame to add the correct tag so the time is displayed correctly in winamp? Thanks a lot.
Go to the top of the page
+Quote Post
AstralStorm
post Jun 24 2003, 23:39
Post #4





Group: Members
Posts: 745
Joined: 22-April 03
From: /dev/null
Member No.: 6130



Sorry, my previous comment is irrevelant.
You weren't encoding with variable bitrate.

I don't know what causes this behaviour...

This post has been edited by AstralStorm: Jun 24 2003, 23:40


--------------------
ruxvilti'a
Go to the top of the page
+Quote Post
nyarlathotep
post Jun 24 2003, 23:41
Post #5





Group: Members
Posts: 412
Joined: 13-April 03
From: Haut-Médoc FRA
Member No.: 5943



Maybe the Xing VBR tag is not written into the mp3 file.

You can try vbrfix.
Go to the top of the page
+Quote Post
nfz1
post Jun 24 2003, 23:45
Post #6





Group: Members
Posts: 4
Joined: 24-June 03
Member No.: 7380



I think lame --preset fm does use VBR.
Go to the top of the page
+Quote Post
AstralStorm
post Jun 24 2003, 23:56
Post #7





Group: Members
Posts: 745
Joined: 22-April 03
From: /dev/null
Member No.: 6130



A snip from 'lame --preset help' v. 3.90.3

QUOTE
basic- presets covering a wide span (fixed rates unless used with -v or VBR):
    phone (16 kbps)    mw-us (40 kbps)    radio (128 kbps)    studio (256 kbps)
    phon+ (24 kbps)    sw    (24 kbps)    tape  (128 kbps)
    lw    (24 kbps)    fm    (112 kbps)    hifi  (160 kbps)
    mw-eu (24 kbps)    voice (56 kbps)    cd    (192 kbps)


He didn't say he's using -v.


--------------------
ruxvilti'a
Go to the top of the page
+Quote Post
nfz1
post Jun 25 2003, 00:15
Post #8





Group: Members
Posts: 4
Joined: 24-June 03
Member No.: 7380



Sorry, I was not using the -v option. I tried it, still no luck. thanks in advance for any other ideas.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th September 2014 - 12:04