IPB

Welcome Guest ( Log In | Register )

Transcoding FLAC into WMA LL w/ DRM, yeah, it sounds nuts
BMW_is_nuts
post Jul 10 2013, 06:41
Post #1





Group: Members
Posts: 1
Joined: 10-July 13
Member No.: 109042



OK, what I am looking at here is a pretty unique issue I think.

I want to transcode my existing FLAC (that resides on my XBMC) into WM9 lossless, but it absolutely needs to be DRM'ed.

This is due to restrictions in the head unit of my vehicle. It plays MP3, AAC and WMA, but they all have drawbacks.

MP3 has occasional problems with embedded coverart images. Aside from that highest bitrate of 320kb/s every now and then skips. I have not found any pattern to close in on the problem, it also happens _sporadic_, meaning at times a track will skip or garble at 3:20, sometimes at 1:15 and then maybe not at all.

So I was going for WMA lossless. Now, here the problem is the head unit loads the file and then just skips on. It displays the WMA ID Tag data briefly and then just moves to the next file. It also reliably displays embedded cover art. After much digging I finally found the reason in the internal BMW head unit training manula - the CIC unit of this particular model years will only accept WMA files with copy protection applied.

I am not sure if there is a difference between full blown WMA DRM (which from what I gather is an encryption requireing a license key, much like a decryption key I assume) and just simple copy protection which is mentioned in the manual. This protection could just be a boolean flag in the metadata.

I am usually using dpoweramp for encoding/transcoding but I have nowhere found any option to "protect" the created WMA files.

Does anyone have any pointers= Does it really require to setup some kind of "vendor identity" and a corresponding certificate/license/decryption passkey etc. or is there a quick and dirty workaround to make WMA files appear to have CP?

I know it's a weird problem, but it kinda stinks to be stuck with 192kb MP3 which playback reliably... Any input would be appreciated.
Go to the top of the page
+Quote Post
 
Start new topic
Replies
saratoga
post Jul 10 2013, 07:07
Post #2





Group: Members
Posts: 5054
Joined: 2-September 02
Member No.: 3264



I don't think any car stereo exists that supports WMA Lossless, which is probably why your player skips them.
Go to the top of the page
+Quote Post
Glenn Gundlach
post Jul 11 2013, 05:42
Post #3





Group: Members
Posts: 371
Joined: 19-April 08
From: LA
Member No.: 52914



QUOTE (saratoga @ Jul 9 2013, 22:07) *
I don't think any car stereo exists that supports WMA Lossless, which is probably why your player skips them.


2011 Ford Fusion hybrid with 'moon and tune' package (upgraded Sony sound) will play MP3 and WMA including lossless from the USB port. It will not play .M4A files even if I create them in Adobe Audition and are _not_ protected. When presented with .M4A files the stereo talks to you about protected content. It doesn't play .FLAC but since WMA lossless is sonically identical to FLAC I use it for some of the files. It will play MP3 CDs but I haven't tried other formats on CD. I have never had any skips with any MP3 , WMA, WMA loosless or .WAV on the USB drive.

My wife's Lexus RX will not play WMA of any variety (though it shows a number as it skips to the next file) and while it will show numbered file names it does not play them in order and comes up with its' own renumbered folders. I haven't tried ,M4A or FLAC files in her car.

G
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 07:32