IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
How to have foobar and mp3tag agree on where to write Album Artist?
erik_kaashoek
post Mar 20 2013, 08:56
Post #1





Group: Members
Posts: 3
Joined: 20-March 13
Member No.: 107296



I use both mp3tag and foobar to manage a large collection of mp3 files.
Both foobar and mp3tag have a tag edit field called "Album Artist"
When using mp3tag that field is written to the IDv3.2 tag albumartist.
Looking at the same file with foobar shows the input in the "Album Artist" field but after updating in foobar its written to IDV3.2 field "album artist".
when you then open the same file in mp3tag the "Album Artist" tag is empty. Adding a column for "album artist" shows the tag has indeed moved from "albumartist" to "album artist" after updating in foobar.
How can I tell foobar to also write the tag edit field "Album Artist" to "albumartist" just like MP3tag does?
Go to the top of the page
+Quote Post
marc2003
post Mar 20 2013, 09:02
Post #2





Group: Members
Posts: 4439
Joined: 27-January 05
From: England
Member No.: 19379



file>preferences>advanced>tagging>mp3>id3v2 revisons and quirks and tick the box map TPE2 to album artist.
Go to the top of the page
+Quote Post
erik_kaashoek
post Mar 20 2013, 09:08
Post #3





Group: Members
Posts: 3
Joined: 20-March 13
Member No.: 107296



That works for reading the tag in foobar but when you then open file properties and change the tag value it gets written to "album artist"

How to tell foobar to write the tag from where it came?

More problems.

When the Album Artist field contains "Cantilena; Shepherd" and you edit it in foobar to "Cantilena; Shepherd." foobar splits the tag in two tags and writes them to separate tags. Now mp3tag sees "Cantilena" in the tag %Album artist%

Also tried with tagscanner. Identical behaviour for writing tags as mp3tag. tagscanner shows there are two entries for šlbum artist by showing "Cantilena/Shepherd." after updating to "Cantilena; Shepherd." in tagscanner, mp3tag is showing the same.

So how to tell fb2k to have the same tag write behaviour as mp3tag and tagscanner?

This post has been edited by erik_kaashoek: Mar 20 2013, 09:30
Go to the top of the page
+Quote Post
marc2003
post Mar 20 2013, 09:23
Post #4





Group: Members
Posts: 4439
Joined: 27-January 05
From: England
Member No.: 19379



mp3tag doesn't really use a tag named albumartist. it writes to an id3v2 frame named TPE2. now i've just told you how to make foobar do the same. that is it. done. tongue.gif

i forgot to say, after changing this setting in foobar, open album list, right click all music>properties>tools>reload info from files.

This post has been edited by marc2003: Mar 20 2013, 09:26
Go to the top of the page
+Quote Post
erik_kaashoek
post Mar 20 2013, 09:33
Post #5





Group: Members
Posts: 3
Joined: 20-March 13
Member No.: 107296



I feel so stupid.

I use the setting you told me to use (its my default) so the reading from TPE2 to "Album Artist" works perfectly (as always)
Its the writing I can not get to work.

I like to use fb2k for mass updating of tags because of the nice rename tool it has.
(I am recording several internet radio stations that provide mp3 tags in various different ways and I wan to have them consistent)
Go to the top of the page
+Quote Post
marc2003
post Mar 20 2013, 19:37
Post #6





Group: Members
Posts: 4439
Joined: 27-January 05
From: England
Member No.: 19379



QUOTE (erik_kaashoek @ Mar 20 2013, 08:08) *
When the Album Artist field contains "Cantilena; Shepherd" and you edit it in foobar to "Cantilena; Shepherd." foobar splits the tag in two tags and writes them to separate tags. Now mp3tag sees "Cantilena" in the tag %Album artist%


i did not see this edit earlier. follow these steps carefully...

-first of all create a foobar playlist containing only mp3 files (we don't want to touch album artist tags of other file types)
-navigate to the advanced preferences i referenced earlier and untick the box. we're only doing this temporarily.
-now highlight all files in playlist>right click>properties>reload info.
-in the properties dialog you will now see <BAND>. this is the TPE2 frame that mp3tag uses (and foobar with that tick enabled). we want to keep it so don't touch that.
-what you want to do is remove the album artist tags. this is currently mapped to the TXXX frame and it's why it shows the space in mp3tag.
-when you have removed those tags, go back to the preferences again and tick the box.
-back in the propeties dialog, tools>reload info again. now you'll see <BAND> is gone as it's now mapped that frame back to album artist in the dialog.

any further tag updates by foobar2000 should now show as albumartist in the extended tags dialog of mp3tag.

don't ask me about the other software because i don't use it. tongue.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 15:24