IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
LAME Comment Tag
anleva
post Jan 28 2006, 20:24
Post #1





Group: Members
Posts: 5
Joined: 8-July 04
Member No.: 15135



I'm converting my flac files (ripped with EAC) to mp3 using the convert function and LAME encoder in Foobar. I'm trying to now add a value in the comment tag but can't seem to get the syntax right.

I'm trying to add the following comment: LAME v3.97 -V 2 --vbr-new

In the Command Line Encoder Settings Parameters in Foobar (diskwriter) I have the following string:

-V 2 --vbr-new --tc "LAME v3.97 -V 2 --vbr-new" %s %d

The file converts from flac to mp3 just fine and all the flac tags come across perfectly, but this additional comment doesn't appear in the comment field. It doesn't appear as a tag at all.

Help! What am I doing wrong?

This post has been edited by anleva: Jan 30 2006, 16:42
Go to the top of the page
+Quote Post
clintb
post Jan 28 2006, 21:20
Post #2





Group: Members
Posts: 182
Joined: 4-July 02
From: Sunnyvale, CA
Member No.: 2472



Here's my commandline, "-V 2 --vbr-new - %d"

The options are:
Format is: Lossy
Highest BPS mode supported: 16 bit
Tag: ID2v2

All my tags, comments included, come across perfectly...from FLAC/CUE images.

Edit: Oops, didn't see that you're trying to add a specific comment.

This post has been edited by clintb: Jan 28 2006, 21:29
Go to the top of the page
+Quote Post
anleva
post Jan 28 2006, 21:31
Post #3





Group: Members
Posts: 5
Joined: 8-July 04
Member No.: 15135



QUOTE (clintb @ Jan 28 2006, 12:20 PM)
Here's my commandline, "-V 2 --vbr-new - %d"

The options are:
Format is: Lossy
Highest BPS mode supported: 16 bit
Tag: ID2v2

All my tags, comments included, come across perfectly...from FLAC/CUE images.
*



Thanks clintb. All of my comments are coming over from FLAC as well. I am using the same commandline as you for the most part with the exception that I have added --tc, which should add a value in the comment field.

I am trying to add an additional "hard coded" comment on my mp3 files. This comment I do not want on my FLAC files as it is specific to mp3 and the encoding options used. LAME does provide an ability to add a "hard coded" comment during the encoding process, but I can't seem to get the syntax right.

This post has been edited by anleva: Jan 28 2006, 21:33
Go to the top of the page
+Quote Post
sha_man
post Feb 20 2006, 12:28
Post #4





Group: Members
Posts: 24
Joined: 13-February 06
Member No.: 27728



may I ask what the %d is for?

This post has been edited by sha_man: Feb 20 2006, 12:28
Go to the top of the page
+Quote Post
Synthetic Soul
post Feb 20 2006, 12:39
Post #5





Group: Super Moderator
Posts: 4887
Joined: 12-August 04
From: Exeter, UK
Member No.: 16217



%d is a placeholder for the output filename, which will be detirmined by your output file formatting string.

The relevant parts are - %d.

"-" tells LAME to use STDIN as the input.
"%d" is replaced by foobar using the output file formatting string.


--------------------
I'm on a horse.
Go to the top of the page
+Quote Post
TBO
post Feb 20 2006, 17:13
Post #6





Group: Banned
Posts: 83
Joined: 10-February 06
Member No.: 27671



Possibly foobar2000 overwrites LAME's comment tag with the tags which it adds itself, or there is some other incompatibility due to you having two tagging methods activated.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 18:26