IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Speexenc crushing
Anakunda
post Sep 29 2010, 11:42
Post #1





Group: Members
Posts: 484
Joined: 24-November 08
Member No.: 63072



Greetings,

need convert some audio files to SPX. Used the free binaries from speex.org, particulary speexenc.exe 1.2b3.
I use this string for fb2k converter:

CODE
--vbr --quality 8 - %d

I believe there's nothing bad on it.

But suddenly conversin crashes. Error report here:

CODE
1 out of 1 tracks converted with major problems.

Source: "E:\xfer\01 - Jambory.mp3"
  An error occurred while writing to file (The encoder has terminated prematurely with code -1073741819 (0xC0000005); please re-check parameters) : "C:\Users\Anakunda\AppData\Local\Temp\01 - Jambory.spx"
Additional information:
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "D:\media\speex\speexenc.exe" --vbr --quality 8 - "01 - Jambory.spx"
Working folder: C:\Users\Anakunda\AppData\Local\Temp\

  Conversion failed: The encoder has terminated prematurely with code -1073741819 (0xC0000005); please re-check parameters


speexenc does start, at least to print commandline help, just no conversion

Using Win7/x64

This post has been edited by Anakunda: Sep 29 2010, 11:42
Go to the top of the page
+Quote Post
ojdo
post Sep 29 2010, 11:52
Post #2





Group: Members
Posts: 894
Joined: 18-June 06
From: Germany
Member No.: 31980



When I read the manual I see the options begining with a single hyphen "-vbr", not "--vbr". And -quality 8 is not necessary as it is the default value.

Edit: removed wrong suggestion


This post has been edited by ojdo: Sep 29 2010, 12:13


--------------------
http://freemusi.cc/
Go to the top of the page
+Quote Post
Anakunda
post Sep 29 2010, 12:15
Post #3





Group: Members
Posts: 484
Joined: 24-November 08
Member No.: 63072



Hey thanks!

you were quite rite with the switches.
Now using %s does make work !

A side question, how do I force foobar2000 to use pipe instead file I/O ?
Go to the top of the page
+Quote Post
Yirkha
post Sep 29 2010, 23:58
Post #4





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



fb2k uses pipe unless you specify %s, then it uses a temporary .wav file.
The reason for crashing when using pipe input (-) might be that fb2k AFAIK uses 0xFFFFFFFF as file length in the dummy WAVE header in piped data.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Speech
post Jun 8 2011, 00:22
Post #5





Group: Members
Posts: 61
Joined: 9-May 09
Member No.: 69642



I'm trying to convert audio files with speexenc.exe. Its basic syntax is extremely simply:
CODE
speexenc.exe inputfilename.wav outputfilename.spx


However, when I define a conversion preset, I see that you can only define the output file name (%d); you can't define the input file name.

I would get the following error with the option %d:

CODE
1 out of 1 tracks converted with major problems.

Source: "D:\My documents\test.wav"
  An error occurred while writing to file (The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters) : "D:\My documents\test.spx"
  Additional information:
  Encoder stream format: 16000Hz / 1ch / 24bps
  Command line: "C:\Program Files (x86)\foobar2000\speexenc.exe" "test.spx"
  Working folder: D:\My documents\
  
  Conversion failed: The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters


I would get the following error with the option %s %d:

CODE
1 out of 1 tracks converted with major problems.

Source: "D:\My documents\test.wav"
  An error occurred while finalizing the encoding process (Object not found) : "D:\My documents\test.spx"
  Conversion failed: Object not found


This would be extremely basic, but I didn't find any information in the manual: where is the input file with default parameters like these ("-S --noreplaygain -V 2 - %d")? Or, how do you define where the input file would be placed in the command line?


--------------------
Mon blog: http://piratefurieux.wordpress.com
Go to the top of the page
+Quote Post
klonuo
post Jun 8 2011, 01:24
Post #6





Group: Members
Posts: 258
Joined: 29-April 10
Member No.: 80274



QUOTE (Speech @ Jun 8 2011, 01:22) *
where is the input file with default parameters like these ("-S --noreplaygain -V 2 - %d")?

It's in last dash, as pipe which speexenc does not understand so you have to use temp file %s
QUOTE (Speech @ Jun 8 2011, 01:22) *
Or, how do you define where the input file would be placed in the command line?

It's in Destination section in converter

edit: Destination section is for output file of course. For input file you don't have to worry about it (foobar uses %temp% folder)

This post has been edited by klonuo: Jun 8 2011, 01:36
Go to the top of the page
+Quote Post
Speech
post Jun 8 2011, 01:33
Post #7





Group: Members
Posts: 61
Joined: 9-May 09
Member No.: 69642



Thank you for your answer, but it's not clear for me: what would you put in the "parameters" field then? "%s %d" or "%d" don't work.


--------------------
Mon blog: http://piratefurieux.wordpress.com
Go to the top of the page
+Quote Post
klonuo
post Jun 8 2011, 01:35
Post #8





Group: Members
Posts: 258
Joined: 29-April 10
Member No.: 80274



%s is temporary input file
%d is destination file

for speexenc, you should use both, as it does not accept piping from foobar
Go to the top of the page
+Quote Post
lvqcl
post Jun 8 2011, 01:45
Post #9





Group: Developer
Posts: 3467
Joined: 2-December 07
Member No.: 49183



"%s %d" should work.

But sometimes foobar2000 cannot recognize speex files, don't know why.

Also, only 8 and 16-bit WAV files are supported. Set "Highest BPS mode supported" to 16.

This post has been edited by lvqcl: Jun 8 2011, 01:47
Go to the top of the page
+Quote Post
Speech
post Jun 8 2011, 01:50
Post #10





Group: Members
Posts: 61
Joined: 9-May 09
Member No.: 69642



Thanks again, but what you say doesn't seem to work (see the output window I posted before).
Here are two screen captures; is there anything wrong with these?





--------------------
Mon blog: http://piratefurieux.wordpress.com
Go to the top of the page
+Quote Post
klonuo
post Jun 8 2011, 01:54
Post #11





Group: Members
Posts: 258
Joined: 29-April 10
Member No.: 80274



If "source track folder" isn't read only medium, then I don't see what could be wrong

edit: OK, lvqcl posted more probable problem

This post has been edited by klonuo: Jun 8 2011, 01:57
Go to the top of the page
+Quote Post
Speech
post Jun 8 2011, 01:56
Post #12





Group: Members
Posts: 61
Joined: 9-May 09
Member No.: 69642



No, just My documents on the hard disk. Does it work for you? If not, I think this should be considered as a bug.


--------------------
Mon blog: http://piratefurieux.wordpress.com
Go to the top of the page
+Quote Post
lvqcl
post Jun 8 2011, 01:58
Post #13





Group: Developer
Posts: 3467
Joined: 2-December 07
Member No.: 49183



In case you didn't mention: I edited my previous post and added to it:

Also, only 8 and 16-bit WAV files are supported. Set "Highest BPS mode supported" to 16.
Go to the top of the page
+Quote Post
lvqcl
post Jun 8 2011, 02:03
Post #14





Group: Developer
Posts: 3467
Joined: 2-December 07
Member No.: 49183



and make sure you don't have foo_input_celt installed.
Go to the top of the page
+Quote Post
Speech
post Jun 8 2011, 02:05
Post #15





Group: Members
Posts: 61
Joined: 9-May 09
Member No.: 69642



Yes! Setting the Highest BPS mode supported to 16 solved the problem (and I don't have foo_input_celt). Thank you both for your help.


--------------------
Mon blog: http://piratefurieux.wordpress.com
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 16:01