IPB

Welcome Guest ( Log In | Register )

30 Pages V  « < 28 29 30  
Reply to this topicStart new topic
TAudioConverter, Multithreaded Audio Converter and Extractor
o-l-a-v
post Apr 28 2014, 01:28
Post #726





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



Ozok: Found a bug in 0.9.5 beta:

Set a ouput folder. For instance: C:\Users\User\Desktop\TAC
Close TAC
Delete the folder
Start TAC.

TAC now resets the "output" to TAC.exe's location. In my case:
C:\Users\Olav\Documents\Stuff\tac64bit_0.9.5BETA_3555

No other versions of TAC have had this problem

This post has been edited by o-l-a-v: Apr 28 2014, 01:28
Go to the top of the page
+Quote Post
ozok
post Apr 28 2014, 18:36
Post #727





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



QUOTE (o-l-a-v @ Apr 28 2014, 02:28) *
Ozok: Found a bug in 0.9.5 beta:

Set a ouput folder. For instance: C:\Users\User\Desktop\TAC
Close TAC
Delete the folder
Start TAC.

TAC now resets the "output" to TAC.exe's location. In my case:
C:\Users\Olav\Documents\Stuff\tac64bit_0.9.5BETA_3555

No other versions of TAC have had this problem

It was suppose to be a feature actually laugh.gif. As you know the program folder is the default output folder in portable version and when user runs the program in a different machine, this path would change. I thought this would be the ideal behaviour.
Go to the top of the page
+Quote Post
o-l-a-v
post Apr 28 2014, 20:52
Post #728





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



QUOTE (ozok @ Apr 28 2014, 18:36) *
QUOTE (o-l-a-v @ Apr 28 2014, 02:28) *
Ozok: Found a bug in 0.9.5 beta:

Set a ouput folder. For instance: C:\Users\User\Desktop\TAC
Close TAC
Delete the folder
Start TAC.

TAC now resets the "output" to TAC.exe's location. In my case:
C:\Users\Olav\Documents\Stuff\tac64bit_0.9.5BETA_3555

No other versions of TAC have had this problem

It was suppose to be a feature actually laugh.gif. As you know the program folder is the default output folder in portable version and when user runs the program in a different machine, this path would change. I thought this would be the ideal behaviour.


Oh my tongue.gif I liked it better without that feature. Middle way: Option for disabling it?
Go to the top of the page
+Quote Post
o-l-a-v
post May 11 2014, 12:20
Post #729





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



With john33's newest OGG Vorbis build, TAC does not work.

Logs.zip: http://www43.zippyshare.com/v/71524102/file.html
Go to the top of the page
+Quote Post
lvqcl
post May 11 2014, 12:37
Post #730





Group: Developer
Posts: 3383
Joined: 2-December 07
Member No.: 49183



QUOTE (o-l-a-v @ May 11 2014, 15:20) *
With john33's newest OGG Vorbis build, TAC does not work.

Logs.zip: http://www43.zippyshare.com/v/71524102/file.html

Does it mean that older versions of oggenc2.exe work? Because in the logs I can see:

-q 6 "C:\Users\Olav\AppData\Local\Temp\TAudioConverter\{7A6EEEFF-D09D-46C4-AED6-45147EF01F60}.wav" -o "C:\Users\Olav\Desktop\TAC\\\{DDE59462-42AE-46A0-AC41-FDE632037333}.ogg"

...and all versions of oggenc2 that I tried refuse to work with such paths.
Go to the top of the page
+Quote Post
ozok
post May 11 2014, 14:20
Post #731





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



I think something I changed caused it. These should fix this problem.
32bit TAC.exe http://www55.zippyshare.com/v/46842244/file.html
64bit TAC.exe http://www55.zippyshare.com/v/34165405/file.html

This post has been edited by ozok: May 11 2014, 14:20
Go to the top of the page
+Quote Post
o-l-a-v
post May 14 2014, 02:04
Post #732





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



QUOTE (ozok @ May 11 2014, 14:20) *
I think something I changed caused it. These should fix this problem.
32bit TAC.exe http://www55.zippyshare.com/v/46842244/file.html
64bit TAC.exe http://www55.zippyshare.com/v/34165405/file.html

Did not fix it. Still gets error.
Go to the top of the page
+Quote Post
ozok
post May 21 2014, 16:06
Post #733





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



New beta2 0.9.5 build 3684 changes:
QUOTE
Added: Several presets for mp3, aac and ogg vorbis
Added: Skinning is disabled as default
Added: TAC will rename encoded files on the fly
Added: Playback now stops at end point (cue, trim etc)
Added: Custom file/folder help is a text file instead of a message box
Fixed: Triple "\" in file path would cause some encoders to fail
Fixed: Cover art image path was written as a tag
Fixed: Couldn't write/read total track and disc no flac tags
Fixed: Stopping cd ripping didn't reset UI elements
Fixed: ID3v1 now has the lowest reading priority
Fixed: Encoding speed information was missing in cd ripping
Fixed: Track no and track count tags read from ID3v2 weren't parsed properly
Fixed: Lame channel option wasn't loaded/saved properly
Fixed: Controls in "Codec Options" window no longer look as if they are disabled
Updated: Tag libraries

Download: https://bitbucket.org/ozok/taudioconverter-...erter/downloads

This post has been edited by ozok: May 21 2014, 16:07
Go to the top of the page
+Quote Post
eahm
post May 21 2014, 16:26
Post #734





Group: Members
Posts: 1085
Joined: 11-February 12
Member No.: 97076



Good release ozok and thanks for this "Added: Skinning is disabled as default".


--------------------
/lwAsIimz
Go to the top of the page
+Quote Post
ozok
post May 21 2014, 20:49
Post #735





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



Thanks eahm. This should also fix problems with oggenc2 due to "\\\" in file path.
Go to the top of the page
+Quote Post
ozok
post Jun 21 2014, 13:28
Post #736





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



0.9.5 change log:
QUOTE
-Added: [General] "Merge Audio" mode
-Added: [General] Several presets for aac, mp3 and ogg vorbis
-Added: [General] An option to use MediaInfo or libraries from 3delite.hu to read tags
-Added: [General] TAC will rename files right after they are encoded
-Added: [General] TAC will try to create temp folder at startup
-Added: [General] "Filters" button's icon will go grey if filters are disabled
-Added: [General] "Create log.zip" option to "Help" menu
-Added: [General] TAC will remember it's last position, window state and size
-Added: [General] Number of files will be shown at the bottom of the file list
-Added: [General] "Title", "Album", "Artist" and "Genre" columns to file list (thx to o-l-a-v)
-Added: [General] Clicking to column in the file list will sort the list (thx to o-l-a-v)
-Added: [General] "Album Artist" (%albumartist%) tag to custom folder/file option
-Added: [General] Improved FLAC tag writing and reading
-Added: [CDRipper] Will now ask confirmation when user wants to stop ripping
-Added: [General] A few minor features and UI changes
-Added: [General] Skinning is disabled as default
-Fixed: [General] TAC couldn't rename some files if "Custom Folder Tree" was selected and tags contained invalid chars (thx to o-l-a-v)
-Fixed: [General] TAC wouldn't search external gif and bmp artwork files
-Fixed: [General] TAC wouldn't pad track no when "Custom folder tree" was selected
-Fixed: [General] TAC didn't respect start/end points during playback
-Fixed: [General] Codec list and related controls didn't resize/move when window was resized
-Fixed: [General] Main window's dimensions are now smaller
-Fixed: [General] Custom folder tree would fail with some cue files
-Fixed: [General] Lame channel option wasn't saved/loaded propery
-Fixed: [CDRipper] Wouldn't restore window title and menu items when stopped by user
-Fixed: [CDRipper] Wouldn't write artwork to ogg/opus files due to a bug in tag library
-Fixed: [CDRipper] Encoding speed information was missing
-Fixed: [TTagger] A bug where tags couldn't be written because external artwork file was being used by an other process (thx to o-l-a-v)
-Fixed: [TTagger] A bug where ttagger would write cover art path as a tag
-Updated: Opusenc to 0.1.8-git (using libopus 1.1.x-git)
-Updated: Tag libraries
-Updated: QAAC to 2.41
-Updated: RefAlac to 1.41


Known issues:
QUOTE
-Skinning option is not saved


Download
Source
Go to the top of the page
+Quote Post
Meeko
post Jul 2 2014, 13:58
Post #737





Group: Members
Posts: 82
Joined: 24-December 09
From: New York
Member No.: 76308



Hi ozok. I continue to love using this converter, even over foobar in some instances.

Question, where is this "merge" files function on the latest release? I can't find it. Is it similar to foobar2000 when it allows you to output converted files into one file?

Thanks again. smile.gif


--------------------
foobar2000, FLAC, and qAAC -V68
It just works people!
Go to the top of the page
+Quote Post
ozok
post Jul 2 2014, 14:01
Post #738





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



It's in the "Method" list. See bottom right here: http://i.imgur.com/QYzRnen.png
Go to the top of the page
+Quote Post
Meeko
post Jul 2 2014, 14:29
Post #739





Group: Members
Posts: 82
Joined: 24-December 09
From: New York
Member No.: 76308



I feel sheepish for not having looked there! beer.gif

Ran a test album, and I probably forgot to select certain things....no tags and no artwork in the merge mode. Foobar at least gives you a starting point to re-tag. Maybe this doesn't work in merge mode when you have a various artist album. I have it set from "copy tags from source".


--------------------
foobar2000, FLAC, and qAAC -V68
It just works people!
Go to the top of the page
+Quote Post
ozok
post Jul 2 2014, 18:29
Post #740





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



Yes, tags aren't written in that mode. But I'll add a way to do it.
Go to the top of the page
+Quote Post
Meeko
post Jul 6 2014, 14:35
Post #741





Group: Members
Posts: 82
Joined: 24-December 09
From: New York
Member No.: 76308



Sounds like a good plan for a future update. smile.gif Your work has been most appreciated for those who want the cream-of-the-crop of converters.


--------------------
foobar2000, FLAC, and qAAC -V68
It just works people!
Go to the top of the page
+Quote Post
o-l-a-v
post Aug 17 2014, 21:43
Post #742





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



TAC 0.9.5 build 3969 has some tagging bugs. It does not write external artwork to opus output (when not using TTagger), and it cuts names (when renaming output) even though the tags looks like they got preserved. Rename bug appears both with and without TTagger as tagger

Logs: https://mega.co.nz/#!L5YgxB4I!54I_V...g6lUisIYBOY2Tcs
Go to the top of the page
+Quote Post
ozok
post Aug 17 2014, 21:53
Post #743





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



Thanks o-l-a-v, I've noticed the same problem with some files too. I think the problem occurs when there is a dot right before the end of file name (in my case it is "...And Justice For All"). I haven't found a solution yet. Let me check artwork bug.

EDIT: I think I've found a solution to truncated file name problem. Thanks again.

This post has been edited by ozok: Aug 17 2014, 22:49
Go to the top of the page
+Quote Post
ozok
post Aug 18 2014, 22:23
Post #744





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



I've also fixed opus artwork problem. I'll prepare a beta asap.
Go to the top of the page
+Quote Post
ozok
post Aug 19 2014, 12:29
Post #745





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



0.9.6 beta update changes:
CODE
-Added: Progress list now shows a new item for each step
-Added: Opus profiles
-Fixed: Skin enable/disable option wasn't saved
-Fixed: CD ripping would fail if no tag info was found or no internet connection existed
-Fixed: Writing artwork to OPUS files with opusenc failed (thx to o-l-a-v)
-Fixed: Writing artwork to files ripped from CD with encoders didn't work
-Fixed: "JPEG error #53" when refreshing cd track list
-Fixed: Empty file name problem if "Custom folder tree" was selected and a tag contained a dot (thx to o-l-a-v)
-Fixed: Updater showed an update while there wasn't one
-Fixed: File adding duration info was wrong
-Fixed: A few interface problems

You can download beta update here.
Please note that packages above only include portable TAudioConverter.exe, changelog.txt and some profiles. You'll need to have portable package of v0.9.5.
Go to the top of the page
+Quote Post
o-l-a-v
post Aug 19 2014, 14:04
Post #746





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



Thanks ozok! smile.gif

Suggestion: To create and save custom presets would be awesome. I'm not really likely to use any of the presets, so would be very useful if one could save current configuration or something like that
Go to the top of the page
+Quote Post
ozok
post Aug 20 2014, 12:19
Post #747





Group: Members
Posts: 308
Joined: 9-December 12
From: Eskişehir
Member No.: 105075



New version 0.9.6 changes:
CODE
-Added: [General] Progress list now shows a new item for each step
-Added: [General] Opus profiles
-Added: [General] Tag editor for audio merging (thx to Meeko)
-Fixed: [General] Skin enable/disable option wasn't saved
-Fixed: [CDRipper] CD ripping would fail if no tag info was found or no internet connection existed
-Fixed: [General] Writing artwork to OPUS files with opusenc failed (thx to o-l-a-v)
-Fixed: [CDRipper] Writing artwork to files ripped from CD with encoders didn't work
-Fixed: [CDRipper] "JPEG error #53" when refreshing cd track list
-Fixed: [General] Empty file name problem if "Custom folder tree" was selected and a tag contained a dot (thx to o-l-a-v)
-Fixed: [General] Updater showed an update while there wasn't one
-Fixed: [General] File adding duration info was wrong
-Fixed: [General] A few interface problems
-Updated: opusenc to 0.1.9
-Updated: QAAC to 2.42
-Updated: RefAlac to 1.42
-Updated: FDKAAC to 0.6.0

Source
Download
Go to the top of the page
+Quote Post
o-l-a-v
post Aug 20 2014, 15:17
Post #748





Group: Members
Posts: 129
Joined: 18-July 12
From: Norway
Member No.: 101545



QUOTE (ozok @ Aug 20 2014, 12:19) *
TAC(0.9.6)

You are the boss Ozok! emot-v.gif Thanks

This post has been edited by o-l-a-v: Aug 20 2014, 15:23
Go to the top of the page
+Quote Post
Wombat
post Aug 20 2014, 18:42
Post #749





Group: Members
Posts: 1040
Joined: 7-October 01
Member No.: 235



Hi ozok! I don't follow this project much, sorry. I saw you have support for the flacCL encoder of CUEtools included already. What about adding the CUEtools flake and the ALAC encoder with its additional compression options?
I just added recent versions here: http://www.hydrogenaud.io/forums/index.php?showtopic=106446
I think Mr. Grigory Chudov, the CUEtools developer won't complain.
Go to the top of the page
+Quote Post

30 Pages V  « < 28 29 30
Reply to this topicStart new topic
4 User(s) are reading this topic (4 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 22:46