IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
CUI/DarkOne: broken playlist grouping/sorting or tags, Split From: Library album lists (73982) (TOS #5)
emericaska8r
post Nov 16 2009, 19:29
Post #1





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



I am getting the same problem, using column UI. Sometimes I'll notice a slight error in tags and notice this has been the problem, yet a lot of the time the tags are identical except for the song name and the problem still occurs. Any suggestions??
Go to the top of the page
+Quote Post
tpijag
post Nov 16 2009, 20:25
Post #2





Group: Members
Posts: 2349
Joined: 19-May 08
Member No.: 53637



If the tags are identical, you would NOT have the problem. The issue could be subtle, nonetheless it is there.
Follow post #7 closely and you may find the error.

terry

If you still have trouble, everybody like screenshots. biggrin.gif

This post has been edited by tpijag: Nov 16 2009, 20:26
Go to the top of the page
+Quote Post
emericaska8r
post Nov 17 2009, 00:47
Post #3





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



yea, most of the time there is a slight difference in id3 tags, but check this out:
Go to the top of the page
+Quote Post
tpijag
post Nov 17 2009, 01:09
Post #4





Group: Members
Posts: 2349
Joined: 19-May 08
Member No.: 53637



Maybe posting the playlist grouping titleformat code for your playlist will help

terry

Edit: You might also try the following. Select all the tracks for the album. Properties >Select the Album Title and Artist fields > Right click > Clean up
This will get rid of Trailing spaces which will be seen as different values


This post has been edited by tpijag: Nov 17 2009, 01:23
Go to the top of the page
+Quote Post
emericaska8r
post Nov 17 2009, 01:36
Post #5





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



this is the format code:
CODE
$if2(%artist%,<no artist>)[ / %album%]

not seeing any spaces in the artist or album fields but thanks for the suggestion
Go to the top of the page
+Quote Post
tpijag
post Nov 17 2009, 02:03
Post #6





Group: Members
Posts: 2349
Joined: 19-May 08
Member No.: 53637




By the way, How does one see a trailing space.

terry
Go to the top of the page
+Quote Post
emericaska8r
post Nov 17 2009, 06:58
Post #7





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



so a trailing space is something other than a random space after a name or something?... suppose i'll try out what you suggested then and see what happens

[edit] yea that didn't do anything.. could it be because i have a custom skin messing it up? i don't think i had this problem before the skin...

This post has been edited by emericaska8r: Nov 17 2009, 07:02
Go to the top of the page
+Quote Post
tedgo
post Nov 17 2009, 09:58
Post #8





Group: Members
Posts: 1089
Joined: 16-April 04
From: Bavaria, Germany
Member No.: 13548



This skin doesn't change the grouping or sort pattern of the ng playlist wink.gif.
It uses the default sort pattern of foobar2000/Columns UI (%path_sort%).
NG Playlist group pattern isn't saved to the FCL-file, that contains the informations for the Columns UI configuration.

And it looks like your files are not named with the leading tracknumber (e. g. "05. Dull Life.mp3" but "Dull Life.mp3").
So your files are sorted alphabetically, but strange, it looks like your path sortingis reversed...

Do you have all your files in one folder?
Or do you have separated album folders?

There is a second playlist view. Is it sorted the same as in NG Playlist?
Please tell me what is your sort pattern for incoming files (Preferences --> General)?
Go to the top of the page
+Quote Post
emericaska8r
post Nov 17 2009, 10:24
Post #9





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



I have separate folders for each artist and subfolders for each album.
The incoming sort pattern is
CODE
%path_sort%

in all other views my albums seem to group fine. they are just all split up in the default view
Go to the top of the page
+Quote Post
tedgo
post Nov 17 2009, 10:34
Post #10





Group: Members
Posts: 1089
Joined: 16-April 04
From: Bavaria, Germany
Member No.: 13548



With "default view" you mean the NG Playlist (the playlist shown on your screenshot)?
That's strange, the other Playlist view (ELPlaylist) uses the same sort pattern.

Is it wrong sorted on all playlists or only on the "Default" playlist?
Have you anytime sorted it manually?

Please try the following:
Toolbar --> Edit --> Sort --> Sort by File Path
If your files are named with a leading tracknumber (and i assume it as you said, the sorting is ok in all other views) it will sort your playlist correctly again.

This post has been edited by tedgo: Nov 17 2009, 10:35
Go to the top of the page
+Quote Post
Robertina
post Nov 17 2009, 10:51
Post #11





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



If each artist has his separate folder with subfolders for each album and the filenames include leading tracknumbers, what about something like this?

CODE
$replace(%path%,\%filename_ext%,) %filename%
Go to the top of the page
+Quote Post
tedgo
post Nov 17 2009, 10:52
Post #12





Group: Members
Posts: 1089
Joined: 16-April 04
From: Bavaria, Germany
Member No.: 13548



Should be (nearly) the same like %path_sort% wink.gif

This post has been edited by tedgo: Nov 17 2009, 10:53
Go to the top of the page
+Quote Post
emericaska8r
post Nov 17 2009, 11:10
Post #13





Group: Members
Posts: 14
Joined: 16-November 09
Member No.: 75001



QUOTE (tedgo @ Nov 17 2009, 10:34) *
With "default view" you mean the NG Playlist (the playlist shown on your screenshot)?
That's strange, the other Playlist view (ELPlaylist) uses the same sort pattern.

Is it wrong sorted on all playlists or only on the "Default" playlist?
Have you anytime sorted it manually?

Please try the following:
Toolbar --> Edit --> Sort --> Sort by File Path
If your files are named with a leading tracknumber (and i assume it as you said, the sorting is ok in all other views) it will sort your playlist correctly again.

THANK YOU! Yea that must have been it. When I clicked sort by file path it worked, as well as when I click sort by album or any of the other options for that matter -- not sure what it was set to sort to earlier then, but no matter. thanks for the persistent replies.
And yes I suppose I mean NG Playlist when I said "default" as I meant the one in my screenshot (sorry I don't know all the foobar jargon). Anyways, thanks again.
Go to the top of the page
+Quote Post
Robertina
post Nov 17 2009, 11:11
Post #14





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



From titleformat_help.html in foobar's folder:

QUOTE
%path_sort%: Path of the file; for use with sorting, where order of subsongs within a file needs to be preserved; exact value returned by it is undefined and should not be relied on.

That's why I thought my proposal could make possibly sense.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th August 2014 - 08:56