IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Pops and clicks using official ASIO in Windows 8 with foobar, but no p, Please add more priority options
PelPix
post Sep 22 2012, 06:01
Post #1





Group: Members
Posts: 6
Joined: 30-January 12
Member No.: 96797



Microsoft seems to have written a new scheduler for handling tasks better in 8, and it works, but the priority settings now mean different things, and anything below the redesigned "Realtime" setting means it's handled in a way that is not suitable for audio playback on some ASIO drivers, so it pops at every latency. The easiest solution is to add ALL of the priority options to the ASIO component instead of just having a tickbox for "high priority."

This post has been edited by PelPix: Sep 22 2012, 06:12
Go to the top of the page
+Quote Post
PelPix
post Oct 5 2012, 23:04
Post #2





Group: Members
Posts: 6
Joined: 30-January 12
Member No.: 96797



Windows 8 users, if you're experiencing pops, try the fix for yourself!
Open Task Manager and set the ASIO host's priority to real-time. Problem solved!
Go to the top of the page
+Quote Post
fuflo
post Oct 5 2012, 23:54
Post #3





Group: Members
Posts: 103
Joined: 18-May 06
Member No.: 30902



are you using native asio drivers or asio4all? personally, with tascam us-144mkII i had/have no issues with asio at all ( native driver ) on win8.
Go to the top of the page
+Quote Post
PelPix
post Oct 19 2012, 03:52
Post #4





Group: Members
Posts: 6
Joined: 30-January 12
Member No.: 96797



QUOTE (fuflo @ Oct 5 2012, 18:54) *
are you using native asio drivers or asio4all? personally, with tascam us-144mkII i had/have no issues with asio at all ( native driver ) on win8.


Native. Setting priority to "Realtime" universally fixes them, and has caused no instability in 10 continuous hours of use (so faR).
Go to the top of the page
+Quote Post
neograniceni
post Nov 15 2012, 21:43
Post #5





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



Would be really nice if such an option to set asio host priority to realtime would be implemented in some future release.

This post has been edited by neograniceni: Nov 15 2012, 21:45
Go to the top of the page
+Quote Post
neograniceni
post Nov 16 2012, 14:50
Post #6





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



QUOTE (PelPix @ Oct 5 2012, 23:04) *
Windows 8 users, if you're experiencing pops, try the fix for yourself!
Open Task Manager and set the ASIO host's priority to real-time. Problem solved!


Well, the problem is that foobar closes/reopens ASIO host every time you start to play song, or when the song is paused/stopped, and it's priority is reset to normal or high which is not enough to work without problems under Win8. So I made a little tray tool to detect and set/keep ASIOhost32.exe or ASIOhost64.exe priority to realtime. Will test it today, and if everything would work I'll share it here.
Go to the top of the page
+Quote Post
neograniceni
post Nov 16 2012, 17:53
Post #7





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



Well, here it is. It works OK for me using foobar 1.1.16, ASIO 2.1.2, Asus Xonar ST with Unixonar driver 1.64 and Windows 8 Pro x64. You can put this to your startup if you want. You can download it from here. Disclaimer: use it on your own responsibility.

Edit: just found there could be multiple asiohosts opened at the same time in foobar. e.g. if you open asio properties from settings while playing music through asio out, or vice versa. Only the first (oldest) asiohost process will be set to realtime priority. I have no intention to deal with that 'coz messing with the ASIO settings while playing music is not something we should be doing anyway. Hope foobar will get an option to set ASIO host realtime priority in some future release, so this tool would become unnecessary.

This post has been edited by neograniceni: Nov 16 2012, 18:29
Go to the top of the page
+Quote Post
neograniceni
post Nov 24 2012, 21:10
Post #8





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



BTW be sure to run it as an administrator (give admin privileges to the shortcut or .exe file) !
Go to the top of the page
+Quote Post
neograniceni
post Feb 23 2013, 19:28
Post #9





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



Version 1.1. update: no longer need to run as administrator, now runs through Windows UAC. Link is the same as above.
Go to the top of the page
+Quote Post
tato
post Sep 8 2013, 06:33
Post #10





Group: Members
Posts: 1
Joined: 8-September 13
Member No.: 109997



QUOTE (neograniceni @ Nov 15 2012, 21:43) *
Would be really nice if such an option to set asio host priority to realtime would be implemented in some future release.


This is just to report that I experienced that ASIO host real time priority is crucial for ASIO Lynx driver running in win 7.
Even in a system where latency looks not to be an issue.

Infact, I was looking for a workaround for my Lynx two B card (thanks for the nice piece of software).
I strongly encourage to implement real time priority choice in foobar ASIO tab.
As far as I checked in my system (Athlon 64x2 3600+) it does not affect stability.
Go to the top of the page
+Quote Post
neograniceni
post Nov 30 2013, 15:15
Post #11





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



Seems the problem no longer exists in Win 8.1. foobar 1.2.9, Asus Xonar ST with latest Asus driver, not a single pop/skip since Win8 -> Win8.1 upgrade.
Go to the top of the page
+Quote Post
neograniceni
post Dec 1 2013, 15:26
Post #12





Group: Members
Posts: 7
Joined: 15-November 12
Member No.: 104548



QUOTE (neograniceni @ Nov 30 2013, 15:15) *
Seems the problem no longer exists in Win 8.1. foobar 1.2.9, Asus Xonar ST with latest Asus driver, not a single pop/skip since Win8 -> Win8.1 upgrade.


Huh, the problem is back unsure.gif .
Go to the top of the page
+Quote Post
Propheticus
post Dec 1 2013, 16:47
Post #13





Group: Members
Posts: 219
Joined: 10-September 11
Member No.: 93615



Check your anti-virus/firewall settings. Some cause high DPC latencies on network interfaces when surfing the web and even more so when torrrenting. This causes the system to be unable to process audio/low latency tasks properly. When you encounter this issue a next time use LatencyMon to see if/which drivers are causing the high DPC latency. In my case Avast Internet Security's Firewall caused ndis.sys (network driver interface) latency to spike. Malwarebytes Anti-Malware's Malicious website blocking feature does as well.
My 'solution' (more like a workaround) was uninstalling the Avast firewall and revert to using Windows 8.1's built in firewall and disabling the malicious website blocking* in MBAM.

Also, the Asus drivers are pretty awful. Try these: http://maxedtech.com/asus-xonar-unified-drivers/

*; Have got features like this already anyway in Chrome itself and via OpenDNS web filtering and Avast browser plugin.

This post has been edited by Propheticus: Dec 1 2013, 16:51
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th August 2014 - 13:42