IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

20 Pages V  « < 17 18 19 20 >  
Reply to this topicStart new topic
Running Foobar in Linux, Alien Cats crossbreeding with Penguins
klonuo
post Mar 7 2012, 22:22
Post #451





Group: Members
Posts: 258
Joined: 29-April 10
Member No.: 80274



Wine 1.4 released in the wild: http://www.winehq.org/news/2012030701
Go to the top of the page
+Quote Post
pletter
post May 29 2012, 12:08
Post #452





Group: Members
Posts: 1
Joined: 29-May 12
Member No.: 100254



I have done a new installation of foobar because a fresh start of my lubuntu pc. I can't set the sound options in Wine to emulation like described in the first post in this topic (the option isn't there anymore). But now the sound is stuttering when i am browsing (especially when scrolling down webpages like forums).

Anyone a solution?
Go to the top of the page
+Quote Post
southisup
post May 29 2012, 16:00
Post #453





Group: Members
Posts: 251
Joined: 28-October 05
Member No.: 25414



You could use Synaptic Package Manager to force a downgrade to Wine 1.2.3 and lock it there, possibly requiring you to edit your sources if it's not available.
You could try regedit as detailed several posts back in this thread.
Or you could remove Pulse Audio entirely and use Alsa.
Or if you have a copy of Windows you could run it in a virtual machine, which is what I'm beginning to suspect may be the best long term solution.
Go to the top of the page
+Quote Post
Matyas
post Jun 1 2012, 13:36
Post #454





Group: Members
Posts: 158
Joined: 8-August 03
From: Bratislava
Member No.: 8242



Use the newly created winepulse (1.5.2 or newer with pulseaudio driver by Maarten Lankhorst). The configuration to use the pulseaudio driver is a bit tricky and honestly, I forgot how did I do it the last time. However, audio is again stable as it should be.
Drawbacks: the wine developers did not accept this change AGAIN into the trunk, therefore its future is unsure.

Resources:
http://repo.or.cz/w/wine/multimedia.git
https://launchpad.net/~ubuntu-wine/+archive/ppa
https://launchpad.net/~alexandre-montplaisi...chive/winepulse
Go to the top of the page
+Quote Post
Tilpo
post Jun 6 2012, 15:18
Post #455





Group: Members
Posts: 20
Joined: 16-June 10
Member No.: 81552



I'm a bit of a noob when it comes to Linux.

I am still unable to stop the audio from stuttering in foobar, I've tried some of the things mentioned in this thread but it does not yet work.
I use Wine 1.5.5, and Ubuntu 12.4. I tried uninstalling PulseAudio or editting the hardware accelaration settings but that doesn't work. When I remove PulseAudio as per instruction of the post someone linked in this thread I don't get any sound at all in foobar2000.

I also tried downgrading to a lower version of Wine, but I don't know how since I keep getting an error when I try to compile Wine 1.2.3 from source ("error: no suitable flex found. Please install the 'flex' package.")
Go to the top of the page
+Quote Post
southisup
post Jun 8 2012, 08:22
Post #456





Group: Members
Posts: 251
Joined: 28-October 05
Member No.: 25414



QUOTE (Tilpo @ Jun 7 2012, 00:18) *
I also tried downgrading to a lower version of Wine, but I don't know how since I keep getting an error when I try to compile Wine 1.2.3 from source ("error: no suitable flex found. Please install the 'flex' package.")

You could try:
http://packages.ubuntu.com/oneiric/otheros...ne1.2#pdownload
Go to the top of the page
+Quote Post
Tilpo
post Jun 8 2012, 12:53
Post #457





Group: Members
Posts: 20
Joined: 16-June 10
Member No.: 81552



QUOTE (southisup @ Jun 8 2012, 08:22) *
QUOTE (Tilpo @ Jun 7 2012, 00:18) *
I also tried downgrading to a lower version of Wine, but I don't know how since I keep getting an error when I try to compile Wine 1.2.3 from source ("error: no suitable flex found. Please install the 'flex' package.")

You could try:
http://packages.ubuntu.com/oneiric/otheros...ne1.2#pdownload

Thanks!

I now got it to work somehow without stuttering audio. Some visualizations are a bit laggy now, but nothing bad.
With this I think I'll keep using Linux. No foobar2000 would have been a deal breaker and I would have gone back to Windows.

This post has been edited by Tilpo: Jun 8 2012, 12:54
Go to the top of the page
+Quote Post
PiroXiline
post Jul 18 2012, 17:51
Post #458





Group: Members
Posts: 7
Joined: 8-September 11
Member No.: 93580



Hello everyone.
The problem I have, is a heavy CPU load (near 80% from foobar2000 + wineserver processes on both 1600 MHz cores) with any type of audio files (Hz or bits), but when playback is stopped or set Foobar to "null output" device - load falls to 0. I trying both default pulseaudio and alsa (with direct hw usage and dmix).
If anyone has any ideas, please help.

This post has been edited by PiroXiline: Jul 18 2012, 18:05
Go to the top of the page
+Quote Post
aliendesaster
post Jul 18 2012, 19:12
Post #459





Group: Members
Posts: 129
Joined: 29-December 03
From: Berlin
Member No.: 10789



Yes, this is with current wine 1.5 here too. If you downgrade to wine 1.4.1 problem should vanish.
Go to the top of the page
+Quote Post
skamp
post Jul 18 2012, 19:48
Post #460





Group: Developer
Posts: 1443
Joined: 4-May 04
From: France
Member No.: 13875



fb2k uses 10% and wine 1.5.8 takes 6% here (Arch Linux).


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
PiroXiline
post Jul 18 2012, 23:17
Post #461





Group: Members
Posts: 7
Joined: 8-September 11
Member No.: 93580



aliendesaster: Thanks. Roll back to 1.4 works for me. I think it was new resampler introduced in 1.5.4.
Go to the top of the page
+Quote Post
PiroXiline
post Aug 3 2012, 23:27
Post #462





Group: Members
Posts: 7
Joined: 8-September 11
Member No.: 93580



Now I tried Wine 1.5.10, works perfectly. Again thank you all.
Go to the top of the page
+Quote Post
Melomane
post Oct 20 2012, 09:14
Post #463





Group: Members
Posts: 643
Joined: 13-January 03
From: Marseille
Member No.: 4552



ubuntu 12.04
wine 1.4

perfect sound

open folder work fine

somes littles draw problems with default user interface
album list, enter dont play

No draw problem using column UI


--------------------
Music is my first love.
Go to the top of the page
+Quote Post
southisup
post Nov 14 2012, 13:09
Post #464





Group: Members
Posts: 251
Joined: 28-October 05
Member No.: 25414



It doesn't seem to have come up before so this is presumably blindingly obvious to everyone except me, but in case there's someone else out there unlucky enough not to know more than I do, here's how to add a directory on a NAS / Samba / SMB / Network share, as foobar2000's media library:

Open up Wine configuration
Switch to the Drives tab
Press Add...
Choose a letter you like the look of, & press OK
Enter the path:
CODE
/home/<yourusername>/.gvfs
& press OK

Now in foobar2000 media library config you can browse to your networks shares at that drive letter under My Computer.

Almost certainly this is neither the only nor the best way.
Go to the top of the page
+Quote Post
kode54
post Nov 27 2012, 05:05
Post #465





Group: Admin
Posts: 4618
Joined: 15-December 02
Member No.: 4082



Interesting issue that I'm having with the DSP Manager page of Preferences:



It's not that the icons fail to load on the buttons, it's that both the list views are disabled.
Go to the top of the page
+Quote Post
Ynn
post Nov 27 2012, 10:59
Post #466





Group: Members
Posts: 14
Joined: 11-April 09
From: France
Member No.: 68865



QUOTE (kode54 @ Nov 27 2012, 06:05) *
Interesting issue that I'm having with the DSP Manager page of Preferences:

Image

It's not that the icons fail to load on the buttons, it's that both the list views are disabled.


I have the same issue with wine 1.5.18 on Xubuntu 12.04, foobar v1.1.18.
Except that, everything is working fine with this configuration.
Go to the top of the page
+Quote Post
tere
post Dec 10 2012, 15:11
Post #467





Group: Members
Posts: 21
Joined: 27-June 06
Member No.: 32281



Everything works fine, but I have problem whit bluetooth A2DP. I buyed a bluetoot audio kit, what is connected whit my resiver. everything works fine in ubuntu, but when I start foobar to listen music then foobar just stops playing. When I open foobar and select track to play, then it plays 7sec and then just stops. any fix for that? using wine 1.4.1
Go to the top of the page
+Quote Post
tere
post Dec 20 2012, 10:00
Post #468





Group: Members
Posts: 21
Joined: 27-June 06
Member No.: 32281



Problem fixed after installed latest wine.
Go to the top of the page
+Quote Post
PiroXiline
post Mar 29 2013, 01:26
Post #469





Group: Members
Posts: 7
Joined: 8-September 11
Member No.: 93580



I am writing for other who wants make direct streaming works.
I use Peter's WASAPI plugin (from official site), and choose "push (my output device)" and direct streaming works (I have already modified ~/.asoundrc for direct use of hw card).
I've got no mixing, but I want it that way.
The problem for me was that Wine by default uses dmix, and mixing all out in 16bit 44kHz.
All other workarounds didn't work for me (sending variable ALSA_DEFAULT_PCM= to wine; tuning ~/.asoundrc, wine registry keys and values).
Go to the top of the page
+Quote Post
R. Daneel
post Jun 14 2013, 19:43
Post #470





Group: Members
Posts: 1
Joined: 14-June 13
Member No.: 108662



For those who struggle with high CPU use:

Do not show visualizations in your columns. See the following numbers:
% CPU use for Foobar 1.2.6 (Wineserver 1.4)
with Spectrum on top: 40% (10%)
with other visualizations: 12% (4%)
without visualisations: 6% (2%)

It's rather obvious in hindsight but it took me a long time to figure it out so I hope this helpes some people.

This post has been edited by R. Daneel: Jun 14 2013, 19:44
Go to the top of the page
+Quote Post
Hakubo
post Jul 24 2013, 05:59
Post #471





Group: Members
Posts: 260
Joined: 20-April 06
Member No.: 29815



Any suggestions to get my album covers to show in NG Playlist?

The relevant value in the Artwork configuration tab is just: front.*, and all covers are inside the music folders, usually named front.jpg. They display fine in the Artwork view panel.

Here's the console output:

CODE
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:win:EnumDisplayDevicesW ((null),0,0x32dc20,0x00000000), stub!
fixme:win:RegisterShellHookWindow (0x20026): stub
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:uxtheme:BufferedPaintInit Stub ()
err:ole:CoCreateInstance apartment not initialised
err:ole:CoCreateInstance apartment not initialised
err:ole:CoCreateInstance apartment not initialised
err:ole:CoCreateInstance apartment not initialised
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599
err:ole:CoCreateInstance apartment not initialised
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT/DATA_SEND_TIMEOUT 1500
fixme:ntdll:NtPowerInformation semi-stub: SystemPowerCapabilities
fixme:process:GetSystemDEPPolicy stub
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevationType, ...) semi-stub


This post has been edited by Hakubo: Jul 24 2013, 06:01
Go to the top of the page
+Quote Post
marc2003
post Jul 24 2013, 09:25
Post #472





Group: Members
Posts: 4469
Joined: 27-January 05
From: England
Member No.: 19379



just a guess but perhaps you need to install gdiplus which is part of winetricks.
Go to the top of the page
+Quote Post
Hakubo
post Jul 24 2013, 09:29
Post #473





Group: Members
Posts: 260
Joined: 20-April 06
Member No.: 29815



Thanks, but no. It's already installed.
Go to the top of the page
+Quote Post
marc2003
post Jul 24 2013, 09:36
Post #474





Group: Members
Posts: 4469
Joined: 27-January 05
From: England
Member No.: 19379



ah well that's me out of ideas. i'm sure it used to work but i haven't touched it for a good couple of years now.

what do you see instead of the image? is it blank or does it show the the columns UI missing art image which IIRC is dark grey/black square with a musical note on it?
Go to the top of the page
+Quote Post
Hakubo
post Jul 24 2013, 14:04
Post #475





Group: Members
Posts: 260
Joined: 20-April 06
Member No.: 29815



The former. Just the color of the background, as if nothing's supposed to be there. I did make sure that the relevant checkbox is checked in the prefs, and the configuration was copied from the Windows installation anyway, where is works fine.

Does NG Playlist artwork work for you (or anyone else) in Wine? If so, maybe I'll just have to rebuild the UI layout from scratch.
Go to the top of the page
+Quote Post

20 Pages V  « < 17 18 19 20 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 01:36