IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
foo_winamp_spam 1.0.0
blackwind
post Jun 11 2013, 15:06
Post #1





Group: Members
Posts: 4
Joined: 11-June 13
Member No.: 108602



Hi all,

Recent fb2k convert here. I found that foo_winamp_spam 0.98 was lacking in a few areas, so I went ahead and fixed it:
  • Added support for getting/setting repeat track (manual playlist advance).
  • Increased compatibility by writing only the currently playing item to winamp.m3u.
  • Modified the repeat and shuffle controls to act as Winamp users would expect.
  • Removed pointless configuration options, one of which didn't function at all.
Binary is available here, source is available here. Cheers!


--------------------
/bw
Go to the top of the page
+Quote Post
Andreasvb
post Jun 11 2013, 17:18
Post #2





Group: Members
Posts: 1338
Joined: 6-March 04
From: Sweden
Member No.: 12509



Do you know why files that's encoded in Opus doesn't get registered by e.g. Trillian?

It gets listed correct in WinLister as Winamp v1.x class with correct title and everything.
But as soon as I play an MP3 Trillian detects it.

Also, please remove the Legacy Preference warning. smile.gif


--------------------
Windows 8.1u1 Pro x64 Media Center // foobar2000 1.3.3
Go to the top of the page
+Quote Post
blackwind
post Jun 11 2013, 17:48
Post #3





Group: Members
Posts: 4
Joined: 11-June 13
Member No.: 108602



QUOTE (Andreasvb @ Jun 11 2013, 09:18) *
Do you know why files that's encoded in Opus doesn't get registered by e.g. Trillian?

You'd have to consult the author of the plugin in question. If the correct information is being populated, it's Trillian at fault.

QUOTE
Also, please remove the Legacy Preference warning. smile.gif

If someone tells me how to do so, I'd love to.


--------------------
/bw
Go to the top of the page
+Quote Post
marc2003
post Jun 11 2013, 18:42
Post #4





Group: Members
Posts: 4593
Joined: 27-January 05
From: England
Member No.: 19379



QUOTE (blackwind @ Jun 11 2013, 17:48) *
QUOTE
Also, please remove the Legacy Preference warning. smile.gif

If someone tells me how to do so, I'd love to.


it needs compiling with a v1 SDK or above. the latest version supports foobar v1.1 and above only.

http://www.foobar2000.org/SDK

i'm not a developer so i have no idea if you'd have to make any changes for it to work. if you get stuck, post in the developer forum.

This post has been edited by marc2003: Jun 11 2013, 18:42
Go to the top of the page
+Quote Post
blackwind
post Jun 11 2013, 18:54
Post #5





Group: Members
Posts: 4
Joined: 11-June 13
Member No.: 108602



This is compiled with the latest SDK. Changes are definitely required. I'm not sufficiently bothered by it to go out and do the research, but I'll certainly accept input if anyone cares to offer it here.


--------------------
/bw
Go to the top of the page
+Quote Post
blackwind
post Jun 20 2013, 00:05
Post #6





Group: Members
Posts: 4
Joined: 11-June 13
Member No.: 108602



Turns out the last remaining setting was broken as well (and also of highly questionable utility), so I've gone ahead and removed the preferences dialog entirely. Files in the first post updated.


--------------------
/bw
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 22:04