IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
foobar 1.2.3b1 only left channel of AAC played
DerSchrauber
post Feb 3 2013, 15:56
Post #1





Group: Members
Posts: 1
Joined: 2-November 03
Member No.: 9612



Hi,

I've a problem playing stereo AAC (m4a) files in fb2k v1.2.3b1:
Only the left channel is played, the right channel is muted.

- I tried it with about 30 different files - all the same.
- I've tested with an clean portable install of v1.2.3b1: still the same problem.
- In the spectogram visualisation the left channel is ok, the right channel is empty.
- All files are played ok in fb2k v1.2.2.


Here some info from the file properties:
CODE
Subsong index : 0
File size : 4.14 MB (4 350 583 bytes)
Last modified : 2012-01-13 23:02:48
Duration : 4:25.160 (11 693 556 samples)
Sample rate : 44100 Hz
Channels : 2
Bitrate : 128 kbps
Codec : AAC
Codec profile : AAC LC
Encoding : lossy
Tool : iTunes 10.5.1

CODE
Subsong index : 0
File size : 2.71 MB (2 845 439 bytes)
Last modified : 2011-04-25 09:58:22
Duration : 1:16.302 (3 364 935 samples)
Sample rate : 44100 Hz
Channels : 2
Bitrate : 296 kbps
Codec : AAC
Codec profile : AAC LC
Encoding : lossy
Tool : iTunes 8.2.1, QuickTime 7.6.3

CODE
Subsong index : 0
File size : 6.22 MB (6 527 593 bytes)
Last modified : 2010-01-23 03:28:13
Duration : 4:27.703 (11 805 696 samples)
Sample rate : 44100 Hz
Channels : 2
Bitrate : 192 kbps
Codec : AAC
Codec profile : AAC LC
Encoding : lossy
Tool : iTunes v4.2, QuickTime 6.4
Track gain : +2.32 dB
Track peak : 0.605698
Album gain : +3.70 dB
Album peak : 0.962169
Go to the top of the page
+Quote Post
postED
post Feb 3 2013, 17:11
Post #2





Group: Members
Posts: 4
Joined: 6-December 09
From: Ukraine
Member No.: 75648



Confirm - only left channel works. Ogg vorbis decoding are buggy too.
Download latest Zeranoe ffmpeg build - ffplay decode vorbis and aac fine.
Go to the top of the page
+Quote Post
Peter
post Feb 3 2013, 17:22
Post #3


foobar2000 developer


Group: Admin
Posts: 3293
Joined: 30-September 01
Member No.: 84



Thanks for the report, beta 1 has been pulled until this is resolved.


Beta 2 up, bug has been fixed. Thank you for your patience.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 02:33