IPB

Welcome Guest ( Log In | Register )

32 Pages V  « < 23 24 25 26 27 > »   
Reply to this topicStart new topic
foo_vis_shpeck, Winamp visualisation plugins wrapper
romor
post Aug 25 2010, 21:51
Post #601





Group: Members
Posts: 673
Joined: 16-January 09
Member No.: 65630



Seems like, when Shpeck is embedded in UI and has focus, it interferes "mouse wheel: scroll object below pointer" option
Is this known?
Can be resolved?

I was thinking also, is windowed mode preferred over UI embedding? Because when foobar is minimized and then restored Shpeck element reinitializes, loosing info displays and chosen preset for example


--------------------
scripts: http://goo.gl/M1qVLQ
Go to the top of the page
+Quote Post
byterhythm
post Aug 29 2010, 10:24
Post #602





Group: Members
Posts: 25
Joined: 9-June 07
Member No.: 44192



QUOTE (byterhythm @ Aug 14 2010, 18:31) *
Foobar 1.1 beta breaks Shpeck.


It seems that using a relative path (.) to the plugins directory
no longer works on foobar 1.1

QUOTE (byterhythm @ Aug 14 2010, 18:31) *
In my case, the Winamp plugins like AVS and Milkdrop 2 gets detected,
but when I open a Shpeck window or 'configure' the plugins, it says that
it could not load the DLL.


- Using an absolute path to the directory fixes it.
- I have tested it on a fresh install of foobar w/ only shpeck installed
as a 3rd party component.
- And yes, the latest version of Milkdrop 2 that comes w/ Winamp 5.58
does not work. Older Milkdrop 2 versions work fine.
- Some AVS presets namely the ones made by 'NemoOrange' crashes
Shpeck/AVS/foobar when 'Pixel Doubling' is enabled on the AVS preferences.

Go to the top of the page
+Quote Post
fenrisswolf
post Sep 1 2010, 02:23
Post #603





Group: Members
Posts: 1
Joined: 1-September 10
Member No.: 83518



QUOTE (KarnEvil9 @ Aug 20 2010, 03:37) *
QUOTE (Prisoner416 @ Aug 19 2010, 16:49) *
QUOTE (KarnEvil9 @ Aug 14 2010, 20:24) *
I'm currently using the modified Milkdrop 2 package that was uploaded here, with foobar2000 1.1 beta 2. No problems.

I'm using a portable foobar install, with a fake winamp.exe in the main directory, and a plugins subdirectory containing Milkdrop 2.

Link to modded Milkdrop 2?

http://www.hydrogenaudio.org/forums/index....st&p=712461



Awesome! Thanks for re-posting it! Milkdrop is about the only visualization I run on a regular basis. Desktop mode rocks! (Now if only I could figure out a way of making milkdrop display properly on both screens of a dual head set-up, instead of just one or the other...)
Go to the top of the page
+Quote Post
RavenSoft
post Sep 8 2010, 04:34
Post #604





Group: Members
Posts: 101
Joined: 22-December 05
Member No.: 26563



Everything was working great, then suddenly today as soon as I run foobar2000 it crashes. I've narrowed it down to shpeck plugin. When I don't have shpeck setup in the options foobar2000 works fine. As soon as I setup shpeck and restart foobar2000, shpeck is causing foobar2000 to crash. I then tried the modified milkdrop 2.1 files and foobar2000 minimizes to the tray and won't crash but as soon as I bring up the foobar2000 window, foobar2000 crashes. I tried my previous 1.0 setup and both my 1.1 setup and a fresh install. I am using the xchange theme but that shouldn't be causing the problem should it? Any ideas?
Go to the top of the page
+Quote Post
RavenSoft
post Sep 8 2010, 05:50
Post #605





Group: Members
Posts: 101
Joined: 22-December 05
Member No.: 26563



guess I can't edit my own post, but I loaded up my laptop and ran the same foobar2000 config and it also gave the same error something about not being able to load more than 1 instance of the shpeck plugin or something like that. Only difference is that it didn't crash on my laptop, shpeck when white then loaded itself like normal. My computer in my post above I installed directx and its partially working, when foobar2000 starts the shpeck plugin takes the entire screen and I have to hit esc key to get it to be normal. I'm too tired to look for the option to not make it run like that but maybe someone will tell me so when I look tomorrow it will make things easier. Thanks.
Go to the top of the page
+Quote Post
xenofixus
post Sep 15 2010, 11:23
Post #606





Group: Members
Posts: 9
Joined: 10-February 07
Member No.: 40506



I am unable to get IPC_SETVOLUME working while using shpeck. The following is in c#:
SendMessage(hwnd, WM_WA_IPC, iVolume, IPC_SETVOLUME);

Now, before you go asking me questions about the code itself, I must point out that my function works correctly with both the official version of Winamp and with both the other emulation plugins (foo_winamp_ipc and foo_winamp_spam). I am using foobar v1.1 and foo_vis_shpeck 0.3.7. I enjoy the increased functionality of Shpeck in comparison to the other two (both being outdated) plugins; however, IPC_SETVOLUME is a deal breaker for me. My program needs it to function properly and I would appreciate if I could get a response/fix.
Go to the top of the page
+Quote Post
Yirkha
post Sep 16 2010, 00:06
Post #607





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



Yeah, it's broken, thanks for pointing out.

Unfortunately the old 0.3.7 codebase is long lost and the next version code is in a completely messy state and waiting for my time - so I can't just roll out a new version.

What's your use case? Would a simple binary patch be enough for you for the time being?
CODE
  Offset     foo_vis_shpeck.dll.orig   foo_vis_shpeck.dll
----------- ------------------------- --------------------
0001B91Eh             7Dh                     EBh        
1 differences total.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
xenofixus
post Sep 16 2010, 04:53
Post #608





Group: Members
Posts: 9
Joined: 10-February 07
Member No.: 40506



It is indeed enough | thanks wink.gif
Go to the top of the page
+Quote Post
dbuss1
post Sep 17 2010, 21:05
Post #609





Group: Members
Posts: 6
Joined: 17-September 10
Member No.: 83939





Here's my dual-monitor setup with it. When I go into fullscreen for milkdrop it gets messed up.. What's up with the error in the top right?
Other than that I like it a lot, thanks smile.gif
Go to the top of the page
+Quote Post
jw80
post Sep 18 2010, 00:49
Post #610





Group: Members
Posts: 1
Joined: 25-November 07
Member No.: 49051



I just switched back to foobar from Aimp. First thing I looked for was a way to get better visualizations into foobar. I found foo_vis_shpeck and wow, it's really amazing. Nice to have milkdrop in foobar.

Still, I miss some of the Aimp visualizations, especially Rabbit Hole 1.1. I thought this might be a good place to ask. Is there anyway to play Aimp visualizations (.svp Sonique files) through shpeck? If not, then is there any other foobar plugin that can do this?
Go to the top of the page
+Quote Post
cjard
post Oct 22 2010, 11:18
Post #611





Group: Members
Posts: 27
Joined: 30-July 09
Member No.: 71894



QUOTE (byterhythm @ Aug 29 2010, 10:24) *
- And yes, the latest version of Milkdrop 2 that comes w/ Winamp 5.58
does not work. Older Milkdrop 2 versions work fine.

I'm not seeing Milkdrop in the plugins list in prefs, only AVS. Wiki says to check for NSCRT.DLL but this DLL does not exist in my winamp install dir.. Anyone got any ideas? What's the most recent version of winamp that has a working Milkdrop2? I'm trying an older version of winamp (5.35) to see if it helps.. It's just installed Milkdrop 1 tho..

This post has been edited by cjard: Oct 22 2010, 11:22
Go to the top of the page
+Quote Post
Yirkha
post Oct 22 2010, 11:24
Post #612





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



http://www.hydrogenaudio.org/forums/index....st&p=720843


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
cjard
post Oct 22 2010, 11:51
Post #613





Group: Members
Posts: 27
Joined: 30-July 09
Member No.: 71894



QUOTE (cjard @ Oct 22 2010, 11:18) *
What's the most recent version of winamp that has a working Milkdrop2?


After some trial and error, the latest version of winamp i can find to work with shpeck is 556, from:
http://www.oldapps.com/winamp.php?old_winamp=249

Copying the NSCRT.DLL from this to the latest 558 version doesnt seem to help
Go to the top of the page
+Quote Post
cjard
post Oct 22 2010, 18:36
Post #614





Group: Members
Posts: 27
Joined: 30-July 09
Member No.: 71894



note that even though the 556 installer reports youre installing 555, it is truly 556 youre installing
Go to the top of the page
+Quote Post
bukem
post Oct 23 2010, 12:47
Post #615





Group: Members
Posts: 120
Joined: 14-September 03
From: Poland
Member No.: 8837



Latest version of MilkDrop 2.22 package for foobar2000 is ready.

Change log (Winamp 5.59 Full Beta 3033):
* Fixed: [vis_milk2] Unicode issues with presets editor (5.58-specific)
* Fixed: [vis_milk2] sprites.ini file lookup fix

Note: Before anybody will complain again - yes, it's on RapidShare. If you have problem with that please feel free to upload it to any other file provider yourself.

This post has been edited by bukem: Oct 23 2010, 13:10
Go to the top of the page
+Quote Post
KarnEvil9
post Oct 23 2010, 14:39
Post #616





Group: Members
Posts: 149
Joined: 16-June 05
Member No.: 22774



Thanks, bukem!


--------------------
My Last.fm Profile: http://www.last.fm/user/_Tarkus_/
Go to the top of the page
+Quote Post
Zarggg
post Oct 26 2010, 22:46
Post #617





Group: Members
Posts: 556
Joined: 18-January 04
From: bethlehem.pa.us
Member No.: 11318



QUOTE (bukem @ Oct 23 2010, 07:47) *
Note: Before anybody will complain again - yes, it's on RapidShare. If you have problem with that please feel free to upload it to any other file provider yourself.

Since I was the one who complained last time, I think it's my responsibility to post. My point/suggestion/overreaction was made at that time; I don't need to get into it again. If that's your preferred filehost, then that is your prerogative. Apologies for making a larger deal about it than it probably is.
Go to the top of the page
+Quote Post
ton
post Oct 27 2010, 00:24
Post #618





Group: Members
Posts: 75
Joined: 29-June 03
Member No.: 7453



QUOTE (bukem @ Oct 23 2010, 03:47) *
Latest version of MilkDrop 2.22 package for foobar2000 is ready.

Change log (Winamp 5.59 Full Beta 3033):
* Fixed: [vis_milk2] Unicode issues with presets editor (5.58-specific)
* Fixed: [vis_milk2] sprites.ini file lookup fix

Note: Before anybody will complain again - yes, it's on RapidShare. If you have problem with that please feel free to upload it to any other file provider yourself.


Downloaded the file twice and both times I get several errors with unpacking saying something like "Unknown method in Winamp\plugins\....
Is the file corrupted or am I doing something wrong ?
Go to the top of the page
+Quote Post
Zarggg
post Oct 27 2010, 04:56
Post #619





Group: Members
Posts: 556
Joined: 18-January 04
From: bethlehem.pa.us
Member No.: 11318



Worked fine for me; unpacked using 7zip.
Go to the top of the page
+Quote Post
KarnEvil9
post Oct 27 2010, 05:10
Post #620





Group: Members
Posts: 149
Joined: 16-June 05
Member No.: 22774



PowerArchiver extracts it just fine too.


--------------------
My Last.fm Profile: http://www.last.fm/user/_Tarkus_/
Go to the top of the page
+Quote Post
ton
post Oct 27 2010, 13:58
Post #621





Group: Members
Posts: 75
Joined: 29-June 03
Member No.: 7453



I downloaded the file again and tried it with PowerArchiver and 7zip as well and get the errors again.
7zip says "unsuppported compression method".
I don't understand what is wrong.
Go to the top of the page
+Quote Post
wharfrat73
post Oct 27 2010, 15:52
Post #622





Group: Members
Posts: 9
Joined: 8-January 06
Member No.: 26974



I got that error too using 7 zip. It looks like everything unzipped.
Go to the top of the page
+Quote Post
KarnEvil9
post Oct 27 2010, 16:21
Post #623





Group: Members
Posts: 149
Joined: 16-June 05
Member No.: 22774



QUOTE (ton @ Oct 27 2010, 04:58) *
I downloaded the file again and tried it with PowerArchiver and 7zip as well and get the errors again.
7zip says "unsuppported compression method".
I don't understand what is wrong.

I just downloaded it again, and still no problems with PowerArchiver. It not only extracted fine, but it also tested with no errors. I don't know what to tell you.


--------------------
My Last.fm Profile: http://www.last.fm/user/_Tarkus_/
Go to the top of the page
+Quote Post
Robertina
post Oct 27 2010, 20:31
Post #624





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



I see in 7-Zip's compression method column = ID 21 which means LZMA2. This method is supported since 7-Zip v9.04 beta, so trying to extract this archive with earlier versions (as 4.65 for example) would provide the error messages as mentioned I assume.
Go to the top of the page
+Quote Post
ton
post Oct 27 2010, 21:08
Post #625





Group: Members
Posts: 75
Joined: 29-June 03
Member No.: 7453



QUOTE (Robertina @ Oct 27 2010, 11:31) *
I see in 7-Zip's compression method column = ID 21 which means LZMA2. This method is supported since 7-Zip v9.04 beta, so trying to extract this archive with earlier versions (as 4.65 for example) would provide the error messages as mentioned I assume.


That did the trick. Many thanks !
Go to the top of the page
+Quote Post

32 Pages V  « < 23 24 25 26 27 > » 
Reply to this topicStart new topic
6 User(s) are reading this topic (6 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th September 2014 - 13:19