IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Failed to locate function AMDeviceNotificationGetThreadHandle, RECENT ERROR - on previously good foobar install.
TDHeller
post Apr 6 2013, 17:38
Post #1





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



Please, I KNOW this MUST have been covered here before; but I am hitting an endless loop of listings to "apparently abandoned ware" and being sent here.

Great as this forum and the information is, the posts begin in 2006 fercrissakes and don't end til last month. The thread's search function leaves me more than wanting help.
So:
I recently DL'd an APE file and installed the media Monkey component in prefs. to play it -OK But it was a whole album without cuts.
All was well until I broke it up into tracks and converted the APE to a series of MP3's with Audacity.
I now have all the track files as mp3's correctly listed and attributed HOWEVER...

I also have multiple IPOD errors when trying to SEND to IPOD - 1. IPOD Error- Failed to locate function AMDeviceNotificationGetThreadHandle
2. ERROR - DB Version 5 requires iPhoneCalc.dll. Write operations are disabled.
Needless to say I can't send files to IPOD any longer and I am unhappy mad.gif

Having searched here and netwide for over 24 hours and I can still find NO Solution to return to Synch-abillity in FooBar / IPOD land.
Does anyone have an suggestion of where to start to recover or where to get older components (IPHONCALC) ?

I fear this may be deeper than FooBar now that I have the AMDevice error listed.

Anyone? Buehler? sad.gif
Go to the top of the page
+Quote Post
db1989
post Apr 6 2013, 17:58
Post #2





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Should we assume you’re referring to foo_dop, given that you mention idevices and posted this in 3rd Party Plugins?

If so, what type of iPod do you have? If it’s relatively new at all, expect functionality neither now nor in the future from foo_dop.

Did this problem just begin suddenly? Does it only occur with the new MP3s or has it propagated retroactively to actions that previously worked for you? Has anything else changed? Have you recently updated your iPod via Apple or anything like that?

And so on. It would help to be more specific when posting rather than leaving readers to employ guesswork and follow a few circumstantial clues.

This post has been edited by db1989: Apr 6 2013, 18:00
Go to the top of the page
+Quote Post
TDHeller
post Apr 6 2013, 23:56
Post #3





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



Sorry to be so obtuse - it was not my intent.
But,
I am using a 6th gen Nano I have used this for well over a year now on Foobar without a hitch. Which is why this is so frustrating. -
and yes the problem happened very suddenly -But it happens now on ALL Files.
I have tried a windows restore at the last known working point without success.

After the problem started I did reinstall and update Itunes then Synced to the Ipod in question (I have two 6th gens & both exhibit the same behavior).

The only other thing changed from original install is I lost a D: drive a few weeks ago but recovered the music files.
They are now isolated in another drive and all I have on the reference drive are fresh files.
Did I also mention the new error I get now on start-up ?

ERROR: IPOD Manager:
Failed to locate function AMDeviceNotificationGetThreadHandle

I have tried a new installation of foobar but without luck. I don't really want to delete it since my new config is all set up and don't really want to go through that again.
Thanks for ANY IDEAS or HELP you can provide.
I will send you feedback on success or failure
Thanks for your reply.

This post has been edited by db1989: Apr 7 2013, 19:30
Reason for edit: deleting redundant full quote
Go to the top of the page
+Quote Post
db1989
post Apr 7 2013, 13:54
Post #4





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Thanks for the information.

Searching for that error on Google turns up some statements that may be relevant:
Note: With version 10.6.3 [of iTunes] (and maybe above) you get the message “Failed to locate function AMDeviceNotificationGetThreadHandle” when fb2k is started. Tested with Win 7 64-bit, foo_dop 0.6.9.6. Runs with Apple Application Support 1.3.0 and Apple Mobile Device Support 3.1.0.62 from an older iTunes.
QUOTE (tolga7t @ Oct 15 2011, 03:18) *
Just wanted to add that I, too, just a couple of hours ago updated my iphone 4 to the new iOS5 and foobar gives me an error that says "Failed to locate function AMDeviceNotificationGetThreadHandle" using the latest stable version of foobar & foo_dop.
Can you confirm that this error began occurring without either your device or your version of iTunes having been updated, whether manually or automatically?

Aside from offering info from simple searches, I don’t have the experience with foo_dop to offer any relevant speculation, but hopefully other users can be of help.

This post has been edited by db1989: Apr 7 2013, 19:32
Reason for edit: adding “[of iTunes]”, which I meant to include before but missed out
Go to the top of the page
+Quote Post
TDHeller
post Apr 7 2013, 19:09
Post #5





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



To answer your question about Updates etc. NO the Only change I know of was in converting the APE File to MP3 in Audacity which in no way can I imagine would have caused this.

Shortly AFTER that the initial failure showed up - ERROR - DB Version 5 requires iPhoneCalc.dll. Write operations are disabled.

I then tried as a last resort, Re-Installing ITunes (ver. 10?) and Reading the Database on my Nano. ALWAYS CHECKED was the item for let other sources manage my library (or some such).
Having no success there I uninstalled Itunes to save additional aggravation.

Gathering from your advice it seems a version revision may have been at fault which unfortunately becomes an issue online since Everyone i see demands they give you ONLY the Latest version.
I also have a laptop I will investigate for file locations etc. hopefully find a working combination to get up again and in sync (what a crappy reference).
1. Find IphoneCalc.dll and install
2. revert to older version of foobar perhaps more stable.

The only glitch I might anticipate is, the Main Sys is Vista-64 and the Laptop is XP-S3 but both are running in x-86 mode for foobar.
Hope it will all work out :-)

This post has been edited by db1989: Apr 7 2013, 19:30
Reason for edit: deleting redundant full quote
Go to the top of the page
+Quote Post
TDHeller
post Apr 17 2013, 15:01
Post #6





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



Here again:-) Despair is setting in now.
I have recently tried uninstalling I-tunnes and reverted to the older version which supported Foobar (10.6.3) and renamed all the .itl libraries to .old

Updated FooBar to the latest version and continue to get the dreaded "Failed to locate function AMDeviceNotificationGetThreadHandle".

As if it might matter, I am running on an Intel Q6600 through ASUS P5W-DH deluxe MOBO with 8GB OCZ ram, 4-HDD storage drives and 1-SSD drive for speedy stuff -Including Foobar and Vista-64 Pro.
All the same setup I had initially before the error mess.

I can't seem to find ANY information on this error except the "Apparently Abandoned-ware" post here. Fortunately I seem to now find my IPOD Nano 6th and can sync to it but always see this message on startup.

I've tried reverting to earlier releases of foobar v1,03 - v1.17 - v1.23 & v1.24 each has issues. Though Foo_Dop is available and seems functional in earlier releases. Any thoughts would be appreciated.
I am now using Media-Monkey as a backup but find it far less than satisfying - though it does work. I also don't think the .APE file conversion was to blame as earlier stated.
Sorry to ramble here but I seem lost and old...
Help?
Go to the top of the page
+Quote Post
TDHeller
post Apr 21 2013, 15:02
Post #7





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



If anyone is out there These are the specific symptoms I am now having with FooBar 2000 - My favorite and only player.
1. On Startup I get - Failed to Locate Function AMDeviceNotificationGetThreadHandle Then Foobar starts and Media Library is available.
2. On Sending a Music File to IPOD Nano 6th Gen (previously working) I get - DB Version 5 requires iPhoneCalc.dll write operations are disabled.
Foo_dop appears in components list under "iPhone Manager" and appears to be working except for sync. iPod Mobile Device Support is enabled in options.

I have done a complete uninstall and reinstalled FooBar ver 1.2.5 [i]Stable release[/i]. Additionally I have installed and configured (without effect) Tried with and without all apps - Lyrics Panel, Biography Panel & Playlist Manager.

I am running Win Vista-64 using Kaspersky AV with all exceptions available for Ipod (6th Gen NANO using original firmware/software program) - NO ITunes (this has no apparent effect either way).
This problem is displayed on two 6th gen NANO's.

In online searches I am unable to find iPhoneCalc.dll except on an Asian text site (unfortunately I don't read cuneiform text) nor any reference to AMDevicenotificationgetthreadhandle except the abandondendware thread here which provides a wealth of seemingly unresolved attempts at resolution.
Am I wrong? Have I missed something entirely obvious? Or is there no solution to this problem possible??

I will continue to attempt resolution but would greatly appreciate any clues as to how to proceed from here.
Thanks in advance...

This post has been edited by db1989: Apr 21 2013, 15:37
Reason for edit: pointless full-quote again
Go to the top of the page
+Quote Post
lvqcl
post Apr 21 2013, 15:11
Post #8





Group: Developer
Posts: 3325
Joined: 2-December 07
Member No.: 49183



QUOTE (db1989 @ Apr 7 2013, 16:54) *
Searching for that error on Google turns up some statements that may be relevant:
QUOTE
Note: With version 10.6.3 [of iTunes] (and maybe above) you get the message “Failed to locate function AMDeviceNotificationGetThreadHandle” when fb2k is started.

QUOTE (TDHeller @ Apr 17 2013, 18:01) *
I have recently tried uninstalling I-tunnes and reverted to the older version which supported Foobar (10.6.3) and renamed all the .itl libraries to .old

As you can see above, 10.6.3 is not supported.
Go to the top of the page
+Quote Post
TDHeller
post Apr 21 2013, 19:58
Post #9





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



QUOTE (lvqcl @ Apr 21 2013, 10:11) *
QUOTE (db1989 @ Apr 7 2013, 16:54) *
Searching for that error on Google turns up some statements that may be relevant:
QUOTE
Note: With version 10.6.3 [of iTunes] (and maybe above) you get the message “Failed to locate function AMDeviceNotificationGetThreadHandle” when fb2k is started.

QUOTE (TDHeller @ Apr 17 2013, 18:01) *
I have recently tried uninstalling I-tunnes and reverted to the older version which supported Foobar (10.6.3) and renamed all the .itl libraries to .old

As you can see above, 10.6.3 is not supported.



A very interesting search - and one which I have seen before though not really helpful.
Since this WAS working with version 10.6+ previously - so this may not be the problem.
Just in case, I have now downgraded iTunes to ver. 10.4 with the same results in both instances.

i.e. 1. On Startup I still get - Failed to Locate Function AMDeviceNotificationGetThreadHandle
2. On music transfer to IPOD still shows; DB Version 5 requires iPhoneCalc.dll write operations are disabled..

Don't mean to come off too terse here but this seems like an endless loop of frustrating failures trying to get the most simple of programs operational.
Thanks again for your help - I still have hope

Go to the top of the page
+Quote Post
TDHeller
post Apr 21 2013, 22:43
Post #10





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



[quote name='db1989' date='Apr 6 2013, 12:58' post='830306']

Should we assume you’re referring to foo_dop, given that you mention idevices and posted this in 3rd Party Plugins?

If so, what type of iPod do you have? If it’s relatively new at all, expect functionality neither now nor in the future from foo_dop.


In retrospect I will say that I have a 6th gen Nano which may be called "New At All" So should I not expect any functionality between Foobar and my Nano 6th?
This seems quite odd since it has worked well until recently. Is there Other support for IPOD's anywhere or is FooBar going the way of WinAmp and simply giving up on new tech?

Just re-reading the post for clarity into this mystifying issue.
Thanks
Go to the top of the page
+Quote Post
TDHeller
post Apr 22 2013, 02:05
Post #11





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



Is there any reason MediaFire seems to be the only DL Site for iPhoneCalc.dll and that it is currently removed or unavailable?
Still searching for a fix - apparently alone here...
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Apr 22 2013, 10:10
Post #12





Group: Members
Posts: 925
Joined: 21-December 01
From: New Zealand
Member No.: 705



Is mobile support activated in the Ipod manager settings? If so try disabling and restarting Foobar2000


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
lvqcl
post Apr 22 2013, 10:31
Post #13





Group: Developer
Posts: 3325
Joined: 2-December 07
Member No.: 49183



QUOTE (TDHeller @ Apr 22 2013, 05:05) *
Is there any reason MediaFire seems to be the only DL Site for iPhoneCalc.dll and that it is currently removed or unavailable?


It seems that iphonecalc.dll is a part of MediaMonkey
Go to the top of the page
+Quote Post
TDHeller
post Apr 22 2013, 14:32
Post #14





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



QUOTE (A_Man_Eating_Duck @ Apr 22 2013, 05:10) *
Is mobile support activated in the Ipod manager settings? If so try disabling and restarting Foobar2000



Yes this is confirmed - That with mobile device support enabled I have the error : Failed to Locate Function AMDeviceNotificationGetThreadHandle .
[i]with Mobile Device Support[/i] DISabled this error does not appear.
- however when trying to send files to IPOD I always receive the error : DB Version 5 requires iPhoneCalc.dll write operations are disabled

To Address IVQCL's statement above...
I can also confirm that iPhoneCalc.dll is a part of Media Monkey as I also have Media Monkey installed and running on this PC.

But after having copied iPhoneCalc.dll from Media Monkey to FooBar, Components Directory AND the FooBar Root Directory, both separately and together this error still occurs.

This as I said earlier all on a PC which ran FooBar wonderfully until a reformat of an accessory drive earlier this month.

Those conditions were as follows:
FooBar and all Music Libraries were stored on D:\ SATA drive with the OS on C:\ - SSD Drive.

D:\ was inadvertently reformatted and recovered (mostly).

Followed by all new DL's of Music Library to New D:\ with FooBar now residing on C:\.
All of which should be irrelevant.
But FooBar has been tried on both C: D: and E: as well, all with the same result.
Music libraries have also been tried in different locations to no avail.

Thanks so much for the interest assisting in this problem - which has now apparently turned into a test of wills between foobar and myself. All help is appreciated.

This post has been edited by TDHeller: Apr 22 2013, 14:34
Go to the top of the page
+Quote Post
TDHeller
post Apr 22 2013, 15:10
Post #15





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



QUOTE (lvqcl @ Apr 22 2013, 05:31) *
QUOTE (TDHeller @ Apr 22 2013, 05:05) *
Is there any reason MediaFire seems to be the only DL Site for iPhoneCalc.dll and that it is currently removed or unavailable?


It seems that iphonecalc.dll is a part of MediaMonkey



The It Seems link you posted from 2010 is now apparently dead - could not find remote server.
AND Musicmusics reply to the original poster (Fangs404) stated -in 2010- that this did NOT support Nano 6G.

But thanks just the same :-)

This post has been edited by TDHeller: Apr 22 2013, 15:14
Go to the top of the page
+Quote Post
q3mi4
post Nov 12 2013, 07:45
Post #16





Group: Members
Posts: 2
Joined: 10-October 13
Member No.: 110833



I guess this really is a dead-end, but I'm interested if you've found any solution, after all?
I would suggest setting up the (right version) software combination on another PC.
and, at first glance, I don't seem to have seen you stating your iOS version (if Nano 6 has one?).

I ran into this issue with iphonecalc once and tried downloading it as a separate file, then extracting it separately from iTunes setup exe, but only a complete installation of iTunes worked finally.
what I've learned from this post for myself seems to sum up 'not only avoid upgrading iOS (which I knew before), but also avoid updating iTunes'.

too bad foo_dop got abandoned... too bad Apple is unlikely to let users do it their way...
Go to the top of the page
+Quote Post
TDHeller
post Apr 15 2014, 14:51
Post #17





Group: Members
Posts: 15
Joined: 5-February 12
Member No.: 96945



QUOTE (q3mi4 @ Nov 12 2013, 02:45) *
I guess this really is a dead-end, but I'm interested if you've found any solution, after all?
I would suggest setting up the (right version) software combination on another PC.
and, at first glance, I don't seem to have seen you stating your iOS version (if Nano 6 has one?).

I ran into this issue with iphonecalc once and tried downloading it as a separate file, then extracting it separately from iTunes setup exe, but only a complete installation of iTunes worked finally.
what I've learned from this post for myself seems to sum up 'not only avoid upgrading iOS (which I knew before), but also avoid updating iTunes'.

too bad foo_dop got abandoned... too bad Apple is unlikely to let users do it their way...



Yes it certainly was a great product that unfortunately has become abandoned-ware after apple & foo-dop & apparently everyone else jumped this cool ship.
Since I couldn't find any solution that worked for me - I had to change to "media-monkey" an inferior interface IMHO but one that functions without countless contortions.
Too bad Foo-Bar I'm glad I knew you, but you've now become just another bit on the scrap heap of useless code - say Hi to MS BOB for me if you see him and hi to Win 95 as well.
Go to the top of the page
+Quote Post
foosion
post Apr 15 2014, 16:03
Post #18





Group: FB2K Moderator (Donating)
Posts: 4409
Joined: 24-February 03
Member No.: 5153



QUOTE (TDHeller @ Apr 15 2014, 14:51) *
Too bad Foo-Bar I'm glad I knew you, but you've now become just another bit on the scrap heap of useless code - say Hi to MS BOB for me if you see him and hi to Win 95 as well.
Thanks for this amusing tidbit! smile.gif While I can understand your reason for switching to another software what you said is like saying Windows 8.1 is obsolete because Word 97 is not compatible with the DOCX file format.


--------------------
http://foosion.foobar2000.org/ - my components for foobar2000
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 12:30