IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Changed behavior of 'Stop After Current', when "Reset stop-after-current when stopping" is not enabled
Robertina
post Jun 8 2009, 03:41
Post #1





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



With activated option "Stop After Current" foobar 0.9.6.8 exactly does what the option's name says.

With earlier versions of foobar2000 with Columns UI the cursor does NOT move to the next track in the playlist but remains on the file of which playing has been finished.

Is there a possibility to return to that former behavior with Columns UI?

I am listening with foobar to podcasts which I am deleting apart after hearing. Now for each file I have to move the cursor one position in the playlist back to delete the file I have heard completely.

I remember that this topic has been discussed before but till yet only DUI users have been affected. That's why I am posting my question in the "third party plugins / CUI"-forum. As well I have read foobar's change log: "Fixed weird behaviors of the 'stop after current' option."

Robertina.

foobar2000 v0.9.6.8, CUI v0.3.7.3
Go to the top of the page
+Quote Post
Robertina
post Jun 8 2009, 12:34
Post #2





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Yirkha @ Jun 8 2009, 12:35) *
FYI, there is a new maintenance release of foobar2000 out - version 0.9.6.8.

Changelog:
  • Fixed weird behaviors of the “stop after current” option.

Unfortunately with foobar2000 v0.9.6.8 I have a situation I feel very uncomfortable with.

Can someone give me some links where the "weird behaviors" of the 'stop after current'-option have been described for better understanding?

Robertina.  crying.gif

Moderation: Moved here from foobar2000 v0.9.6.8.

This post has been edited by Yirkha: Jun 8 2009, 13:03
Go to the top of the page
+Quote Post
Case
post Jun 8 2009, 12:52
Post #3





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



It was discussed in IRC. Using "Stop after current" made playback queue skip the next queued item and its behavior was broken when "Reset stop-after-current when stopping" was not set.
Go to the top of the page
+Quote Post
shakey_snake
post Jun 8 2009, 13:10
Post #4





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



QUOTE (Robertina @ Jun 7 2009, 22:41) *
With activated option "Stop After Current" foobar 0.9.6.8 exactly does what the option's name says.

With earlier versions of foobar2000 with Columns UI the cursor does NOT move to the next track in the playlist but remains on the file of which playing has been finished.
This behavior was changed in 0.9.6

QUOTE (Robertina @ Jun 7 2009, 22:41) *
Is there a possibility to return to that former behavior with Columns UI?
This is a core function, not a UI function. Columns UI has nothing to do with it.

This post has been edited by shakey_snake: Jun 8 2009, 13:12


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Yirkha
post Jun 8 2009, 13:11
Post #5





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



The behavior of this feature was changed in 0.9.6 (IIRC) to really stop after current, not on current or something like that.

But it has worked correctly only when "[x] Reset stop-after-current when stopping" was enabled. Somebody had pointed out that it doesn't work otherwise and that bug was fixed now in 0.9.6.8.

I assume that's what you are referring to here, hence I renamed this thread. And moved the other posts from the other one here, please don't do that, we read everything.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Robertina
post Jun 8 2009, 13:45
Post #6





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Yirkha @ Jun 8 2009, 14:11) *
The behavior of this feature was changed in 0.9.6 (IIRC) to really stop after current, not on current or something like that.

I fear I am a bit confused at the moment but please let me ask and explain my situation again:

As a musician I have some ten thousands of loop files which I have to organize into a suitable folder structure. Their length is < 1 minute.

Till foobar 0.9.6.7 I have heard them and then performed file operations on every single file I just have listened to, because foobar stopped ON current.

The situation now is that for each file I must scroll one position upwards.

So is there any possibility to avoid this self-acting jump to the next file? If not this would stand for some ten thousands clicks more I have to do.

Please excuse my insistence but without certainty about that I can't sleep.

Robertina.

QUOTE
I assume that's what you are referring to here, hence I renamed this thread. And moved the other posts from the other one here, please don't do that, we read everything.

It was not my intention to make a double post, sorry for this. I know that the forum is read by the moderators very accurate.


Go to the top of the page
+Quote Post
Yirkha
post Jun 8 2009, 14:10
Post #7





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



QUOTE (Robertina @ Jun 8 2009, 14:45) *
Till foobar 0.9.6.7 I have heard them and then performed file operations on every single file I just have listened to, because foobar stopped ON current.
Till 0.9.6.7 with "Reset stop-after-current after stopping" enabled disabled, till 0.9.6 with that option disabled enabled. That caused the confusion about what was fixed when.

QUOTE (Robertina @ Jun 8 2009, 14:45) *
The situation now is that for each file I must scroll one position upwards.
Yes. But it's consistent with the name of the feature. Most people use it differently - e.g. when you are leaving the computer and don't want to abort current track in the middle - in which case it has to really stop on the next track to work right. You seem to be the first one to provide real usage scenario for which the "broken" behavior was better.

QUOTE (Robertina @ Jun 8 2009, 14:45) *
So is there any possibility to avoid this self-acting jump to the next file? If not this would stand for some ten thousands clicks more I have to do.
No, it can't be overriden. The possibilities I see here:
  • Adapt to the new behavior (...)
  • If you are removing the track from the list after doing whatever with it, so the current one always stays on the top of the playlist, use foo_scheduler with action "Select track #1" trigerred by the "on playback end" event.
  • Bribe someone to make foo_stopOnCurrent component.


This post has been edited by Yirkha: Jun 8 2009, 21:49
Reason for edit: Exchanged some "enabled" and "disabled". Thank you, Chaotic.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Case
post Jun 8 2009, 15:10
Post #8





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



Since it was me who forced Peter to change the behavior to work the way I want it was only fair to make foo_stop_on_current for you. It's a bit crude but should work for your needs.
Go to the top of the page
+Quote Post
atomicknight
post Jun 9 2009, 21:42
Post #9





Group: Members
Posts: 1
Joined: 9-June 09
Member No.: 70530



Is there any chance of seeing the old behavior added back (presumably under a different name)? The component provided by Case provides somewhat of a workaround, but I've found that it doesn't seem to work properly in all cases. Unfortunately, the only reproducible case I have is that seeking to the end causes the cursor to advance to the next song (i.e. same as the behavior of "Stop After Current" in 0.9.6.8) instead of remaining on the song itself. Other (not quite reproducible) cases involve the component just not working (causes the same behavior as "Stop After Current") and also one weird case in which the song kept jumping backward when trying to play (akin to the "two steps forward, one step back" concept). I usually keep my playback order on Random, but I'm not sure if this has anything to do with the above. I do know that the reproducible issue does occur regardless of the playback order, including on a completely new install of foobar2000 (using a virtual machine).

Personally, I didn't find "Stop After Current" to be a misnomer for its previous behavior. In my mind, "Stop After Current" just means to invoke a "stop" command after the current song finishes playing, without any regard on whether the cursor should be advancing. I think the "new" behavior reduces some flexibility in navigation because it was trivial to advance to the next song under the old behavior by invoking a "next" command, whereas the new behavior prevents one-time repeats of the last song played when you're using a playback order like Random (because the "previous" command doesn't do anything).
Go to the top of the page
+Quote Post
Case
post Jun 9 2009, 22:42
Post #10





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



"Stop on Current" component doesn't work with Random playback order. It is a hack that lets playback advance to the next track but immediately calls foobar to jump to Previous track. Also you must disable "Stop After Current" when using it.
Go to the top of the page
+Quote Post
Robertina
post Jun 10 2009, 14:53
Post #11





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Case @ Jun 9 2009, 23:42) *
"Stop on Current" component doesn't work with Random playback order. It is a hack that lets playback advance to the next track but immediately calls foobar to jump to Previous track. Also you must disable "Stop After Current" when using it.

All my settings match the requirements you are pointing out here, Case, but I have the same problems as atomicknight.

Furthermore with foo_stop_on_current the consoles of both CUI and DUI list the following track as opened before the cursor is set back by your component; nevertheless I would like to thank you for your assistance.

I am using foobar2000 since 2007, it is the first time that I am really unlucky with it.

I will try to abide by the new behaviour somehow when working with loop- and sample files.

Robertina.
Go to the top of the page
+Quote Post
Case
post Jun 10 2009, 16:28
Post #12





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



New version here. This one uses a timer callback that is called every second so it will actually stop a bit earlier than the track really ends. With this you can have Stop After Current or Random enabled but DSPs that alter track length won't work (such as Skip Silence).
Go to the top of the page
+Quote Post
Robertina
post Jun 15 2009, 01:58
Post #13





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Case @ Jun 10 2009, 17:28) *
New version here. This one uses a timer callback that is called every second so it will actually stop a bit earlier than the track really ends.

Case,

I have tested foo_stop_on_current v0.2 over the last four days.

Owing to its behaviour to stop the actually playing file a bit before its real end my loop- and sample files become truncated, because they have music data at their end, not silence; in podcasts I am missing the last spoken words.

So using foo_stop_on_current 2.0 would mean that I am no longer able to make a reliable statement about the quality and completeness of files.

Nevertheless I will regularly visit your homepage for updates.

Thank you for your support again.


Yirka,

QUOTE
You seem to be the first one to provide real usage scenario for which the "broken" behavior was better.

I don't want to blow up my own thread but please let me pointing out this last comment:

I understand that for those users who primarily play their (ripped) audio CDs with foobar2000 there is not such a great need for a "stop on current"-function as far as they only want to hear some music. But already for playing a track twice they have to move the cursor one position back in their playlist and I think they would benefit from a "play a single file and stop on it"-function as well.

I am working as a composer and musician. Although we all have the essential professional tools my colleagues and I we love foobar2000 for its highly configurable user interface, its speed and converter options. We all use it with a simple "spreadsheets layout" with columns displaying file type and file properties (channels, bitrate, file path and so on). There is no faster way to get a quick overview or to check files which could be usefully in the actual project.

So even if I am "the fist one who is providing a real usage scenario" for such a function, I am not the only one.

So please consider to implement a "play a single file and stop on it"-function if possible (I am aware of foobar's special feature concerning the playback queue but never have used it).

Robertina.

(My compositions are better than my english.)
Go to the top of the page
+Quote Post
Arvid
post Jun 15 2009, 04:00
Post #14





Group: Members
Posts: 11
Joined: 21-October 04
Member No.: 17764



I often like to listen to a track several times. Also I often control the player with hotkeys so I'm not sure where the cursor is. With the previous behavior, I could press play and it would do what I wanted whether
  • The track is playing
  • The track is paused
  • The track was last stopped manually
  • The track was last played to its end

Now, in the last case, you should press previous, but it is not always easy to remember or determine if that's the case or any of the other three, so I often find myself annoyingly starting an unintended track. I think the previous behavior makes more sense.
Go to the top of the page
+Quote Post
Case
post Jun 16 2009, 23:25
Post #15





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



Suggestion to Arvid: use playback order "Repeat (track)". That will let you enjoy same track several times and jump to next one with press of a button. Normal playback order advances to next track naturally, unless track is not finished when you hit Stop. With "Stop After Current" the stop comes when track is finished and playback position has moved to next item.

I uploaded a new version of my "Stop on Current" component that should now work properly and not leave samples unplayed. Same link.
Go to the top of the page
+Quote Post
boomman
post Jun 17 2009, 20:59
Post #16





Group: Members
Posts: 21
Joined: 11-April 08
Member No.: 52713



I thank you for this plugin, it is useful. Sad to see that such "bugs" getting "fixed" after so much time in minor release.
Component works mostly well, but it stopped playing files with length less then one second.
Go to the top of the page
+Quote Post
Case
post Jun 18 2009, 04:06
Post #17





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



Simplified the system and made it work with those very short files too. Download here.
Go to the top of the page
+Quote Post
boomman
post Jun 24 2009, 16:24
Post #18





Group: Members
Posts: 21
Joined: 11-April 08
Member No.: 52713



Oh, I see now that it was not your plugin, it was foobar core itself. I degraded to 0.9.6.7 and it started to play tracks of small length.
Looks like I need to review my points on foobar2000 as a stable application...
Go to the top of the page
+Quote Post
Scidd0w
post Jun 24 2009, 17:16
Post #19





Group: Members
Posts: 161
Joined: 22-December 02
Member No.: 4204



Why not try to use Case' new version of the plugin with 0.9.6.8? It should fix your problems with very short files!
Go to the top of the page
+Quote Post
boomman
post Jun 24 2009, 18:51
Post #20





Group: Members
Posts: 21
Joined: 11-April 08
Member No.: 52713



Scidd0w,
I tried, it still not played half of my shortest tracks. I even deleted it from components and it still not worked. I downgraded and it works finally.
However, I tried clean installation of 0.9.6.8 and short files played well, so probably there's something conflicting in my installation.
I will keep 0.9.6.7 now, I need native "stop after current function" too much.
Go to the top of the page
+Quote Post
Robertina
post Aug 2 2009, 12:03
Post #21





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Case @ Jun 17 2009, 16:06) *
Simplified the system and made it work with those very short files too. Download here.

Case,

thank you very much for this updated version of "Stop on Current".

Playing a file and if "Stop on Current" is active there is a new entry in foobar's Playback menu named "Flush Playback Queue". This entry vanishes if playback stops.

What is it for?

Robertina.
Go to the top of the page
+Quote Post
Case
post Aug 2 2009, 12:12
Post #22





Group: Developer (Donating)
Posts: 2179
Joined: 19-October 01
From: Finland
Member No.: 322



New version utilizes foobar's built-in playback queue functionality to do its thing. When queue contains items that menu is visible. Try not to pay attention to it - it's nothing dangerous.
Go to the top of the page
+Quote Post
Robertina
post Aug 2 2009, 12:18
Post #23





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Case @ Aug 2 2009, 00:12) *
New version utilizes foobar's built-in playback queue functionality to do its thing. When queue contains items that menu is visible. Try not to pay attention to it - it's nothing dangerous.

I have never used foobar's queue function, so it was the first time I saw this.

Thank you for answering.

Robertina.
Go to the top of the page
+Quote Post
studio13
post Dec 2 2011, 17:48
Post #24





Group: Members
Posts: 16
Joined: 1-December 11
Member No.: 95516



Thanks so much for providing this component. I'm using it in a sound design workflow where I audition hundreds of tiny audio files and sometime much longer ones. Stop on current is exactly the playback behavior I needed !! smile.gif

Tagged : ProTools, Sound Design, Stop on current, I love Foobar !
Go to the top of the page
+Quote Post
Marijn van der Z...
post Nov 12 2012, 19:31
Post #25





Group: Members
Posts: 4
Joined: 30-July 08
Member No.: 56499



A (late) big thanks from me too. Case, you're awesome.

I also think the old behavior made much more sense. I'm using stop after/on current for rating and cleaning up my collection. I play a song till the end and after that I decide what to do with it. Now it is possible for me to rate a song and then play the next one, using only keyboard shortcuts.

An annoying thing the Case's component fixes has to do with autoplaylists in combination with shuffled playback. I use an autoplaylist with unrated songs and like to shuffle through it whil rating the songs. When I rate the previous song or song before that, the song leaves the playlist, which changes the playback order! This is annoying if I already heard the 'next' one or two songs, but obviously isn't relevant when I haven't.

I'm not sure if people can follow that last part, but the important part is that I'm unhappy with Foobar's default behavior and happy with Case's component smile.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th July 2014 - 02:25