IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Group music by Album, Artist and Track No with Facets
SlashEmUp
post Jul 29 2013, 05:13
Post #1





Group: Members
Posts: 3
Joined: 29-July 13
Member No.: 109350



Hello there,

So I have Facets downloaded for foobar and I came across and issue that I can't seem to solve no matter how much Google searching or fiddling around myself I do.

My issue is that my music is not being 'sorted' correctly when I use the grouping feature. It seems to be working aside from sorting by the track number. If you see my attached screenshot, it correctly groups by artist and album, but each individual album is not sorted by the correct track number, which can be quite annoying.

Does anyone know how I can fix it? As far as I can tell, it seems to only be a problem when I have an artist with multiple albums.

Thanks.


Screenshot of the issue: http://gyazo.com/1c64120d361d82f4c1f5b8d3337bfd2c
Go to the top of the page
+Quote Post
Wander
post Jul 29 2013, 10:12
Post #2





Group: Members
Posts: 56
Joined: 25-May 11
From: Germany
Member No.: 90967



I am not sure how the default playlist view sorts by default - I guess by %path_sort% - but according to your picture all your albums are sorted descending by title name. You probably clicked twice at the column "title/track artist". To sort by track number you first have to click at the column "track no" and than at "album" to enable album grouping.

You should also check your tags and file names. If there is something wrong sorting won't work correctly.
Go to the top of the page
+Quote Post
Rarn
post Aug 1 2013, 06:40
Post #3





Group: Members
Posts: 12
Joined: 26-July 11
Member No.: 92568



QUOTE (SlashEmUp @ Jul 29 2013, 00:13) *
Hello there,

So I have Facets downloaded for foobar and I came across and issue that I can't seem to solve no matter how much Google searching or fiddling around myself I do.

My issue is that my music is not being 'sorted' correctly when I use the grouping feature. It seems to be working aside from sorting by the track number. If you see my attached screenshot, it correctly groups by artist and album, but each individual album is not sorted by the correct track number, which can be quite annoying.

Does anyone know how I can fix it? As far as I can tell, it seems to only be a problem when I have an artist with multiple albums.

Thanks.


Screenshot of the issue: http://gyazo.com/1c64120d361d82f4c1f5b8d3337bfd2c


If your problem is just that you want it to autosort when you browse by facets, then you can change the facets default sort order.

go to Preferences > Media Library > Facets

in the library section, change the default sort order to something like:
%album artist%|%date%|%album%|%discnumber%|%tracknumber%

you can remove %date% if you prefer albums to be sorted alphabetically rather than by date.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 23:23