IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
jSpeex POS?
KWhat4
post Oct 30 2005, 02:45
Post #1





Group: Members
Posts: 1
Joined: 30-October 05
Member No.: 25441



I am having major problems with the jspeex codec. I can get it to encode and decode data locally as in to a file and back however when i try to send data over the network it start crapping out on the decode with stuff like "Invalid sideband mode encountered (1st sideband): 6" and "More than two sideband layers found" and "Invalid mode encountered: 10".

The data going into the speex codec is 640 bytes, thats encoded down to 70. I then take that 70 put it threw my socket (YES i fulushed the socket). I read it out on the other side as 70 bytes, and try to decode it... bamm many many errors but for some reason its playing some of the data correctly. for the most part it sounds garbaled.

NOW PLEASE DO NOT TELL ME TO READ THE DOCS OR LOOK AT THE SAMPLES AS JUST ABOUT EVERY OTHER POST REGARDING THIS CODEC HAS SAID. IF THE DOCS WHERE ACCTUALLY WORTH READING INSTED OF "encode(int1, int2, int3)" AND NOT LISTING WHAT THE PARAMATERS ARE OR EVEN WHAT THE FUNCTION DOES "encodes audio" yah that helps, thanks READING THEM MAY HELP, BUT THEY SUCK.

So please tell me what is wrong, or atleast where there is some good documentation for this codec.

Thanks

This post has been edited by KWhat4: Oct 30 2005, 02:46
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st October 2014 - 16:35