IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Using SoX via FB2K to resample some music, Trying to figure out how to input the desired sample rate
spardavr4
post Sep 2 2014, 16:46
Post #1





Group: Members
Posts: 4
Joined: 2-September 14
Member No.: 117163



Hello all,

I am new to resampling and I just obtained some ALAC files that are 24 bit/96 kHz. I would like to put these songs onto my iPhone but it is only capable of syncing a max of 24/48.

I successfully downsampled using SoX plugin in foobar, but it made the files 24/44.1.

Is there a way to force Foobar/SoX to downsample to files to 48 and not 44.1 kHz?

Thanks!
Go to the top of the page
+Quote Post
julf
post Sep 2 2014, 17:13
Post #2





Group: Members
Posts: 275
Joined: 14-January 12
Member No.: 96426



QUOTE (spardavr4 @ Sep 2 2014, 17:46) *
Is there a way to force Foobar/SoX to downsample to files to 48 and not 44.1 kHz?


--rate 48000
Go to the top of the page
+Quote Post
spardavr4
post Sep 2 2014, 17:17
Post #3





Group: Members
Posts: 4
Joined: 2-September 14
Member No.: 117163



QUOTE (julf @ Sep 2 2014, 11:13) *
QUOTE (spardavr4 @ Sep 2 2014, 17:46) *
Is there a way to force Foobar/SoX to downsample to files to 48 and not 44.1 kHz?


--rate 48000



Thanks for the response! If you mean the target sample rate via the DSP Manager preferences, I have the target set to 48000, but it still downsamples to 44.1 kHz.

Sorry if that's not what you meant. I am very new to using foobar smile.gif
Go to the top of the page
+Quote Post
Apesbrain
post Sep 2 2014, 17:17
Post #4





Group: Members
Posts: 490
Joined: 3-January 04
Member No.: 10915



File > Preferences > Playback > DSP Manager: Highlight "Resampler (SoX)" and click "Configure" button. Set "Target samplerate".

EDIT: Sorry, your post above beat me to it.

This post has been edited by Apesbrain: Sep 2 2014, 17:21
Go to the top of the page
+Quote Post
spardavr4
post Sep 2 2014, 17:22
Post #5





Group: Members
Posts: 4
Joined: 2-September 14
Member No.: 117163



QUOTE (Apesbrain @ Sep 2 2014, 11:17) *
File > Preferences > Playback > DSP Manager: Highlight "Resampler (SoX)" and click "Configure" button. Set "Target Sample Rate".

EDIT: Sorry, your post above beat me to it.



Haha, yeah I actually found that after I posted my question and retried to resample the files, and yet it still downsampled to 44.1.

I also found under the advanced tab in the preferences menu an option that says decoding to which is set 44100 in a small box that I can add text to. I'm not sure if I want to change this since I don't want to break anything lol.
Go to the top of the page
+Quote Post
romor
post Sep 2 2014, 17:56
Post #6





Group: Members
Posts: 680
Joined: 16-January 09
Member No.: 65630



QUOTE (Apesbrain @ Sep 2 2014, 17:17) *
File > Preferences > Playback > DSP Manager: Highlight "Resampler (SoX)" and click "Configure" button. Set "Target samplerate".

EDIT: Sorry, your post above beat me to it.

That is for Playback.

spardavr4 is obviously using converter, where playback DSP settings doesn't apply.
In Converter dialog there is link to "Processing" dialog - any necessary DSP, in this case re-sampler, should be activate there.


--------------------
scripts: http://goo.gl/M1qVLQ
Go to the top of the page
+Quote Post
spardavr4
post Sep 2 2014, 18:17
Post #7





Group: Members
Posts: 4
Joined: 2-September 14
Member No.: 117163



QUOTE (romor @ Sep 2 2014, 11:56) *
QUOTE (Apesbrain @ Sep 2 2014, 17:17) *
File > Preferences > Playback > DSP Manager: Highlight "Resampler (SoX)" and click "Configure" button. Set "Target samplerate".

EDIT: Sorry, your post above beat me to it.

That is for Playback.

spardavr4 is obviously using converter, where playback DSP settings doesn't apply.
In Converter dialog there is link to "Processing" dialog - any necessary DSP, in this case re-sampler, should be activate there.


Found it! Thanks it worked smile.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 16:31