IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Question about latest changelog regarding WavPack
bryant
post Jun 24 2013, 00:39
Post #1


WavPack Developer


Group: Developer (Donating)
Posts: 1297
Joined: 3-January 02
From: San Francisco CA
Member No.: 900



In the latest foobar2000 changelog there's this entry:

QUOTE
Made WavPack files with malformed channel mask info play

Is this something I should be concerned about? How did these WavPack files get malformed channel masks? My searches revealed no other details.

BTW, thanks for the continued support of WavPack in foobar2000! smile.gif

David
Go to the top of the page
+Quote Post
Peter
post Jun 24 2013, 09:37
Post #2


foobar2000 developer


Group: Admin
Posts: 3314
Joined: 30-September 01
Member No.: 84



I've encountered WavPack files having channel mask of zero, encoded from WAV files carrying the same. These did not play at all - the code to fall back to the default channel layout for the specified channel count did not work (typo in the code).
Go to the top of the page
+Quote Post
bryant
post Jun 25 2013, 17:09
Post #3


WavPack Developer


Group: Developer (Donating)
Posts: 1297
Joined: 3-January 02
From: San Francisco CA
Member No.: 900



Ah, that makes sense. Thanks, Peter.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 13:03