IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Fading doesn't seem to work
romor
post Apr 26 2014, 09:21
Post #1





Group: Members
Posts: 670
Joined: 16-January 09
Member No.: 65630





I would assume this should work on primary driver.
Just in case I also disabled any DSP, but can't hear nor see any fading in any case (automatic track change, manual track change, seek...)

What could be the problem?

This post has been edited by romor: Apr 26 2014, 09:23


--------------------
scripts: http://goo.gl/M1qVLQ
Go to the top of the page
+Quote Post
Case
post Apr 26 2014, 09:51
Post #2





Group: Developer (Donating)
Posts: 2214
Joined: 19-October 01
From: Finland
Member No.: 322



Note that foobar2000 doesn't strip silence away from your files. Typical tracks for example fade to silence and often have a longish silent ending. With such a track there's nothing to work with.

Your screenshot looks like there's no fades at all though. Just abrupt ending. Is it a bad rip where for example EAC's offset corrections are used incorrectly making it eat parts of the files away?

You could still get audible fades if you increase your buffer length and make fades longer. Or use a DSP that removes silence from the tracks. You could also try it with some albums that play back gaplessly to hear the effect with your current settings.
Go to the top of the page
+Quote Post
romor
post Apr 26 2014, 10:12
Post #3





Group: Members
Posts: 670
Joined: 16-January 09
Member No.: 65630



QUOTE (Case @ Apr 26 2014, 09:51) *
Your screenshot looks like there's no fades at all though. Just abrupt ending. Is it a bad rip where for example EAC's offset corrections are used incorrectly making it eat parts of the files away?


Yes, no fades at all.
I don't think it's a bad rip problem. I tried various file formats, but it's like this feature simply isn't working here.


QUOTE (Case @ Apr 26 2014, 09:51) *
You could still get audible fades if you increase your buffer length and make fades longer. Or use a DSP that removes silence from the tracks. You could also try it with some albums that play back gaplessly to hear the effect with your current settings.


I increased buffer length, but still the same.
The silence in the screenshot is tiny, which I'm not much concerned about. I choose it as example as it was easier to spot no fade.

Assuming this feature works as expected elsewhere, let me note that this is on-board audio on P35 platinum MB, with default Windows hdaudio driver.
If there are other information I should provide, let me know.


--------------------
scripts: http://goo.gl/M1qVLQ
Go to the top of the page
+Quote Post
lvqcl
post Apr 26 2014, 10:41
Post #4





Group: Developer
Posts: 3362
Joined: 2-December 07
Member No.: 49183



AFAIK fading is performed by the OS, so it's not possible to see its effect on spectrogram.
Also I can hear the effect of fading: two tracks overlap, the first starts to fade out, the second starts to fade in (Win7 SP1, X-Fi Gamer).

This post has been edited by lvqcl: Apr 26 2014, 10:43
Go to the top of the page
+Quote Post
romor
post Apr 26 2014, 11:36
Post #5





Group: Members
Posts: 670
Joined: 16-January 09
Member No.: 65630



Sorry, I deleted nonsense message

It's like lvqcl wrote - "fading is performed by the OS, so it's not possible to see its effect on spectrogram"

Fading now works fine.
I installed Realtek driver, and restarted two times. That's all I know.



This post has been edited by romor: Apr 26 2014, 12:31


--------------------
scripts: http://goo.gl/M1qVLQ
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th August 2014 - 08:40