IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Corrupt frames in HE-AAC files(?), qtaacenc + QuickTime 7.6.9
Cron
post Apr 15 2011, 15:13
Post #1





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



I'm using qtaacenc to transcode flac > aac and some of the resulting aac-files have audible "clicks" that are not present in the original flac-files. While decoding these .m4a to .wav in foobar2000 I get errors:

(File 1, length 16:55)
Decoding error: Unsupported format or corrupted file, frame: 7922 of 9075

(File 2, length 7:01)
Decoding error: Unsupported format or corrupted file, frame: 7922 of 21859
Decoding error: Unsupported format or corrupted file, frame: 18493 of 21859

Trying to re-transcode doesn't help - the clicks are there again. Even when using chain flac > wav > aac I get the same corrupt files! I've tried this now on two computers.

If I cut the first second off in Audacity and encode the resulting wav-file, I get no corrupted frames at all.

What's going on? blink.gif


Software and encoding parameters:
foobar2000 v1.1.1 + qtaacenc 20101119 + QuickTime 7.69.80.9
Parameters: --cvbr 96 --he --samplerate keep --highest - %d
Go to the top of the page
+Quote Post
Garf
post Apr 15 2011, 18:38
Post #2


Server Admin


Group: Admin
Posts: 4886
Joined: 24-September 01
Member No.: 13



Does this happen when using QuickTime directly?

BTW. Are you sure HE-AAC is better than LC-AAC at 96kbps?
Go to the top of the page
+Quote Post
IgorC
post Apr 15 2011, 18:45
Post #3





Group: Members
Posts: 1582
Joined: 3-January 05
From: ARG/RUS
Member No.: 18803



Apple HE-AAC is only available up to 80 kbps. Not more.
I donīt know how qtaacenc has managed to get HE-AAC at 96 kbps.

This post has been edited by IgorC: Apr 15 2011, 18:47
Go to the top of the page
+Quote Post
Cron
post Apr 15 2011, 20:37
Post #4





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



QUOTE (IgorC @ Apr 15 2011, 18:45) *
Apple HE-AAC is only available up to 80 kbps. Not more.
I donīt know how qtaacenc has managed to get HE-AAC at 96 kbps.

Aha! didn't know that. Also explains why the encoded files showed 80 kbps when I checked their Properties in Foobar.

Changing --cvbr 96 to --cvbr 80 doesn't change the error though and I get the same error even with 64 kbps.

QUOTE (Garf @ Apr 15 2011, 18:38) *
Does this happen when using QuickTime directly?

I don't have QuickTime Pro so I can't check that sorry.

Here is a picture showing that the flac doesn't seem to have anything odd (clipping or such) that should make QuickTime to burb like it does...


Go to the top of the page
+Quote Post
IgorC
post Apr 15 2011, 20:59
Post #5





Group: Members
Posts: 1582
Joined: 3-January 05
From: ARG/RUS
Member No.: 18803



Cron,
Can you post the short piece of this file (up to 30 seconds)?

Also you can remove --he:
--cvbr 96 --samplerate keep --highest - %d

HE-AAC is disabled for bitrates >80 kbps for a good reason. It is not beter than LC-AAC at those rates.

P.S. Not sure if --samplerate keep is compatible with --he (HE-AAC)
P.S.2. Also LC-AAC had a bug at 80-112 kbps in past. If there is a lowpass at 15.5 kHz then everything is fine. If there is a load of frequency content over that lowpass then it's bug.

This post has been edited by IgorC: Apr 15 2011, 21:38
Go to the top of the page
+Quote Post
Cron
post Apr 15 2011, 21:56
Post #6





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



QUOTE (IgorC @ Apr 15 2011, 20:59) *
Cron,
Can you post the short piece of this file (up to 30 seconds)?

Also you can remove --he:
--cvbr 96 --samplerate keep --highest - %d

HE-AAC is disabled for bitrates >80 kbps for a good reason. It is not beter than LC-AAC at those rates.

P.S. Not sure if --samplerate keep is compatible with --he (HE-AAC)

Removing --he does help, so the problem shouldn't be in the input file (right?). I'm interested as to what is causing the problem in he-aac though.

Removing --samplerate does not help.

Cutting the lossless file changes something that makes the problem go away. I even tried to cut the file to the multiples of AAC frame size (1024 samples) to get the samples to align same way in the frame, but couldn't reproduce the problem that way. Since the defect is at 6:07 I can't post a sample of it so that you can reproduce the problem sad.gif

It should be noted that cutting the file after the 6:07 still produces lossless files that will encode to defective aac.

All this is really weird... but I've had it now with two files and two different computers - exactly the same corrupt frames every time I try to encode.
Go to the top of the page
+Quote Post
IgorC
post Apr 16 2011, 04:50
Post #7





Group: Members
Posts: 1582
Joined: 3-January 05
From: ARG/RUS
Member No.: 18803



Confirmed.
The same issue for HE-AAC 80 kbps, VBR, iTunes 10.2.1.1, QuickTime 7.6.9 .
No problem with other AAC encoders.

This post has been edited by IgorC: Apr 16 2011, 04:51
Go to the top of the page
+Quote Post
Cron
post Apr 16 2011, 09:20
Post #8





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



Thanks IgorC!

I'm wondering if its a new bug that has come with some new version of QT. It's so easily noticeable that it would very unlikely to go unnoticed prolonged time now that I've noticed it in two files during one day.
Go to the top of the page
+Quote Post
menno
post Apr 16 2011, 14:49
Post #9


Nero MPEG4 developer


Group: Developer (Donating)
Posts: 1218
Joined: 11-October 01
From: LA
Member No.: 267



Have you tried other decoders yet?
Go to the top of the page
+Quote Post
Cron
post Apr 16 2011, 16:33
Post #10





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



QUOTE (menno @ Apr 16 2011, 14:49) *
Have you tried other decoders yet?

I've tried foobar2000, QuickTime Player and Windows Media player - all of then choke to the faulty frames.
Go to the top of the page
+Quote Post
Cron
post May 24 2011, 11:15
Post #11





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



I recently found an CD that has three tracks encoding badly.

There obviously is a pattern here: frame 7922 encodes badly way too often for it to be an accident...



What makes things worse is that when trying to play these files, my Sansa Clip+ with Rockbox 3.8.1 crashes and becomes totally unresponsive. Crash happens exactly at the point of faulty frame. I have to reboot the Clip+ with holding the power button at the bottom for 30s.

Mostly because of the huge CPU usage of HE-AAC decoding, I'm moving to use ogg vorbis for portable use unsure.gif
Go to the top of the page
+Quote Post
Cron
post Aug 4 2011, 14:23
Post #12





Group: Members
Posts: 19
Joined: 13-April 10
Member No.: 79827



Latest QuickTime update (7.7 for Windows) seems to fix the problem and produces clean output.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 10:42