IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Muting during silence when playing 24 bit 48 KHz audio, Technical issue
Audionerd
post May 23 2009, 10:14
Post #1





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



When playing "Enjoy The Silence" by Depeche Mode in 24/48 Foobar (or ?) mutes the output right at the end when the music fades and there is a second of silence before the "Enjoy the Silence" chorus/dacapo. the muting results in the audio taking a fraction of a second to resume thus the chorus sounds like "...oy the silence". Also all beginnings of tracks are "capped off" by the same fraction of a scond.

The problem only exists when playing 24/48 pcm audio and when played through any of the other players at hand there is no problem which leads me to rule out muting in my DAC as the reason.

Does anybody know what to do?

blink.gif Jens the Audionerd

Ps I can upload a 10 second snippet of audio that illustrates the problem if needed.
Go to the top of the page
+Quote Post
lvqcl
post May 23 2009, 10:29
Post #2





Group: Developer
Posts: 3357
Joined: 2-December 07
Member No.: 49183



Try to set output bit depth = 16bit, and dither = on.

This post has been edited by lvqcl: May 23 2009, 10:32
Go to the top of the page
+Quote Post
Audionerd
post May 23 2009, 10:41
Post #3





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



QUOTE (lvqcl @ May 23 2009, 10:29) *
Try to set output bit depth = 16bit, and dither = on.


That does remove the problem but introduces a few new ones.
It makes it impossible to play 24 bit dts files, and playing 24 bit files by converting them to 16 is kind of blasphemous...
Go to the top of the page
+Quote Post
lvqcl
post May 23 2009, 11:11
Post #4





Group: Developer
Posts: 3357
Joined: 2-December 07
Member No.: 49183



QUOTE (Audionerd @ May 23 2009, 13:41) *
That does remove the problem but introduces a few new ones.

It looks like your DAC mutes quiet signals.

QUOTE (Audionerd @ May 23 2009, 13:41) *
It makes it impossible to play 24 bit dts files, and playing 24 bit files by converting them to 16 is kind of blasphemous...

What output plugin do you use? Since you wrote "when played through any of the other players at hand there is no problem" -- maybe DirectSound plugin can solve this issue?
Go to the top of the page
+Quote Post
Audionerd
post May 23 2009, 11:25
Post #5





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



QUOTE
It looks like your DAC mutes quiet signals.

Actually that was my first guess as well, but from the tests made - including playing the exact same audio from a dvd to the same digital input on the dac - I no longer think that the dac is the problem.

QUOTE
What output plugin do you use? Since you wrote "when played through any of the other players at hand there is no problem" -- maybe DirectSound plugin can solve this issue?

Sorry - forgot that. I use WASAPI on a Vista SP1 system.
Will try the DirectSound in an hour or so (wife ill, I have to go shopping...)
rolleyes.gif

Thanx so far smile.gif
Go to the top of the page
+Quote Post
Audionerd
post May 23 2009, 17:46
Post #6





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



I have tried the DirectSound option and the muting/delay is indeed gone but so is the fidelity of the playback!
Is there any way to make DS sound acceptable?

Anyway, I am pretty sure that the culprit is the WASAPI output plugin but it is weird that there is no problem when playing dd, dts or red book cd's - only when playing 24 bit 48 KHz headbang.gif
Go to the top of the page
+Quote Post
shakey_snake
post May 23 2009, 18:09
Post #7





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



Considering no one else has had such issues, it's more likely that it was your drivers/your hardware than fb2k's output component.

This post has been edited by shakey_snake: May 23 2009, 18:19


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Audionerd
post May 23 2009, 19:49
Post #8





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



QUOTE (shakey_snake @ May 23 2009, 18:09) *
Considering no one else has had such issues, it's more likely that it was your drivers/your hardware than fb2k's output component.

That's a rather bold suggestion given the fact that the ONLY player with the problem is Foobar and only when using the WASAPI component.

Not to mention that there is no way you can be sure I am the only one with the problem...

From my seat it appears that the drivers/hardware can be responsible but if so it most be that the other players do not output 24 bit from 24 bit files.
There is however one little problem with that assumption: I can tell 10 times out of 10 when some less than ideal algorithm is used to convert from 24 to 16 bits and it does not sound if something like that is happening and indeed nothing else is indicating it either.

But from the looks of it - especially that stupid "warn" system I need a double blind test to support my previous claim that DS sounds way inferior to WASAPI - hence I am checking out for good.

This post has been edited by Audionerd: May 23 2009, 20:04
Go to the top of the page
+Quote Post
shakey_snake
post May 23 2009, 20:03
Post #9





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



I find that claim extremely dubious considering lossy compressed formats like DTS don't have a fixed bit depth. rolleyes.gif

You basically have no understanding of what is going on here. The fact that you are claiming to hear something based on a flawed premise is fairly amusing.

You've already received a TOS #8 warning based on post #6. If you continue to make quality claims without providing evidence (making positive ABX results and sharing your logs/samples) there will be further consequences. If you haven't yet read our Terms of Service (also at the top of every page) I very much recommend you do so.

This post has been edited by shakey_snake: May 23 2009, 20:32
Reason for edit: fixed poor grammar


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Audionerd
post May 24 2009, 12:09
Post #10





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



In the interest of possible others experiencing problems like mine it has now been established beyond doubt that the muting is caused by a flaw in the DAC's firmware. It appears to be a known issue which has been solved when input is 16 bit PCM and all zeros but has yet to be solved with 24 bit PCM all zeros.
Thanx to lvqcl for keeping me suspicious of the dac's role smile.gif
Why this flaw in my setup is only triggered when played back by Foobar eludes me.
One possible explanation is that only foobar output is truly all zeros when the signal is silent, but I have no way of proving that right now. Suggestions on how to test this are welcome.

This post has been edited by Audionerd: May 24 2009, 12:29
Go to the top of the page
+Quote Post
Audionerd
post May 24 2009, 13:06
Post #11





Group: Members
Posts: 11
Joined: 23-May 09
Member No.: 70050



What I really meant by POST #6 was that the DS output does not allow everything else on the Vista sytem to be muted during playback and that it - from what I've read on MS blogs - uses the mixer. Whether or not that can be heard when nothing else is producing sound is a whole other matter. I only wanted to emphasize the difference between the DS and the WASAPI.
Go to the top of the page
+Quote Post
lvqcl
post May 24 2009, 16:08
Post #12





Group: Developer
Posts: 3357
Joined: 2-December 07
Member No.: 49183



QUOTE (Audionerd)
and only when using the WASAPI component.

What about Kernel Streaming output? I thought it should work like WASAPI...
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 06:35