IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Small but serious bug in EAC - and how to avoid it, German version only
R.A.F.
post Aug 10 2003, 22:37
Post #1





Group: Members
Posts: 281
Joined: 4-August 02
From: Nuremberg/Bavaria
Member No.: 2924



A few weeks ago I discovered a small but annoying bug in EAC. It appears, when there were "suspicious positions" at some tracks while grabbing. In earlier versions EAC always wrote then "There were errors" at the end of the logfile. But instead of doing this, it now always wrote "No errors occured". So it happened during my last several dozen ripps, that I grabbed 7 or 8 CD´s with errors - and didn´t notice it at first, as I took my focus only at the end-message of the logfiles. Important: The bug appears only in the german version of EAC, as there happened a mistake in the german translation-file of EAC. It was reported to André Wiethoff (the author of EAC) a few weeks ago, and meanwhile he uploaded a corrected german textfile (dated on 14/07). So, if you haven´t done it not yet, please download this one from his webpage. If you downloaded the main-program newly, you also have to download the fixed german textfile additionally, as the main program-package was not yet updated.

This post has been edited by R.A.F.: Aug 11 2003, 13:28


--------------------
My used codecs and settings:
FLAC V1.1.2 -4 / APE V3.99 Update 4 -high / MPC V1.15v --q 5 / LAME V3.97b2 -V2 --vbr-new / OGG aoTuV V4.51 Lancer -q5
Go to the top of the page
+Quote Post
Pio2001
post Aug 11 2003, 11:28
Post #2


Moderator


Group: Super Moderator
Posts: 3936
Joined: 29-September 01
Member No.: 73



Thank you for the info !
Go to the top of the page
+Quote Post
guruboolez
post Aug 11 2003, 11:46
Post #3





Group: Members (Donating)
Posts: 3474
Joined: 7-November 01
From: Strasbourg (France)
Member No.: 420



I don't use any language pack, but :

CODE
EAC extraction logfile from 17. July 2003, 23:19 for CD
(...)

Used drive  : TOSHIBA DVD-ROM SD-R2312   Adapter: 2  ID: 0
Read mode   : Burst
Read offset correction : 0
Overread into Lead-In and Lead-Out : No

Used output format : C:\AUDIO\multi_frontend\mac.exe   (Monkey's Audio Lossless Encoder)
                    High Lossless Compression

Other options      :
   Fill up missing offset samples with silence : Yes
   Delete leading and trailing silent blocks : No
   Native Win32 interface for Win NT & 2000


Track  1
(...)

Track  3
  Filename C:\Mes nouveaux rips\De Profundis.wav

  Peak level 84.3 %
  Test CRC F7A9D45C
  Copy CRC 2AE21680
  Copy OK

(...)

No errors occured


End of status report


CRC mismatch, but "no errors" as conclusion ??? (it was a burst Test & Copy extraction).
Go to the top of the page
+Quote Post
.halverhahn
post Aug 11 2003, 12:45
Post #4





Group: Members
Posts: 258
Joined: 4-August 03
Member No.: 8168



QUOTE (guruboolez @ Aug 11 2003, 12:46 PM)
I don't use any language pack, but :

CRC mismatch, but "no errors" as conclusion ??? (it was a burst Test & Copy extraction).


did it happen also on EAC V0.9 beta 4 ?


--------------------
.halverhahn
Go to the top of the page
+Quote Post
guruboolez
post Aug 11 2003, 12:51
Post #5





Group: Members (Donating)
Posts: 3474
Joined: 7-November 01
From: Strasbourg (France)
Member No.: 420



QUOTE (.halverhahn @ Aug 11 2003, 12:45 PM)
QUOTE (guruboolez @ Aug 11 2003, 12:46 PM)
I don't use any language pack, but :

CRC mismatch, but "no errors" as conclusion ??? (it was a burst Test & Copy extraction).


did it happen also on EAC V0.9 beta 4 ?

Don't know : I haven't 0.94xxx installed anymore.
Go to the top of the page
+Quote Post
Supachikn
post Aug 11 2003, 15:03
Post #6





Group: Members
Posts: 34
Joined: 22-November 02
Member No.: 3842



This is not a language pack error, but something that occurs when the Test rip, and the Copy rip result in different outputs, thus the checksums are different. IMO EAC should report this as a bad rip, but it doesnt. Try lowering the speed of the drive, using nero drivespeed, or similar programs. I hope this helps.


--------------------
Quality Windows Audio Playback: http://foobar2000.org/
Go to the top of the page
+Quote Post
Pio2001
post Aug 11 2003, 18:10
Post #7


Moderator


Group: Super Moderator
Posts: 3936
Joined: 29-September 01
Member No.: 73



EAC has always reported "no errors occured" when CRC mismatch, but no errors were detected. It means that no error was detected during the reading part.

What we talk about here is much more annoying : reporting "no errors occured" (in german, AFAIU) whatever happens. If I understood well, the message "there were errors" have been replaced by "no errors occured" in the german translation.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 16:45