IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
foo_prettypop plugin and Windows 8
djl236
post Dec 31 2012, 00:29
Post #1





Group: Members
Posts: 2
Joined: 31-December 12
Member No.: 105492



Hello, I've been searching on here and Google and am unable to find any solution to my problem.

I've recently installed Windows 8 on my laptop from Windows 7 (I did a new clean install). I was reinstalling and reconfiguring foobar to be the same as it was on Windows 7. The only problem I'm having is that I'm unable to get the foo_prettypop component (located here: http://www.maroonspoon.com/foo_prettypop/) to work now on Windows 8. It was working on Windows 7. I'm receiving the following error:

QUOTE
Failed to load DLL: foo_prettypop.dll
Reason: A dynamic link library (DLL) initialization routine failed.


I've installed the following: Microsoft Visual Studio C++ Redistributables 2005 x86 and x64, 2008 x86 and x64 and 2010 x86 and x64. .NET 4.5 is installed natively with Windows 8, which includes previous versions of .NET (so you can't install them individually).

Is perhaps this plugin just not compatible with Windows 8 or am I missing something?

Thanks.
Go to the top of the page
+Quote Post
lvqcl
post Dec 31 2012, 00:40
Post #2





Group: Developer
Posts: 3358
Joined: 2-December 07
Member No.: 49183



QUOTE
which includes previous versions of .NET


No it doesn't. http://msdn.microsoft.com/en-us/library/hh506443.aspx
Go to the top of the page
+Quote Post
djl236
post Dec 31 2012, 01:16
Post #3





Group: Members
Posts: 2
Joined: 31-December 12
Member No.: 105492



QUOTE (lvqcl @ Dec 30 2012, 18:40) *
QUOTE
which includes previous versions of .NET


No it doesn't. http://msdn.microsoft.com/en-us/library/hh506443.aspx



I got it working and here's how.

You're correct, it doesn't include them and for some damn reason Windows 8 wouldn't let me outright intsall them because it comes with .NET 4.5 so I found the Windows Live Essentials pack and installed the Movie Maker app, Photo Gallery and SkyDrive. It then prompted me saying it needed files from .NET 2 and 3.5 do you want to download and install them? I said yes and it successfully downloaded and installed those two previous versions of .NET. Now the plugin works in foobar.

Thank you Microsoft for making something simple, difficult (per usual). Hope this helps someone else out.
Go to the top of the page
+Quote Post
kode54
post Jan 1 2013, 01:12
Post #4





Group: Admin
Posts: 4608
Joined: 15-December 02
Member No.: 4082



Attempting to launch a stand-alone .NET 2/3 application will also offer to install the correct frameworks. Add/remove programs probably has an option for it as well.
Go to the top of the page
+Quote Post
dragon2913
post Jan 3 2013, 13:41
Post #5





Group: Members
Posts: 1
Joined: 3-January 13
Member No.: 105560



Hej, I am using windows 8 at the moment and I had the same problem. I think that preetypopup is not compatible with NETframework 4/4.5 that's why it is not working for you. Try to install NETframework 3.5 http://www.microsoft.com/en-us/download/details.aspx?id=21 it helped me and now everything works fine.

This post has been edited by dragon2913: Jan 3 2013, 13:48
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 14:42