IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
fb2k seems to be showing my songs in a wrong order. How do I fix that?, [TOS #5: split from “New to Foobar - how to properly delete songs/f…”]
deathcoreRULES
post Feb 11 2013, 00:04
Post #1





Group: Members
Posts: 56
Joined: 7-February 13
Member No.: 106484



Okay it moved, but it's on the bottom of the track list.

It's track number 1, but it's at the bottom? The tagging is right for all the other songs. Track 1 / 14 for example. Disc 1 / 1.

Also is there a way to refresh Foobar, or do I have to close and reopen the program every time to see changes? F5 does not work.

This post has been edited by db1989: Feb 11 2013, 00:24
Reason for edit: deleting pointless full quote
Go to the top of the page
+Quote Post
deathcoreRULES
post Feb 11 2013, 01:00
Post #2





Group: Members
Posts: 56
Joined: 7-February 13
Member No.: 106484



Ok this is strange.

I am using columns UI because Foobar doesn't have a library like iTunes where it shows all the albums in one of big list.

I have it sorted by genre so if I go Pop Punk for example it will show the albums all of my bands.

The tracks here are in the right order.

If I go to my quick search bar though and search for the band Green Day, the songs are messed up.

Library:

Track 1
Track 3
Track 11

Quick Search Bar:

Track 3
Track 11
Track 1 ?

It's only that one album though.

There is no problem with any other album. The track list is correct.
Go to the top of the page
+Quote Post
deathcoreRULES
post Feb 14 2013, 21:23
Post #3





Group: Members
Posts: 56
Joined: 7-February 13
Member No.: 106484



Ok I think pictures will help better than my terrible explanations.

Here are songs from the exact same album, but they are split. I moved all the songs to the same folder but they won't go together. I closed Foobar and tried dragging but it doesn't work.

Go to the top of the page
+Quote Post
db1989
post Feb 14 2013, 21:30
Post #4





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



The answer is in the screenshot. One album is headed “Misfits / Misfits”, the other “The Misfits / Misfits”. Some field is inconsistent between the two sets of tracks. I presume it’s album artist. Unify that (or do what I would do, and don’t use it unless it’s different from artist), and I bet the ‘problem’ disappears.
Go to the top of the page
+Quote Post
deathcoreRULES
post Feb 14 2013, 21:39
Post #5





Group: Members
Posts: 56
Joined: 7-February 13
Member No.: 106484



Ok that worked my mistake. I thought I checked that. Originally the folders were 'Misfits' and 'The Misfits' inside My Music. I moved them all to 'The Misfits.' I try to keep all the tag fields filled in.

Here's the other song that I am still trying to fix. I don't get what is wrong. No album artist here I removed it.

Go to the top of the page
+Quote Post
Wander
post Feb 15 2013, 10:44
Post #6





Group: Members
Posts: 46
Joined: 25-May 11
From: Germany
Member No.: 90967



Can you post the file names?

As far as I know - I don't have a foobar2000 installation here to check - the results of quicksearch get sorted according to the path- / filename.
Go to the top of the page
+Quote Post
deathcoreRULES
post Feb 15 2013, 11:11
Post #7





Group: Members
Posts: 56
Joined: 7-February 13
Member No.: 106484



The actual file names in windows explorer?

Name:

03 Holiday
11 Wake me up when September Ends
American Idiot

The track numbers are all right though. Same album and artist. I double checked.
Go to the top of the page
+Quote Post
Wander
post Feb 15 2013, 11:33
Post #8





Group: Members
Posts: 46
Joined: 25-May 11
From: Germany
Member No.: 90967



Ok, here's the problem. Quicksearch by default sorts your tracks according to their filenames (the ones displayed in explorer), therefore "American Idiot" is put at the end.

You can either force your playlist to be sorted a certain way - however that's only possible with some playlist-plugins - or you can click on a certain column to sort it or you could just rename the files in a consistent way - what seems to be the best option in my opinion. To do so either rename it manually (American Idiot -> 01 American Idiot) or select the three files -> right click -> Tools -> File Operations -> "Move to" and then select a pattern you wish your files to be renamed. For more information on that, take a look at the wiki.

I would recommend to do the same with your whole library - given the fact that your tracks are tagged properly.
Go to the top of the page
+Quote Post
trout
post Feb 15 2013, 19:03
Post #9





Group: Members
Posts: 416
Joined: 26-March 09
Member No.: 68400



Yeah, it would be a good idea to fix your file names so they're consistent.
But there's still another solution -

Preferences > Shell Integration > Sort incoming files by:

default = %path_sort% = ordered by path and file name, which indeed seems to be what you have shown.
Unless you want to leave it that way, so you can find such problems with paths, you can change it to sort by tag values, something like:

%album artist% - %date% - %album% - %discnumber% - %tracknumber% - %title%

AFAIK Quicksearch uses this preference. Most components do, though some have their own sort prefs.
To fix existing playlists you can go to Edit > Sort

This post has been edited by trout: Feb 15 2013, 19:06
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th July 2014 - 03:27