IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
Streaming Ogg Packets
chris319
post May 5 2014, 08:47
Post #51





Group: Members
Posts: 28
Joined: 12-March 07
Member No.: 41410



OK, now I think I have it. No warnings or errors:

CODE
Processing file "OpusTestStreamChris.opus"...

New logical stream (#1, serial: 00000001): type opus
Encoded with libopus 1.1
User comments section follows...
        ENCODER=opusenc from opus-tools 0.1.8
        ENCODER_OPTIONS=--serial 1 --quiet --comp 0 --ignorelength
Opus stream 1:
        Pre-skip: 316
        Playback gain: 0 dB
        Channels: 1
        Original sample rate: 44100Hz
        Packet duration:   20.0ms (max),   20.0ms (avg),   20.0ms (min)
        Page duration:   1000.0ms (max),  510.0ms (avg),   20.0ms (min)
        Total data length: 9951 bytes (overhead: 9.51%)
        Playback length: 0m:00.999s
        Average bitrate: 79.61 kb/s, w/o overhead: 72.04 kb/s
Logical stream 1 ended
New logical stream (#2, serial: 00000002): type opus
Encoded with libopus 1.1
User comments section follows...
        ENCODER=opusenc from opus-tools 0.1.8
        ENCODER_OPTIONS=--serial 2 --quiet --comp 0 --ignorelength
Opus stream 2:
        Pre-skip: 316
        Playback gain: 0 dB
        Channels: 1
        Original sample rate: 44100Hz
        Packet duration:   20.0ms (max),   20.0ms (avg),   20.0ms (min)
        Page duration:   1000.0ms (max),  510.0ms (avg),   20.0ms (min)
        Total data length: 9951 bytes (overhead: 9.51%)
        Playback length: 0m:00.999s
        Average bitrate: 79.61 kb/s, w/o overhead: 72.04 kb/s
Logical stream 2 ended
Go to the top of the page
+Quote Post
lithopsian
post May 5 2014, 14:33
Post #52





Group: Members
Posts: 158
Joined: 27-February 14
Member No.: 114718



Beautiful! Does it stream?
Go to the top of the page
+Quote Post
chris319
post May 5 2014, 16:29
Post #53





Group: Members
Posts: 28
Joined: 12-March 07
Member No.: 41410



Yes it does. Looks like this is the winner.
Go to the top of the page
+Quote Post
lithopsian
post May 5 2014, 17:45
Post #54





Group: Members
Posts: 158
Joined: 27-February 14
Member No.: 114718



QUOTE (chris319 @ May 5 2014, 16:29) *
Yes it does. Looks like this is the winner.

Do you know what the problem was? Just a bug in writing the data? Or something basic to the Ogg format?
Go to the top of the page
+Quote Post
chris319
post May 5 2014, 19:43
Post #55





Group: Members
Posts: 28
Joined: 12-March 07
Member No.: 41410



Basically it was not knowing how to handle the HTTP headers and chainig ogg files, and each file needing a different serial number.

Thanks again for your help.

This post has been edited by chris319: May 5 2014, 19:47
Go to the top of the page
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st July 2014 - 13:25