IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Lenovo W520 audio dropouts, low volume
LocrianGroove
post Jul 5 2012, 08:21
Post #1





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



I have a Lenovo W520 with 2nd gen i7, 8GB RAM, running Windows 7 64 bit, and foobar2000. The audio skips during network activity when using the Conexant audio driver, but it doesn't have this problem with the Microsoft High Definition Device driver. This is even when the buffer in foobar2000 is set to 1500 ms.

The problem with the Microsoft driver, is the volume is limited (maybe 5 dB lower) than the Conexant driver. This is unacceptable when driving the Sennheiser HD 600 headphones with ReplayGain enabled, especially during quite passages. Is it possible to bump up the volume of the system when using the Microsoft driver?
Go to the top of the page
+Quote Post
Apesbrain
post Jul 5 2012, 13:41
Post #2





Group: Members
Posts: 478
Joined: 3-January 04
Member No.: 10915



So long as your playback is via foobar2000, you can boost the preamp gain:
File > Preferences > Playback > Preamp
Go to the top of the page
+Quote Post
LocrianGroove
post Jul 7 2012, 03:07
Post #3





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



The foobar2000 preamp gain won't help very much when the track peak is close to 1. Money For Nothing, from the Dire Straits CD Brothers In Arms (Track gain: +2.74 dB, Track peak: 1), won't be boosted by the preamp gain at all.
Go to the top of the page
+Quote Post
Dynamic
post Jul 7 2012, 22:14
Post #4





Group: Members
Posts: 803
Joined: 17-September 06
Member No.: 35307



QUOTE (LocrianGroove @ Jul 7 2012, 03:07) *
The foobar2000 preamp gain won't help very much when the track peak is close to 1. Money For Nothing, from the Dire Straits CD Brothers In Arms (Track gain: +2.74 dB, Track peak: 1), won't be boosted by the preamp gain at all.


I used to worry about clipping prevention too. Now, for me, a major mismatch in volume is worse than mild distortion to a noise-like transient peak, so I use Apply Gain without using clipping prevention in foobar2000. I then use the Advanced Limiter DSP which will look ahead and limit only peaks that would exceed 1.0 (full scale). So long as my preamp level is sane, that sounds great to me.
Go to the top of the page
+Quote Post
uart
post Jul 8 2012, 19:14
Post #5





Group: Members
Posts: 809
Joined: 23-November 04
Member No.: 18295



QUOTE (LocrianGroove @ Jul 5 2012, 00:21) *
I have a Lenovo W520 with 2nd gen i7, 8GB RAM, running Windows 7 64 bit, and foobar2000. The audio skips during network activity when using the Conexant audio driver, but it doesn't have this problem with the Microsoft High Definition Device driver. This is even when the buffer in foobar2000 is set to 1500 ms.

The problem with the Microsoft driver, is the volume is limited (maybe 5 dB lower) than the Conexant driver. This is unacceptable when driving the Sennheiser HD 600 headphones with ReplayGain enabled, especially during quite passages. Is it possible to bump up the volume of the system when using the Microsoft driver?

In addition to the Foorbar gain settings, have you confirmed that you've got the volume sliders (overall and wav) at 100% in the windows mixer?
Go to the top of the page
+Quote Post
LocrianGroove
post Jul 10 2012, 04:39
Post #6





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



Yes, the volume controls/mixer levels are all up in both cases. I just took some measurements.

I'm playing a 1 kHz sine wave with foobar2000 (using tone://1000:10) and measuring the open circuit voltage with each of the two drivers, volume up all the way in foobar2000, Windows 7, without using the foobar preamp gain.

With the Microsoft High Definition Device driver, I'm reading 444 mV
With the Conexant driver (with headphone limiter enabled), I'm reading 430 mV
With the Conexant driver (with headphone limiter disabled), I'm reading 965 mV
Go to the top of the page
+Quote Post
uart
post Jul 10 2012, 18:13
Post #7





Group: Members
Posts: 809
Joined: 23-November 04
Member No.: 18295



QUOTE (LocrianGroove @ Jul 9 2012, 19:39) *
With the Microsoft High Definition Device driver, I'm reading 444 mV
With the Conexant driver (with headphone limiter enabled), I'm reading 430 mV
With the Conexant driver (with headphone limiter disabled), I'm reading 965 mV

Interesting. So it looks like the real difference is that the "headphone limiter" cannot be disabled in the microsoft driver.

Take a really close look in the Windows mixer (I'm still using WinXP but there's probably something similar in Win7). Under "options" you'll sometimes find an "advanced options" setting that enables extra stuff like that.

BTW. What's the purpose of the "headphone limiter". Is it some kind of attempt to protect the listeners hearing from excessive volume?
Go to the top of the page
+Quote Post
DVDdoug
post Jul 10 2012, 18:37
Post #8





Group: Members
Posts: 2565
Joined: 24-August 07
From: Silicon Valley
Member No.: 46454



QUOTE
BTW. What's the purpose of the "headphone limiter". Is it some kind of attempt to protect the listeners hearing from excessive volume?
I believe this is an EU regulation. There's something about it mentioned in my Lenovo user manual. (My Lenovo laptop puts-out about 0.75VRMS with a high impedance load. I have not checked it with headphones.)
Go to the top of the page
+Quote Post
uart
post Jul 10 2012, 19:17
Post #9





Group: Members
Posts: 809
Joined: 23-November 04
Member No.: 18295



QUOTE (DVDdoug @ Jul 10 2012, 09:37) *
QUOTE
BTW. What's the purpose of the "headphone limiter". Is it some kind of attempt to protect the listeners hearing from excessive volume?
I believe this is an EU regulation. There's something about it mentioned in my Lenovo user manual. (My Lenovo laptop puts-out about 0.75VRMS with a high impedance load. I have not checked it with headphones.)

Thanks for the info Doug. I thought it would something like that.
Go to the top of the page
+Quote Post
LocrianGroove
post Jul 12 2012, 07:42
Post #10





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



QUOTE (uart @ Jul 10 2012, 13:13) *
Take a really close look in the Windows mixer (I'm still using WinXP but there's probably something similar in Win7). Under "options" you'll sometimes find an "advanced options" setting that enables extra stuff like that.

I did look carefully and double checked, but I couldn't find any other way to boost the volume. I wonder if there's a registry value that could be changed to disable the volume limiter, though I haven't been able to find anything on this.
Go to the top of the page
+Quote Post
[JAZ]
post Jul 12 2012, 18:13
Post #11





Group: Members
Posts: 1772
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



I have a realtek HDAudio in my laptop, with the brand drivers, but I believe the setting was also there with the standard Windows 7 drivers, check this:

rightclick on speaker in the taskbar -> playback devices.

In the playback tab, select "Speakers", right click -> properties.

There, see if you have a tab labeled "personalized" or something like that. In that tab I have a checkbox named "Limited output". You need to uncheck this.

Go to the top of the page
+Quote Post
LocrianGroove
post Jul 13 2012, 03:59
Post #12





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



QUOTE ([JAZ] @ Jul 12 2012, 13:13) *

There, see if you have a tab labeled "personalized" or something like that. In that tab I have a checkbox named "Limited output". You need to uncheck this.

The tabs I have are General, Levels, Enhancements, and Advanced, and unfortunately there's not a limited output option. I have driver version 6.1.7601.17514 from 11/19/2010.

I have decided to send my laptop back to Lenovo, since it really should have worked out of the box, or at least with the latest drivers. I'll post again with my results. Thanks for all of the suggestions.
Go to the top of the page
+Quote Post
uart
post Jul 13 2012, 13:21
Post #13





Group: Members
Posts: 809
Joined: 23-November 04
Member No.: 18295



QUOTE (LocrianGroove @ Jul 12 2012, 18:59) *
I have decided to send my laptop back to Lenovo, since it really should have worked out of the box, or at least with the latest drivers.

It will be interesting to see how that turns out. Are you going to send it back with the reason: "audio drops out under network activity" or: "audio volume insufficient"?
Go to the top of the page
+Quote Post
LocrianGroove
post Jul 13 2012, 15:08
Post #14





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



It will be for the reason, audio drops out under network activity. I don't think Lenovo supports anything other than their own drivers, so I wouldn't get anywhere complaining about Microsoft's driver. Does anyone ever get anywhere complaining about Microsoft's software?

This post has been edited by LocrianGroove: Jul 13 2012, 15:09
Go to the top of the page
+Quote Post
AliceWonder
post Jul 23 2012, 05:56
Post #15





Group: Members
Posts: 119
Joined: 13-July 12
From: California
Member No.: 101393



Have you tried a 3rd party USB sound card?
I have similar laptop (T520, quad core i7 8GB) and found that audio is much better using Logitech headphones that have their own built in USB sound card.
I have both cheap wired (USB - ~$20) and wireles (also USB ~ $85).

I never had good luck with the built in sound out. Maybe the difference was headphones and not the USB sound card, I really don't know, but I doubt the Logitech I have now qualify as good headphones.

I've not had any problems, native audio or Logitech, with audio skipping during network traffic. I've used when I'm docked (cat5) or not (802.11n). That may be a hardware problem.
I don't know which wireless you went with, I did not go for the fancier 2 band internal wireless but went with the basic, figuring I didn't want the extra internal heat and rarely am far from a hot spot.
Go to the top of the page
+Quote Post
LocrianGroove
post Oct 8 2012, 05:27
Post #16





Group: Members
Posts: 107
Joined: 28-February 07
Member No.: 41051



QUOTE (LocrianGroove @ Jul 12 2012, 22:59) *
I have decided to send my laptop back to Lenovo, since it really should have worked out of the box, or at least with the latest drivers. I'll post again with my results. Thanks for all of the suggestions.


QUOTE (AliceWonder @ Jul 23 2012, 00:56) *
I've not had any problems, native audio or Logitech, with audio skipping during network traffic. I've used when I'm docked (cat5) or not (802.11n). That may be a hardware problem.


After sending the laptop back to Lenovo for repair three times, newegg sent me a new laptop. The replacement is the same model and does not have this problem.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd August 2014 - 08:12