IPB

Welcome Guest ( Log In | Register )

16 Pages V  « < 12 13 14 15 16 >  
Reply to this topicStart new topic
LAME 3.99 is out, 2012-02-28: version 3.99.5 has been released
bbrabant
post Jan 28 2012, 13:11
Post #326





Group: Members
Posts: 44
Joined: 4-April 07
Member No.: 42201



QUOTE (john33 @ Jan 28 2012, 12:59) *
What error message do you get, if any?


Immediately after running lame a windows dialog box comes up "Application Failure lame.exe 3.99.2.4 in lame.exe 3.99.2.4 at offset 0001afa6"
Go to the top of the page
+Quote Post
biomega
post Jan 28 2012, 14:55
Post #327





Group: Members
Posts: 1
Joined: 28-January 12
Member No.: 96760



QUOTE (bbrabant @ Jan 28 2012, 10:53) *
Thanks for the new Lame compiles but on my windows xp pc (32bit) I am unable to run these compiles. I had no problem running the previous compiles of Lame.


Same problem here. NO error messages. Nothings happens (in the command-line window it simply jumps to a new line).

I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)
Could that may be the case for this new release (LAME 3.99.4)?

This post has been edited by biomega: Jan 28 2012, 15:34
Go to the top of the page
+Quote Post
Alex B
post Jan 28 2012, 17:41
Post #328





Group: Members
Posts: 1303
Joined: 14-September 05
From: Helsinki, Finland
Member No.: 24472



QUOTE (biomega @ Jan 28 2012, 15:55) *
I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)
Could that may be the case for this new release (LAME 3.99.4)?

You may be right. I just tried AMD Athlon XP 3200+ on Win 7 (32-bit). LAME 3.99.4 did not work when using the same foobar2000 settings that work fine with 3.99.3.

foobar2000 reported:

Conversion failed: The encoder has terminated prematurely with code -1073741795 (0xC000001D); please re-check parameters

This post has been edited by Alex B: Jan 28 2012, 17:42


--------------------
http://listening-tests.freetzi.com
Go to the top of the page
+Quote Post
bbrabant
post Jan 28 2012, 21:32
Post #329





Group: Members
Posts: 44
Joined: 4-April 07
Member No.: 42201



QUOTE (biomega @ Jan 28 2012, 16:55) *
I've only encountered a similar behavior with programs that require a CPU with SSE2 support. (using an AthlonXP without SSE2)


I am using a AMD Athlon XP 2200 also without SSE2 support
Go to the top of the page
+Quote Post
R3D
post Feb 3 2012, 12:32
Post #330





Group: Members
Posts: 2
Joined: 3-February 12
Member No.: 96908



Hey, I've got a question and I hope you can help me. (I hope it's the right topic)

I would like to convert my CD's new. For the last nearly 2 years I used Rarewares Lame bundle 3.98.4 64-Bit all the time. But deleted it by mistake.
The problem is that I can't find the Rarewares 3.98.4 64-Bit version on their website anymore. Just the 32-Bit version of 3.98.4.

And I don't know if I can trust Lame 3.99.4 because I read about artifacts.


So, my question is... does someone know where I can find the Rarewares 64-Bit version of Lame 3.98.4?

Thanks. smile.gif
Go to the top of the page
+Quote Post
john33
post Feb 3 2012, 13:08
Post #331


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3761
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Here you go:

http://homepage.ntlworld.com/jfe1205/LAME/lame3.98.4-64.zip smile.gif

This post has been edited by db1989: Feb 3 2012, 20:47
Reason for edit: removing pointless full quote of above post


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
R3D
post Feb 3 2012, 18:49
Post #332





Group: Members
Posts: 2
Joined: 3-February 12
Member No.: 96908



Thx for your quick help! smile.gif

This post has been edited by db1989: Feb 3 2012, 20:47
Reason for edit: as above
Go to the top of the page
+Quote Post
db1989
post Feb 7 2012, 14:48
Post #333





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Split: LAME: different compilers producing significantly different bitstreams
Go to the top of the page
+Quote Post
Steve Forte Rio
post Feb 25 2012, 10:12
Post #334





Group: Members
Posts: 469
Joined: 4-October 08
From: Ukraine
Member No.: 59301



Hi all. I wonder when we will see regular (non-test) LAME 3.99.5 32- and 64-bit compiles at RareWares?
Go to the top of the page
+Quote Post
ZinCh
post Feb 28 2012, 20:57
Post #335





Group: Members
Posts: 171
Joined: 28-September 06
Member No.: 35705



LAME 3.99.5 final version released today ( February 28 2012 )
Go to the top of the page
+Quote Post
john33
post Feb 28 2012, 23:38
Post #336


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3761
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



A full set of 3.99.5 compiles is now at Rarewares.

For anyone who may have used the most recent test compile; there are no code changes in the release version so there is no need to re-encode anything. smile.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
eahm
post Feb 29 2012, 00:48
Post #337





Group: Members
Posts: 1161
Joined: 11-February 12
Member No.: 97076



Good birthday present thank you smile.gif

This post has been edited by eahm: Feb 29 2012, 01:18
Go to the top of the page
+Quote Post
apodtele
post Mar 1 2012, 19:40
Post #338





Group: Members
Posts: 39
Joined: 16-November 11
Member No.: 95199



I run Windows 7 64-bit, however...

32-bit Winamp uses lame_enc.dll. Do I have to take 32-bit build?
32-bit foobar2000 uses lame.exe. Can I take 64-bit build?

See how confused I am?

Unfortunately, those players do not come in 64-bit form to bring me peace.
Go to the top of the page
+Quote Post
Jebus
post Mar 1 2012, 20:12
Post #339





Group: Developer
Posts: 1323
Joined: 17-March 03
From: Calgary, AB
Member No.: 5541



Appologies and thanks in advance, because I know this increases the work for you every time a new release is made, but any chance we could get those libmp3lame downloads updated to the latest as well?
Go to the top of the page
+Quote Post
john33
post Mar 1 2012, 23:28
Post #340


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3761
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (Jebus @ Mar 1 2012, 19:12) *
Appologies and thanks in advance, because I know this increases the work for you every time a new release is made, but any chance we could get those libmp3lame downloads updated to the latest as well?

Done. smile.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
DoctorO
post Mar 1 2012, 23:56
Post #341





Group: Members
Posts: 29
Joined: 11-April 11
Member No.: 89722



QUOTE (apodtele @ Mar 1 2012, 18:40) *
32-bit Winamp uses lame_enc.dll. Do I have to take 32-bit build?
you need to use the 32-bit compile of lame_enc.dll as Winamp cannot load / use the 64-bit version.

-daz
Go to the top of the page
+Quote Post
yakuman
post Mar 2 2012, 00:30
Post #342





Group: Members
Posts: 6
Joined: 2-March 12
Member No.: 97505



QUOTE (apodtele @ Mar 1 2012, 13:40) *
32-bit foobar2000 uses lame.exe. Can I take 64-bit build?

See how confused I am?

Unfortunately, those players do not come in 64-bit form to bring me peace.

I've been there too. foobar2000 can encode with 64-bit LAME. This is what I've been doing ever since I recently discovered the 64-bit version. I don't know if there's any quality or size difference in the result of MP3 files, though.

This post has been edited by yakuman: Mar 2 2012, 00:30
Go to the top of the page
+Quote Post
Fishman0919
post Mar 2 2012, 17:42
Post #343





Group: Members
Posts: 79
Joined: 18-December 03
Member No.: 10554



I'm getting an error when trying to compile with "nmake -f Makefile.MSVC MSVCVER=8.0 PREC=DOUBLE"

CODE
Setting environment for using Microsoft Visual Studio 2010 x86 tools.

C:\Program Files\Microsoft Visual Studio 10.0\VC>cd lame

C:\Program Files\Microsoft Visual Studio 10.0\VC\lame>nmake -f Makefile.MSVC MSV
CVER=8.0 PREC=DOUBLE

Microsoft ® Program Maintenance Utility Version 10.00.30319.01
Copyright © Microsoft Corporation. All rights reserved.

----------------------------------------------------------------------
building LAME featuring RH
+ ASM
+ MMX
+ using MSVC 8.0 32-Bit Compiler
+ optimizing for Pentium II/III
----------------------------------------------------------------------
Pass GTK=YES to build the frame analyzer. (requires installed GTK)


--- LAME MP3 ENCODING LIBRARY UPTODATE ---


--- HIP DECODING LIBRARY UPTODATE ---


--=* .\output\libmp3lame-static.lib ready *=--


--- COMMON FRONTEND STUFF UPTODATE ---

Microsoft ® Windows ® Resource Compiler Version 6.1.7600.16385
Copyright © Microsoft Corporation. All rights reserved.

libmp3lame-static.lib(psymodel.obj) : error LNK2001: unresolved external symbol
_static_assert_tab_mask_add_delta
.\output\lame.exe : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: '"c:\Program Files\Microsoft Visual Studio 10.0\VC\BI
N\link.EXE"' : return code '0x460'
Stop.

C:\Program Files\Microsoft Visual Studio 10.0\VC\lame>


This post has been edited by db1989: Mar 2 2012, 17:44
Reason for edit: Please enclose large items in [codebox] rather than [code] tags.
Go to the top of the page
+Quote Post
robert
post Mar 2 2012, 21:23
Post #344


LAME developer


Group: Developer
Posts: 788
Joined: 22-September 01
Member No.: 5



You'll have to remove the /GL compiler option in Makefile.MSVC line 209.
The _static_assert_tab_mask_add_delta symbol is there to do some compile-time assertions, there should be no such symbol actually compiled into the object files. I don't know, why the linker thinks it should find such a thing, when using /GL for whole program optimization.

some variations on static asserts
Go to the top of the page
+Quote Post
ZinCh
post Mar 2 2012, 21:32
Post #345





Group: Members
Posts: 171
Joined: 28-September 06
Member No.: 35705



Can someone post LAME 3.99.5 builds using MS VC 11 (beta) ?
Go to the top of the page
+Quote Post
Fishman0919
post Mar 3 2012, 05:21
Post #346





Group: Members
Posts: 79
Joined: 18-December 03
Member No.: 10554



QUOTE (robert @ Mar 2 2012, 13:23) *
You'll have to remove the /GL compiler option in Makefile.MSVC line 209.
The _static_assert_tab_mask_add_delta symbol is there to do some compile-time assertions, there should be no such symbol actually compiled into the object files. I don't know, why the linker thinks it should find such a thing, when using /GL for whole program optimization.

some variations on static asserts


Thank You
Go to the top of the page
+Quote Post
Kilu
post Mar 9 2012, 15:13
Post #347





Group: Members
Posts: 36
Joined: 1-May 05
Member No.: 21811



Wonderful, wonderful.


--------------------
made of radiation
Go to the top of the page
+Quote Post
alexz721
post Mar 24 2012, 04:03
Post #348





Group: Members
Posts: 2
Joined: 6-June 07
Member No.: 44091



QUOTE (john33 @ Feb 3 2012, 08:08) *

Hi, was wondering if you could re-up this as the link is dead.
Go to the top of the page
+Quote Post
john33
post Mar 24 2012, 19:54
Post #349


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3761
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (alexz721 @ Mar 24 2012, 03:03) *
QUOTE (john33 @ Feb 3 2012, 08:08) *

Hi, was wondering if you could re-up this as the link is dead.

And again: http://www.john1205.webspace.virginmedia.c...me3.98.4-64.zip

wink.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
alexz721
post Mar 25 2012, 18:17
Post #350





Group: Members
Posts: 2
Joined: 6-June 07
Member No.: 44091



QUOTE (john33 @ Mar 24 2012, 14:54) *
QUOTE (alexz721 @ Mar 24 2012, 03:03) *
QUOTE (john33 @ Feb 3 2012, 08:08) *

Hi, was wondering if you could re-up this as the link is dead.

And again: http://www.john1205.webspace.virginmedia.c...me3.98.4-64.zip

wink.gif

Much thanks, sir.
Go to the top of the page
+Quote Post

16 Pages V  « < 12 13 14 15 16 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th November 2014 - 19:17