IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
DTS playing too fast through sp/dif, DTS-audio goes Speedy Gonzales
Jimmygarn
post Apr 8 2004, 16:38
Post #1





Group: Members
Posts: 1
Joined: 8-April 04
Member No.: 13331



I have a strange problem when playing back DTS encoded cds on my computer, when streaming the signal digitally through my sp/dif the music plays too fast and grown ups sound like children while children becomes all squirrelly. However it sounds ok if I choose to decode the signal and play it back analog.

I't doesn't matter which player I use, I've tried Mplayer Classic as well as Power DVD 5.

Have anyone got a clue what to do?
Go to the top of the page
+Quote Post
2thumbs
post Apr 8 2004, 16:59
Post #2





Group: Members
Posts: 39
Joined: 27-January 04
Member No.: 11565



Hmm. I don't know too much about this, but could this happen if the clock was too fast? You should be able to either sync your soundcard's digital input to the clock of your DTS player (ie, use the player as the master/external clock), or set your soundcard as the master with the right clock. If it's playing too fast, maybe it's stuck at 96KHz, but DTS encoded material is only sampled at 48KHz?

... or maybe I'm totaly off. unsure.gif
Go to the top of the page
+Quote Post
Covak
post Apr 8 2004, 17:27
Post #3





Group: Members
Posts: 12
Joined: 20-June 03
Member No.: 7304



DTS CDs are encoded at 44.1KHz. Whatever's decoding your SPDIF stream must be assuming it's regular old 48KHz DTS. I've heard the problem before. Never found a fix sad.gif
Go to the top of the page
+Quote Post
Pio2001
post Apr 9 2004, 21:46
Post #4


Moderator


Group: Super Moderator
Posts: 3936
Joined: 29-September 01
Member No.: 73



Maybe the soundcard is a resampling one, and even when it doesn't resample, in order to play DTS, it is still stuck at 48 kHz (that is the hardware reason for resampling).
Go to the top of the page
+Quote Post
ViPER1313
post Apr 9 2004, 21:48
Post #5





Group: Members
Posts: 271
Joined: 19-August 02
From: Maryland
Member No.: 3109



Does your receiver support DTS encoded materials?
Go to the top of the page
+Quote Post
marcan
post Apr 10 2004, 00:12
Post #6





Group: Members (Donating)
Posts: 478
Joined: 17-October 02
Member No.: 3565



I was able to play dts encoded in 48 khz with Power DVD, but I couldn’t play DTS Audio. Actually, DTS Audio is encoded in 44.1...

I have found two solutions.

The first solution was to use my very old CD player with the digital output (sp/dif) feeding my decoder.

The second solution is to feed in 44.1 my decoder with foobar thru asio driver (in order to be sure to keep each bit accurate). You must disable all digital treatment (DSP, dithering).

You can rip your DTS audio like a normal CD (freedb generally have the right names) and play it as a normal wav.

It works well now on my laptop, when a dts or ac3 file is played on my playlist, my decoder directly detect it.... but I still need Power DVD in order to play DTS and ac3 encoded in 48. dry.gif

Hope this help.
Go to the top of the page
+Quote Post
-=Wolf=-
post Apr 14 2004, 02:10
Post #7





Group: Members
Posts: 6
Joined: 13-April 04
Member No.: 13461



Hi there!

I have SB audigy... I have the same problem, 48khz DTS ok, 44.1khz DTS audio is not... I tried foobar2000 but i heard only pink noise... where can i get ASIO driver for my soundcard? OS: win XP pro..
All thing are disabled such as DPS, dither, etc...

i cannot find anywhere....
Go to the top of the page
+Quote Post
MugFunky
post Apr 19 2004, 08:35
Post #8





Group: Members
Posts: 493
Joined: 28-December 03
From: Melbourne, Aus
Member No.: 10767



unfortunately if you have a resampling soundcard (creative have won no friends from this design flaw), there's not a lot you can do.

either:
it doesn't resample, it just plays back at 48 instead of 44.1, in which case you get super-fast sound

or:
it resamples, causing the DTS data to b0rk completely, giving white noise at -12db

the problem is that DTS is a simple CDDA stream. the soundcard thinks it's streaming a PCM wave rather than DTS data.

if you have a CD/DVD player with spdif, use that, or get yourself a soundcard that doesn't resample everything to 48k
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th September 2014 - 01:37