IPB

Welcome Guest ( Log In | Register )

78 Pages V  « < 61 62 63 64 65 > »   
Reply to this topicStart new topic
foo_upnp, UPnP/DLNA client and server (previously foo_upnp_mediaserver)
bubbleguuum
post Jun 12 2012, 16:57
Post #1551





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (kumbbl @ Jun 12 2012, 15:53) *
Overall summary: I do not understand why with PlugPlayer-App always the PlugPlayer-Profile (with its downsampling) is used even when using profile foobar2000-Profile (without downsampling, s. on top profile description) is reported (s.a.). And i also do not understand why with iMediaControl it seems that never a downsampling occurs even if using profile iMediaControl-profile (with its downsamling) is reported...


Profiles can be confusing because there are apps or client that use 2 differents User-Agent for http requests: one for Browsing and one for streaming.

The more important one is the one used for Browsing. It determines which profile will be used when the streaming request arrive.
Here in you first log, it looks like the Default profile was used because probably the Browsing User-Agent was not containing "imediacontrol4ipad".
Either that, or the Default profile is forced in "Basic Settings > Always use the Defautl Streaming profile...".

The hint that the default profile is used is the stream URL found in the metadata:
http://192.168.178.38:56923/content/388d5e...amp;convert=wav

profile_id 0 is the Default profile.

profile_id is always used to know which profile to use when the actual stream request is made by the Control Point on this URL, *except* (and this is were it gets confusing) to
determine if the playback stats should be submitted or not for this request (in this case the profile determined from the streaming User-Agent request is used).

That's why you get the confusing trace (profile used for determining if playback stats should be submitted):
41.41119: upnp_server_conf::get_profile(830)/7800: INFO: using profile 'iMediaControl-Profile', matching header (User-Agent:imediacontrol4ipad/1.0 CFNetwork/548.0.4 Darwin/11.0.0)

combined with:
opened 'file://W:\Klaus\Musik\archiv\1-H\ACDC\Back In Black\Original 1st press US (Vinyl Rip)\1980\24-96\06. Back In Black.flac' for streaming, profile: Default, WAV / 96000 Hz / 24 bits / 2 channels, replaygain: on, DSP chain: off

If you want to determine what is the User-Agent used by iMediaControl for browsing look for traces looking like this:

foo_upnp: 16422.16422408: FbMediaServer::OnAction(261)/6172: INFO: received action 'Browse', args = { ObjectID=0, BrowseFlag=BrowseDirectChildren, Filter=*, StartingIndex=0, RequestedCount=16, SortCriteria= }
foo_upnp: 16422.16422408: upnp_server_conf::get_profile(830)/6172: INFO: using profile 'BubbleUPnP', matching header (User-Agent:Android/2.3.7 UPnP/1.0 BubbleUPnP/1.4.3.1)

I know that it is a real pain to configure the server if targetting multiple renderers with a pure Control Point (which can also be a renderer).
It comes from the fact that the target renderer cannot be known at browse time in that case.
However there is a simple solution that you can try and that may work if the Control Point is not too dumb:

- force the use of the Default profile in Basic Settings
- set the Default Profile to the specs of the highest renderer you will use

When browsed with this profile, for each track, 3 URLs are returned to the Control Point

1. the URL as determined by the profile settings
2. a hardcoded 44.1/16 WAV stream (profile_id=1000)
3. a hardcoded 44.1/16 LPCM stream (profile_id=1001)

Either 2. or 3. are playable by all renderers. If the CP is not too dumb it will pick 2 or 3 if it determines that 1. is not playable by the target render.


As a side note I do not understand how imediacontrol4ipad could play WAV/96/24 unless it downsamples it to 48/16.

This post has been edited by bubbleguuum: Jun 12 2012, 16:58
Go to the top of the page
+Quote Post
kumbbl
post Jun 12 2012, 18:09
Post #1552





Group: Members
Posts: 55
Joined: 6-June 06
Member No.: 31522



Hi,

first of all many thanks for your fast and interesting reply, great service!!

QUOTE (bubbleguuum @ Jun 12 2012, 09:57) *
I know that it is a real pain to configure the server if targetting multiple renderers with a pure Control Point (which can also be a renderer).
It comes from the fact that the target renderer cannot be known at browse time in that case.


yes, it seems to be a real pain, you are right....

QUOTE (bubbleguuum @ Jun 12 2012, 09:57) *
However there is a simple solution that you can try and that may work if the Control Point is not too dumb:

- force the use of the Default profile in Basic Settings
- set the Default Profile to the specs of the highest renderer you will use

When browsed with this profile, for each track, 3 URLs are returned to the Control Point

1. the URL as determined by the profile settings
2. a hardcoded 44.1/16 WAV stream (profile_id=1000)
3. a hardcoded 44.1/16 LPCM stream (profile_id=1001)

Either 2. or 3. are playable by all renderers. If the CP is not too dumb it will pick 2 or 3 if it determines that 1. is not playable by the target render.


sounds like a really good solution but unfortunately both CPs PlugPlayer and eLyric from PS Audio (for eLyric all reports above analog, i.e. the special eLyric profile with downsampling is choosen) are too dumb because they seem not to pick 2 or 3 but instead they fail to render 1 :-(

so there seems to be no solution for Apps like PlugPlayer or eLyric... or do you have another idea based on streaming profiles?


QUOTE (bubbleguuum @ Jun 12 2012, 09:57) *
As a side note I do not understand how imediacontrol4ipad could play WAV/96/24 unless it downsamples it to 48/16.


could not your described solution above be the reason why rendering on iPad with iMediaControl works also for HiRes-Streams?! as shown in my previous posting iMediaControl chooses always the Default profile and in this case your solution with this 2 fallback URLs (2: 44.1/16 WAV and 3: 44.1/16 LPCM) could be take place, so maybe iMediaControl is no so dumb but so smart to choose either 2 or 3 when recognicing not being able to render URL 1 ... could this be the explanation why iMediaControl works or have i now something misunderstood?

Again: thanks a lot for your great help service!!
Go to the top of the page
+Quote Post
bubbleguuum
post Jun 12 2012, 18:20
Post #1553





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (kumbbl @ Jun 12 2012, 19:09) *
so there seems to be no solution for Apps like PlugPlayer or eLyric... or do you have another idea based on streaming profiles?


The only possible solutions for you are

- setup a profile that is the least common denominator between your renderers. That probably means restricting playback to 48/16 and converting
most non universally supported format (flac, etc) to WAV. That's mostly the description of the unmodified Default profile, setup to be the more compatible

- run 2 instances of foobar2000 to create 2 servers with different settings and browse the appropriate one depending on the target renderer in your Control Point app.

Both of these solutions kind of suck but I cannot think of anything else.

QUOTE (kumbbl @ Jun 12 2012, 19:09) *
could not your described solution above be the reason why rendering on iPad with iMediaControl works also for HiRes-Streams?! as shown in my previous posting iMediaControl chooses always the Default profile and in this case your solution with this 2 fallback URLs (2: 44.1/16 WAV and 3: 44.1/16 LPCM) could be take place, so maybe iMediaControl is no so dumb but so smart to choose either 2 or 3 when recognicing not being able to render URL 1 ... could this be the explanation why iMediaControl works or have i now something misunderstood?


No, as the "open file for streaming" line would have been different mentioning WAV/44.1/16 or LPCM/44.1/16

This post has been edited by bubbleguuum: Jun 12 2012, 18:21
Go to the top of the page
+Quote Post
LoonyTunes
post Jun 13 2012, 14:40
Post #1554





Group: Members
Posts: 2
Joined: 11-June 12
Member No.: 100617



QUOTE (bubbleguuum @ Jun 12 2012, 16:34) *
QUOTE (LoonyTunes @ Jun 11 2012, 20:09) *
I have a question about how FLAC files are displayed on the client, in this case an Oppo BDP-93. All of my FLAC files that are 44/16 display as FLAC files on the 93, but any FLAC files that are 44/24 and higher display as PCM files on the 93. Is this normal or is there something that I'm missing in the UPnP setup?
Yes this is normal. With the Default profile (used by the Oppo) anything higher than 44.1Khz is streamed as 16 bits wav.
If your Oppo support higher samplerates modify maximum samplerate in the Default profile and eventually set max bitdepth to 24.

Thank you for the quick feedback!

OK, I configured a streaming profile for the Oppo as follows:

My streaming profile is named BDP-93
The USER-AGENT contain OPPO (based on info received from Oppo)
samplerate range 44100 to 19200 24 bit
No checkmark on Stereo only
Transcoding to MP3 is never with Except extensions blank, lossless and internet checked
Decoding to PCM is never to lpcm with except blank
Playback stream capture is wav 44100 16bit
No active DSP's

Checked to make sure that "Basic Settings > Always use the Defautl Streaming profile..." was not checked and then browsed the files from the Oppo. Still have the files above 44/16 showing as PCM, not FLAC.

Then I configured the default streaming profile as follows:

Streaming profile is named default
The USER-AGENT contain is blank
samplerate range 44100 to 19200 24 bit
No checkmark on Stereo only
Transcoding to MP3 is never with Except extensions blank, lossless and internet checked
Decoding to PCM is never to lpcm with except blank
Playback stream capture is wav 44100 16bit
No active DSP's

Changed the "Basic Settings > Always use the Defautl Streaming profile..." by adding check mark and then browsed the files from the Oppo. Still have the files above 44/16 showing as PCM, not FLAC.

At this point I don't see the different profiles making any difference on how the higher res files are shown on the Oppo.

I also took the disk drive that contains these files disconnected it from my computer and connected it to one of the USB ports on the Oppo and all files, including the hi res files, display as FLAC and play as hi res. Also when I burn a few of these hi res files to cd or dvd they show as FLAC and play as hi res on the Oppo.

Any help on getting the 93 to see the higher res files as FLAC and not PCM would be greatly appreciated!!

This post has been edited by db1989: Jun 13 2012, 23:09
Reason for edit: quote of bubbleguuum lacked proper opening tag/attribution + I added LoonyTunes’s OP for context
Go to the top of the page
+Quote Post
akispavlopoulos
post Jun 20 2012, 15:18
Post #1555





Group: Members
Posts: 21
Joined: 3-August 08
Member No.: 56649



Hi!

I'm using your wonderful plugin to stream music to my devices! I have just bought a new LG smart tv (42LM620s), that has DLNA. I can browse throw my tv to my foobar library and stream everything! The only "problem" I have is that when I browse to my folders or stream music I can't see any album art. When I browse throw TVersity I can see album art. I can see album art on my tv when I use your bubbleupnp apk in my android phone to stream music to my tv throw foobar's library too! Why I can't see the album art when I browse directly throw my tv? Are there any options that I have to do? I have enable the "Allow album art streaming" in the upnp options of foobar. Thank you!
Go to the top of the page
+Quote Post
skrech
post Jun 24 2012, 12:44
Post #1556





Group: Members
Posts: 5
Joined: 30-September 11
Member No.: 94074



QUOTE (Speech @ Dec 24 2009, 22:43) *
- If I start a audio file in a playlist from the external device, it would play, but it also sets the option Stop after current (available in the Playback main menu). I would rather prefer it to let the audio continue with the next files in the playlist instead.



QUOTE (bubbleguuum @ Dec 25 2009, 22:04) *
I suppose you mean you are remote controlling a foobar2000 Media Renderer instance, and on that instance "Stop After Current" remains enabled.
During the time of being remotely controlled, the Renderer enables "Stop After Current" because it needs it for proper operation. It just does a poor job at restoring the initial
"Stop After Current" state when not being controlled anymore.



QUOTE (bubbleguuum @ Dec 27 2009, 17:20) *
@Speech: Stop After Current should be fixed in the new version.


Hello,
I'm trying to use my Nokia N9 as a remote controller for foobar2000 and this Stop After Current is very annoying. Is there a possibility for a fix for that?
Go to the top of the page
+Quote Post
Mikka
post Jun 24 2012, 19:35
Post #1557





Group: Members
Posts: 1
Joined: 24-June 12
Member No.: 100941



bubbleguuum, if adding transcoding to vorbis or aac is not too much of a hassle, it would be greatly appreciated!
Go to the top of the page
+Quote Post
tpg8
post Jun 25 2012, 03:31
Post #1558





Group: Members
Posts: 1
Joined: 25-June 12
Member No.: 100948



I have a question about gapless playback...

I use a custom built "minimalist" computer audio server which holds my lossless high-resolution files encoded (mostly in FLAC). The computer is connected directly to my DAC and the computer itself takes care of playback.

What I want to do is just remotely control my audio server using my windows tablet across my home network. I have foobar and foo_upnp installed on both machines and can control the server with the UPnP controller, but playback is not gapless.

Is there a way to force gapless playback in this situation? I mean, the server is playing its own locally stored files and is only being told to do so from across the network - no media is actually being streamed.

Thank you!
Go to the top of the page
+Quote Post
maruko
post Jun 25 2012, 17:12
Post #1559





Group: Members
Posts: 1
Joined: 25-June 12
Member No.: 100975



Hello,

I am already searching for months for a decent UPNP Player / Controller for Windows.
I am using TVersity DLNA Server. And the Plugplayer clients on my phone/tablet.

Now I tried the UPNP Controller function of Foobar, I can controll the tablet (Plugplayer) very good also volume is working.
Only thing I am missing, it's not picking up the current playlist.

And also it takes very long before UPNP Controller finds my tablets in the Network. Can he remember such things or can I add manually?

Thanks & Regards,

Marco de Groot
Go to the top of the page
+Quote Post
thirl88
post Jul 1 2012, 03:59
Post #1560





Group: Members
Posts: 1
Joined: 1-July 12
Member No.: 101096



Hi, I'm brand new to Foobar having installed it purely for its Playback Stream Capture function. I've been disapointed to see that when streaming, my music player (a Roberts 83i) does not display ID3 tag info. It simply says Title: Foobar2000 Playback Stream Capture, Artist: Foobar2000

Is it possible to have the correct artist & title info displayed when in stream capture mode. The tags are displayed correctly in normal uPnP mode but I have other issues with uPnP playback - namely the Roberts freezes up all the time when trying to load tracks (this happens with WMP, Twonky, TVersity as well as Foobar). But it plays fine all day long with Foobar and Playback Stream Capture, but with no artist, title info.

Any ideas??

Thanks

This post has been edited by thirl88: Jul 1 2012, 04:09
Go to the top of the page
+Quote Post
emueyes
post Jul 1 2012, 16:45
Post #1561





Group: Members
Posts: 29
Joined: 13-June 12
Member No.: 100657




OK, I'm not sure this is actually a 3rd party addin question, but it leads on from the great help I received when working out the details of this issue.

To recap, I have compilation albums and loose singles, and don't want hundreds of artists with a single song in the collection to be appearing in the artist listing; it was suggested that a Various Albums 'album' could be assigned to them in the Album Artist tag, which works very well, I now have various Various Artist albums.

However, they don't seem to be respected over the UPnP server. Showing artists shows the original list with hundreds of artists, showing album artists shows every album for every artist.

I have to say at this stage that I'm using an Android tablet and an Android app called UPnPlay, so if I'm out of range for this board please don't censure me, just tell me. I don't think I am though, I think it's a UPnP problem, or more specifically my lack of knowledge of it that is the problem.

In the UPnP >> Server >> Content page of fb2k there is what appears to be some settings for altering what will be shown to UPnP clients, and in particular an XML edit function containing default values.

I want the UPnP server to behave the same way as fb2k itself does, that is, of there is an Album Artist field present for a track, then use it, otherwise use the artist tag.

Am I looking in even remotely the right place within fb2k to do this, or is it a problem with the client ?
Go to the top of the page
+Quote Post
e1964692@rtrtr.c...
post Jul 14 2012, 11:12
Post #1562





Group: Members
Posts: 1
Joined: 14-July 12
Member No.: 101427



hey bubbleguuum, very nice plugin for foobar!

i hear music through it and bubbleupnp since i get my 99$ touchpad.. very cool!

next step is to use the renderer and the music server at the same time. my idea is to use the tablet to select the music from my foobar playlist/archiv on my pc and render it on the same pc, controlled by bubbleupnp.
but i dont get it to work. he doesnt play my selectet music. but when i play a random file on foobar@pc and open bubbleupnp@touchpad i can pause the track and resume!?

when i want to render music on pc the logfile says:

CODE
Opening track for playback: "http://192.168.1.100:56923/content/623597dd29c7b875fe90cd990a48a74f.mp3"
Unable to open item for playback (Bad Request (400)):
"http://192.168.1.100:56923/content/623597dd29c7b875fe90cd990a48a74f.mp3"


maybe u can help me,

greetz from germany

e19

Go to the top of the page
+Quote Post
jorometala
post Jul 15 2012, 10:02
Post #1563





Group: Members
Posts: 1
Joined: 15-July 12
Member No.: 101439



Hallo
First sorry for my bad English.
I'm using Foobar and foo_upnp plugin on Win Xp (don't ask why) for long time. Soon I put the pc in the closet and configure it to sleep after 15 minutes idle (for energy saving) and I noticed that when I play music on the pc on my local network the server pc goes to sleep after 15 minutes and оf course the music stops. Is that a misconfiguration or an issue of foobar and foo_upnp ? Is there a way to make the server to holds the PC awake when there is a streaming in progress and to go to sleep after the set idle time go to sleep when there is no streaming?

edit: other thing i just install bubbleupnp on my android phone and I cant connect to the foobar media server over the internet. On the local network it works OK but when i try to use it over the 3G network it say authentication fail.
The foobar log says "foo_upnp: Denied WAN request (ip: 85.118.193.170, User Agent: BubbleUPnP UPnP/1.1)" I am sure about the credentials . I use them in the office with foobar instance and they works.

This post has been edited by jorometala: Jul 15 2012, 10:32
Go to the top of the page
+Quote Post
Sandrine
post Jul 21 2012, 21:15
Post #1564





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



I'm trying to convince my Yamaha RX-V3067 to accept DSD input. It's basically able to reproduce DSD, I'm just not sure if the integrated DNLA renderer would be able to play it. I've set the SACD decoder to DSD, the streaming profile to MAX rate 2822400, max bitdepth to 24 and "Decode to PCM" to "Never to WAV". Still the Yammi plays at PCM 88khz and the foobar2000 console tells me

"foo_upnp: opened 'file://F:\Music2\_SACD\Modern\Adriano Celentano - (2004) C'e Sempre Un Motivo (SACD ISO 2.0 5.1)\C'E' SEMPRE UN MOTIVO.iso' for streaming, profile: Default, WAV / 88200 Hz / 24 bits / 2 channels, replaygain: off, DSP chain: off"

Multichannel rendering via UPnP doesn't seem to work at all. Any ideas?
Btw, the manual says

"DNLA Version 1.5 (DMP and DMR support), max. audio 24/96."


This post has been edited by Sandrine: Jul 21 2012, 21:19
Go to the top of the page
+Quote Post
bubbleguuum
post Jul 21 2012, 23:05
Post #1565





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (Sandrine @ Jul 21 2012, 22:15) *
I'm trying to convince my Yamaha RX-V3067 to accept DSD input. It's basically able to reproduce DSD, I'm just not sure if the integrated DNLA renderer would be able to play it. I've set the SACD decoder to DSD, the streaming profile to MAX rate 2822400, max bitdepth to 24 and "Decode to PCM" to "Never to WAV". Still the Yammi plays at PCM 88khz and the foobar2000 console tells me

"foo_upnp: opened 'file://F:\Music2\_SACD\Modern\Adriano Celentano - (2004) C'e Sempre Un Motivo (SACD ISO 2.0 5.1)\C'E' SEMPRE UN MOTIVO.iso' for streaming, profile: Default, WAV / 88200 Hz / 24 bits / 2 channels, replaygain: off, DSP chain: off"

Multichannel rendering via UPnP doesn't seem to work at all. Any ideas?
Btw, the manual says

"DNLA Version 1.5 (DMP and DMR support), max. audio 24/96."



Do you have disabled the "stereo only" checkbox in the profile ?
Go to the top of the page
+Quote Post
bubbleguuum
post Jul 22 2012, 12:40
Post #1566





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (jorometala @ Jul 15 2012, 11:02) *
Hallo
First sorry for my bad English.
I'm using Foobar and foo_upnp plugin on Win Xp (don't ask why) for long time. Soon I put the pc in the closet and configure it to sleep after 15 minutes idle (for energy saving) and I noticed that when I play music on the pc on my local network the server pc goes to sleep after 15 minutes and оf course the music stops. Is that a misconfiguration or an issue of foobar and foo_upnp ? Is there a way to make the server to holds the PC awake when there is a streaming in progress and to go to sleep after the set idle time go to sleep when there is no streaming?

That's weird: the plugin normally prevent the PC from sleeping while it is streaming.


QUOTE
edit: other thing i just install bubbleupnp on my android phone and I cant connect to the foobar media server over the internet. On the local network it works OK but when i try to use it over the 3G network it say authentication fail.
The foobar log says "foo_upnp: Denied WAN request (ip: 85.118.193.170, User Agent: BubbleUPnP UPnP/1.1)" I am sure about the credentials . I use them in the office with foobar instance and they works.


In Android BubbleUPnP, you *cannot* connect directly to a remote foo_upnp. You can only connect to BubbleUPnP Server which in turn will make your foobar2000 UPnP server accessible over the Internet, or any other Media Server you may have.
Go to the top of the page
+Quote Post
bubbleguuum
post Jul 22 2012, 12:43
Post #1567





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (Sandrine @ Jul 21 2012, 22:15) *
"foo_upnp: opened 'file://F:\Music2\_SACD\Modern\Adriano Celentano - (2004) C'e Sempre Un Motivo (SACD ISO 2.0 5.1)\C'E' SEMPRE UN MOTIVO.iso' for streaming, profile: Default, WAV / 88200 Hz / 24 bits / 2 channels, replaygain: off, DSP chain: off"


Might be due to your SACD being an ISO which I believe has the consequence that each separate track has a subsong index (like single FLAC + cue sheet).
Any track having a subsong index is streamed forced to PCM (it cannot be otherwise: there's no physical file for the track), and I think the plugin is not DSD aware that way (never tested it).
Go to the top of the page
+Quote Post
bubbleguuum
post Jul 22 2012, 12:47
Post #1568





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (e1964692@rtrtr.com @ Jul 14 2012, 12:12) *
hey bubbleguuum, very nice plugin for foobar!

i hear music through it and bubbleupnp since i get my 99$ touchpad.. very cool!

next step is to use the renderer and the music server at the same time. my idea is to use the tablet to select the music from my foobar playlist/archiv on my pc and render it on the same pc, controlled by bubbleupnp.
but i dont get it to work. he doesnt play my selectet music. but when i play a random file on foobar@pc and open bubbleupnp@touchpad i can pause the track and resume!?


If what you want is a remote UI to control foobar, BubbleUPnP is not exactly that as it manages its own playback queue totally independent of foobar's own playback queue.
For pure foobar2000 control, a dedicate foobar controller app will probably be better.

This post has been edited by bubbleguuum: Jul 22 2012, 12:49
Go to the top of the page
+Quote Post
psme
post Jul 23 2012, 14:12
Post #1569





Group: Members
Posts: 39
Joined: 10-October 11
Member No.: 94259



hi bubbleguuum,

Thanks again for the great UPnP plugin, I use it almost everyday!

But there is 1 minor issue that bug me! In my library, some albums have multiple versions of the same song, 1 with vocal, 1 is instrumental. On the vocal track, I tag the song with Artist, and I specifically leave the instrumental track a blank Artist tag. I also tag a AlbumArtist so tracks are grouped in a album.

But, for those blank/empty Artist track, foobar upnp will automatically use the AlbumArtist as the track Artist, which is not I wanted. I'd much prefer foobar upnp simply let the track Artist as is, which is blank/empty as I desired. Or add an option to let user to disable this automatic Artist name fillin/replacement!

Then foobar upnp will be simply PERFECT imo! smile.gif
Go to the top of the page
+Quote Post
bubbleguuum
post Jul 24 2012, 12:55
Post #1570





Group: Developer
Posts: 1110
Joined: 13-November 05
Member No.: 25748



QUOTE (psme @ Jul 23 2012, 15:12) *
hi bubbleguuum,

Thanks again for the great UPnP plugin, I use it almost everyday!

But there is 1 minor issue that bug me! In my library, some albums have multiple versions of the same song, 1 with vocal, 1 is instrumental. On the vocal track, I tag the song with Artist, and I specifically leave the instrumental track a blank Artist tag. I also tag a AlbumArtist so tracks are grouped in a album.

But, for those blank/empty Artist track, foobar upnp will automatically use the AlbumArtist as the track Artist, which is not I wanted. I'd much prefer foobar upnp simply let the track Artist as is, which is blank/empty as I desired. Or add an option to let user to disable this automatic Artist name fillin/replacement!

Then foobar upnp will be simply PERFECT imo! smile.gif


EDIT: foo_upnp does indeed use %artist% to populate the artist returned to client, hence getting the album artist if the artist tag is empty.
Will fix for next release.

This post has been edited by bubbleguuum: Jul 24 2012, 13:05
Go to the top of the page
+Quote Post
Marwin
post Jul 25 2012, 09:09
Post #1571





Group: Members
Posts: 2
Joined: 25-July 12
Member No.: 101731



Hi everybody!

Would you please help to solve a problem with streaming playback stream capture to XBMC.

When playing 'playback stream capture' to XBMC (run on Apple TV 2) there is some kind of white noise coming out from speakers even not modulated by the original music. Playing an MP3 track from music library works fine. Playback stream capture to Sonos 5 works fine.

Assume I need to adjust some streaming profile for that case. Tried to change values in default profile without success.

versions: renderer - xbmc 11.0 on ATV2, controller - plugplayer 4.1.1 on Ipad, server - foobar2000 1.1.2 with foo_upnp 0.99.40
Go to the top of the page
+Quote Post
GeSomeone
post Jul 25 2012, 12:08
Post #1572





Group: Members
Posts: 921
Joined: 22-October 01
From: the Netherlands
Member No.: 335



QUOTE (bubbleguuum @ Jul 24 2012, 13:55) *
foo_upnp does indeed use %artist% to populate the artist returned to client, hence getting the album artist if the artist tag is empty.
Will fix for next release.

To me the foobar2000 way makes sense, but a possibility to define or choose between Artist, Album Artist, Track Artist (or Composer?) would probably cover any tagging behavior.

This post has been edited by GeSomeone: Jul 25 2012, 12:09
Go to the top of the page
+Quote Post
Marwin
post Jul 25 2012, 18:25
Post #1573





Group: Members
Posts: 2
Joined: 25-July 12
Member No.: 101731



QUOTE (Marwin @ Jul 25 2012, 11:09) *
Hi everybody!

Would you please help to solve a problem with streaming playback stream capture to XBMC.

When playing 'playback stream capture' to XBMC (run on Apple TV 2) there is some kind of white noise coming out from speakers even not modulated by the original music. Playing an MP3 track from music library works fine. Playback stream capture to Sonos 5 works fine.

Assume I need to adjust some streaming profile for that case. Tried to change values in default profile without success.

versions: renderer - xbmc 11.0 on ATV2, controller - plugplayer 4.1.1 on Ipad, server - foobar2000 1.1.2 with foo_upnp 0.99.40


edit: if I play anything but stream capture on XBMC through UPNP it shows mp3, wav, flac icons after track name in XBMC context menu. But when I play stream capture it shows 'foobar2000 - ?' text.
Go to the top of the page
+Quote Post
Guillaume
post Aug 6 2012, 13:32
Post #1574





Group: Members
Posts: 280
Joined: 13-February 02
Member No.: 1319



Component looks great, massive thx. Can't get it to work on my XBMC on XBOX, though. When trying (supported) LPCM 44.1/48kHz, constantly getting this error message in XBMC log:
QUOTE
ERROR: CAudioDecoder: Unable to Init Codec while loading file http://192.168.1.1:56923/content/aa26c86f9...amplerate=48000


When trying WAV, getting static noise.
When trying MP3 (which I'd rather not do), it works.


--------------------
Listen to Guillaume - EAC/MP3 Guide
I see seven towers, but I only see one way out...
Go to the top of the page
+Quote Post
amatala
post Aug 14 2012, 13:49
Post #1575





Group: Members
Posts: 11
Joined: 20-January 12
Member No.: 96575



Hello,

I'm using foobar+foo_upnp to stream audio files to my Marantz AV7005 pre/processor. The problem is that I'm facing frequent audio drop-outs when streaming high resolution 96K/24bit FLAC and WAV files. I've tried disabling any kind of processing, DSP, transcoding - still, no luck... crying.gif
The same files are streaming perfectly from the same PC when using TVersity.
Also, standard resolution 44/16 files are working perfectly under foo_upnp - no problem whatsoever.

Is there anything else I can try in order to have the hi-res files working under foo_upnp? I'd like to get rid of TVersity and use foo_unp for streaming all my music - it's much more flexible and offers a lot of features TVersity does not have - e.g. ReplayGain support...

Thanks!
Go to the top of the page
+Quote Post

78 Pages V  « < 61 62 63 64 65 > » 
Reply to this topicStart new topic
3 User(s) are reading this topic (3 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd August 2014 - 21:06