IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Playback queue flushes after playing from ML search, Why? Is intended to be like that?
EpicForever
post Feb 2 2014, 14:33
Post #1





Group: Members
Posts: 717
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Well, maybe someone will tell me that it isn't a bug but it is strange to me and I haven't noticed it before...
Today I noticed, that if I build playback queue and then at some moment I will open Media Library Search window and play something from results, my queue is flushed... Why this happens? Can I do something to change it and keep queue in such scenario? I use foobar 1.2.9. I use foo_keep_queue plugin and it works when I close foobar, but it seems it is unrelated to interruption of playback when ML serach is invoked... Everything is fine when I use simple playlist search. In this case queue is not flushed and it continues play after track from results finishes. I expected the same with ML Search.
Go to the top of the page
+Quote Post
EpicForever
post Feb 4 2014, 18:52
Post #2





Group: Members
Posts: 717
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Anyone? smile.gif
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Feb 4 2014, 20:12
Post #3





Group: Members
Posts: 940
Joined: 21-December 01
From: New Zealand
Member No.: 705



Have you tried disabling library viewer selection playlist in the media library sub menu in the foobar2000 preferences?


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
EpicForever
post Feb 4 2014, 20:42
Post #4





Group: Members
Posts: 717
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Doesn't help...
Maybe I should ask additional question - does anyone notice the same behavior?
Go to the top of the page
+Quote Post
Case
post Feb 4 2014, 22:22
Post #5





Group: Developer (Donating)
Posts: 2270
Joined: 19-October 01
From: Finland
Member No.: 322



Queue flushing upon manual track selection is an intended feature. The component foo_keep_queue is bugged and fails to save queue contents when playing tracks from the library search.
Go to the top of the page
+Quote Post
EpicForever
post Feb 8 2014, 08:22
Post #6





Group: Members
Posts: 717
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Thanks for reply Case smile.gif
How I understand your post, taking my quite long time foobar experience into account:
1. Queue flushing upon manual track selection is an intended feature of foobar's core. This is how Peter/other main dev has decided that it should be. It happens in any scenario - F3 search, ML search, simple doubleclicking somewhere on playlist.
2. foo_keep_queue was intended to change behavior from point 1. in every possible scenario, but it has a slight bug, and scenario with ML search is not supported. From the point of foo_keep_queue this is not intended to flush queue when ML search is invoked - this is only because of bug.
Am I correct? Bit pity that foo_keep_queue developer seems to be long time inactive...
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 07:21