IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
New Problematic sample!!!
[JAZ]
post Jul 8 2002, 22:41
Post #1





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



I've encountered a sample that fulminates lame at any preset ( and I mean ANY, even --alt-preset insane).

http://www.terra.es/personal4/jas00010/fil...we32-20sec.flac

(try http://jaz.project-psy.com/files/awe32-20sec.flac if the other one doesn't work)

The sample comes from a self-made song (with virtual instruments), where I use chorusing. LAME produces noise in there. --alt-preset insane is nearly acceptable, but can be ABX'd (haven't tried to).
Using --alt-preset standard, the noise is more hearable, and I'm sure that anyone can hear it with -b 128

Note: I used Headphones, because it's at night. Maybe with speakers the noise is not as evident.

(As a reference, vorbis pre-rc4 with -q 5 (~160kbps) doesn't have this problem)
Go to the top of the page
+Quote Post
Wombat
post Jul 8 2002, 23:31
Post #2





Group: Members
Posts: 1060
Joined: 7-October 01
Member No.: 235



Congrats [JAZ] !!

you found the first sample that makes nspsytune make an error!

The artifacts are very obvious.

Maybe this is caused by the annormal ending of one sound
ending exactly at 16 kHz where the last sfb comes in?

regards

Wombat
Go to the top of the page
+Quote Post
Seed
post Jul 10 2002, 06:57
Post #3


Musepack Project Coordinator


Group: Developer
Posts: 161
Joined: 24-June 02
Member No.: 2385



[JAZ], I beg to differ. Vorbis pre RC4 CVS from July 4th, -q 5:

http://seed.d2g.com/awe32-20sec.ogg

Very obvious artifacts at the beginning.

I find that only Psytel's AAC encoder handles this sample at around 192 kbps. MPC
and Ogg need higher bitrates to eliminate the artifacts.

Cheers
Go to the top of the page
+Quote Post
[JAZ]
post Jul 10 2002, 09:44
Post #4





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



Yes Seed, you're right.
I didn't listened carefully between the ogg and the .wav, since I noticed the difference between the ogg and the mp3.

EDIT

I finally did the ABX with the current Vorbis 1.0 (used OggDropXPd from rarewaves)

at -q3 : 20 of 20 ( 0.001 )
at -q6 : 18 of 22 ( 0.002 )
at -q7 : 12 of 22 ( 0.416 ) <- Can't really hear the difference. I hear differences playing the same file again. ( Avg 254kbps!!!! )

Again, using headphones. I can hear the problem with q3 with my crappy speakers, but I can't with q6.


ABX'ing APS is out of question, once one see the graphics below.
Go to the top of the page
+Quote Post
plazz
post Jul 10 2002, 18:22
Post #5





Group: Members
Posts: 29
Joined: 30-May 02
From: Cork, Ireland
Member No.: 2167



What song is this?
Go to the top of the page
+Quote Post
Slo Mo Snail
post Jul 10 2002, 18:45
Post #6





Group: Members
Posts: 111
Joined: 2-July 02
From: Germany
Member No.: 2450



Maybe you should read it again wink.gif

QUOTE
The sample comes from a self-made song (with virtual instruments), where I use chorusing.
Go to the top of the page
+Quote Post
[JAZ]
post Jul 10 2002, 21:31
Post #7





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



The song is avaiable in original form ( .psy format, from the open sourcePsycle Tracker , ) at my webpage (songs section). There's the description of the song, and the reason of why it is called "awe32" :·)

Ps. I'm not a webdesigner (as it would be obvious)..
Go to the top of the page
+Quote Post
rts
post Jul 12 2002, 23:43
Post #8





Group: Members
Posts: 35
Joined: 3-January 02
From: Sweden, Malmö
Member No.: 896



QUOTE
Originally posted by [JAZ]
I've encountered a sample that fulminates lame at any preset ( and I mean ANY, even --alt-preset insane).

http://www.terra.es/personal4/jas00010/fil...we32-20sec.flac

(try http://jaz.project-psy.com/files/awe32-20sec.flac if the other one doesn't work)

The sample comes from a self-made song (with virtual instruments), where I use chorusing. LAME produces noise in there. --alt-preset insane is nearly acceptable, but can be ABX'd (haven't tried to).
Using --alt-preset standard, the noise is more hearable, and I'm sure that anyone can hear it with -b 128

Note: I used Headphones, because it's at night. Maybe with speakers the noise is not as evident.

(As a reference, vorbis pre-rc4 with -q 5 (~160kbps) doesn't have this problem)


I tested with lame --alt-preset standard, and I can hear a 'breathing' sound around 8 seconds.
Easy to year. Is this the artifact you mean? Can't hear it with --xtreme or --insane though.
Is this a pre-echo? I ABX'd it 8/8 times...I know I should do at least 16 tests, but hey, it's 0:40AM
and I'm tired of listening to the clip now, 'cause the artifact occurs so far in the clip.

Edit: Spelling.

/Tobbe
Go to the top of the page
+Quote Post
smok3
post Jul 13 2002, 02:56
Post #9


A/V Moderator


Group: Moderator
Posts: 1738
Joined: 30-April 02
From: Slovenia
Member No.: 1922



12/16 (p=0.038) = abxed | - lame 3.92 --alt-preset standard (217kbps)
03/08 (p=0.855)!= abxed | - oggenc 1.0 -q4 (143kbps) - gave up.
09/16 (p=0.402)!= abxed | - mppenc 1.06 -standard (335kbps)

pretty late here, and i used my 'live5.1/sony md amp/b&w 302' boxes thingy..., could swear i heard some cimbal problems with mpc, but couldnt abx, ill try again tommorow..., iam very surprised with ogg, have to give up.


--------------------
PANIC: CPU 1: Cache Error (unrecoverable - dcache data) Eframe = 0x90000000208cf3b8
NOTICE - cpu 0 didn't dump TLB, may be hung
Go to the top of the page
+Quote Post
[JAZ]
post Jul 14 2002, 10:14
Post #10





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



QUOTE
Originally posted by rts


I tested with lame --alt-preset standard, and I can hear a 'breating' sound around 8 seconds.
Easy to year. Is this the artifact you mean? Can't hear it with --xtreme or --insane though.


If you're not sure of the artifact, try hearing at -b 128. It affects to the bass as some sort of extra noise (maybe this breathing you say), and when the drum enters. When I first heard it I thought "damn! have I saved it in 8bits?"
Go to the top of the page
+Quote Post
Tom Servo
post Jul 14 2002, 15:59
Post #11





Group: Members
Posts: 168
Joined: 11-January 02
Member No.: 981



Vorbis 1.0 at -q 3 did compress it flawlessly (avg 136kbit)
Go to the top of the page
+Quote Post
[JAZ]
post Jul 14 2002, 20:25
Post #12





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



Due to curiosity, I've checked the Frequency (spectogram) display of the original, the lame 3.92 aps and the vorbis 1.0 -q6. Here there are the images I've get:

This is the 6th and 7th note of the bass, since the beginning of the song ( A A C, A A AC E )

The noise is clearly seen in it.








(if, for any case, the ISP deletes the images (they deleted one .mp3 from there once, even when it was linked in the page), there's a copy at http://jaz.project-psy.com/images )
Go to the top of the page
+Quote Post
CiTay
post Jul 15 2002, 23:14
Post #13


Administrator


Group: Admin
Posts: 2378
Joined: 22-September 01
Member No.: 3



Moved OT discussion to http://www.hydrogenaudio.org/forums/showth...=&threadid=2676.
Go to the top of the page
+Quote Post
[JAZ]
post Jul 16 2002, 19:29
Post #14





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



Attention.
This sample might show a limitation in the MP3 format rather than a problem in the LAME implementation.
The same problem is found in the Fraunhofer codec.
I've abx'd both, the Fraunhofer 320kbps , and the AP insane (with both, I did 27 of 27).

I also ABX'd Fhg one against LAME one, I did 46 of 60 ( 0.001 ) ( It took me a while to realize where the difference was). LAME was causing a rough sound in a note and the noise was more apparent after it, whereas fhg was more or less constant in the noise.

Noise is only hearable at the start of the notes as some "shhhhs"

(edit: grammatical faults)
Go to the top of the page
+Quote Post
treech
post Jul 16 2002, 19:56
Post #15





Group: Members
Posts: 208
Joined: 28-May 02
From: Helsingborg
Member No.: 2147



Damn, i can't ABX it at 320 ... :=)

try freeformat while you are at it.
i think it only can be played back at 640 with the MAD decoder(if you want to listen to it in winamp), but since you do wav--->mp3--->wav and then abx i guess it's a non-issue ....

smile.gif


it's
lame --freeformat -b 640 f:wavkiller.wav f:killer_freeformat.mp3
Go to the top of the page
+Quote Post
Tom Servo
post Jul 16 2002, 19:59
Post #16





Group: Members
Posts: 168
Joined: 11-January 02
Member No.: 981



Heh, not to be offtopic, but would be bitrates at 640kbit still be useful for audio compression?? biggrin.gif
Go to the top of the page
+Quote Post
treech
post Jul 16 2002, 20:02
Post #17





Group: Members
Posts: 208
Joined: 28-May 02
From: Helsingborg
Member No.: 2147



Just for fun i guess biggrin.gif :diabolic: biggrin.gif biggrin.gif
Go to the top of the page
+Quote Post
[JAZ]
post Jul 16 2002, 20:41
Post #18





Group: Members
Posts: 1793
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



This might seem a joke, but I've been able to abx 29 out of 33 (0.001) the freeformat 640 against the original. but probably 99.995% of people wouldn't get it.
I can't really describe the difference, it was a sutble change in the chorus in one concrete part. Original seemed clean, while mp3 seemed not that clean.

Since the problem was noticeable at another part, it might not be related.

Only MPC passes the test as of right now ( with --standard, 242kbps file)

(Thanks Citay, again. you know why ;·) )


Edit:

Due to request, the list of codecs and settings tried:

LAME
--alt-preset standard: Not tried to abx. it's just too evident. || Quality : 2.3 (annoying)
--alt-preset insane: Not tried to abx. Less evident, but still. || Quality : 2.7 (annoying)
--alt-preset insane --freeformat -b 640 : abx 29 of 33 || Quality : 4.6 (slighly perceptible. not annoying)
--freeformat -b 640 -m s : Can't abx

Fraunhoffer (the one with nero, disabling the mp3pro capability, intensity stereo and resampling)
high quality -b320 : Not tried to abx. Evident too. || Quality : 2.8 (annoying)

ABX between --alt-preset insane and fraunhoffer -b320 : 46 out of 60 (0.001)
(JohnV points that not using --nspsytune in this sample would help)


Vorbis 1.0
-q3 : abx 20 of 20 || Quality : 2.7 (annoying)
-q6 : abx 18 of 22 || Quality : 3.8 (slightly annoying)
-q7 : abx 12 of 22 == Guessing
-q7 (with a more complex part) : abx 20 of 22 || Quality : 4.2 (perceptible, but not annoying)
-q8 : abx 12 out of 22 = Guessing (even with the more complex part)

Musepack 1.06

--standard : Can't abx, not even the complex part.
bitrates : whole song : 242kbps
most complex part : 292kbps

Quicktime 6 MP4

-192kbps : Not tried to abx || Quality : 1.5 ( Sounds coming from a scratched vinyl)
-256kbps : Not tried to abx || Quality : 3.2 ( Sounds fine, but there are still some scratches)

Psytel AACenc
312kbps (encoded by wild_board) : abx : 20 of 25 || Quality : 4.8 (Slightly perceptible)
Archive ( 242kbps ) : can't abx


Edit : Quality numbers are a bit relative... not really exact.
Go to the top of the page
+Quote Post
JohnV
post Jul 17 2002, 00:15
Post #19





Group: Developer
Posts: 2797
Joined: 22-September 01
Member No.: 6



QUOTE
Originally posted by [JAZ]
This might seem a joke, but I've been able to abx 29 out of 33 (0.001) the freeformat 640 against the original. but probably 99.995% of people wouldn't get it.
I can't really describe the difference, it was a sutble change in the chorus in one concrete part. Original seemed clean, while mp3 seemed not that clean.
I know you tested with --alt-preset insane --freeformat -b 640. Unfortunately nspsytune messes with this sample more than gpsycho. There's clear pre-echo with that setting which many people surely can hear, it's infact very audible. Seems that this sample similar to vangelis.wav doesnt trigger short blocks in few critical places when using nspsytune, thus the clear pre echo even at 640kbps.

It sounds better with --freeformat -b640 -ms.


--------------------
Juha Laaksonheimo
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 19:47