IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
vorbis-tools 1.4.0, libvorbis 1.3.1, and libao 1.0.0 coordinated relea, March 26, 2010 Xiph's news
john33
post Apr 15 2010, 19:27
Post #51


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (john33 @ Apr 15 2010, 19:03) *
QUOTE (zanuda @ Apr 15 2010, 17:52) *
oggenc2-87-1.3.1
foobar2000 v1.0.2.1
windowsXP

QUOTE
1 out of 1 tracks converted with major problems.
....
Conversion failed: The encoder has terminated prematurely with code 0 (0x00000000); please re-check parameters


I can confirm the same problem. Same set up converting a 6 channel 384kbps .ac3 file of approx 1 hour 56 mins, the conversion failed at approx 1 hour 2 mins with the same message.

I suspect this may be something to do with the new channel coupling in libvorbis, but I'll need to do some more checking to be sure.

Well, further testing tends to suggest that it is not oggenc2 that is the problem. I decoded the 6 channel .ac3 file to a 6 channel wave file, using the convert option in foobar, and then converted the 6 channel wave file to a 6 channel .ogg file, also in foobar, and it completed normally. Anyone have any ideas on this? The issue would appear to be in the direct transcoding of .ac3 to .ogg - memory leak, perhaps? Pure guess, as I've no real idea!


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
zanuda
post Apr 15 2010, 22:25
Post #52





Group: Members
Posts: 5
Joined: 18-August 08
Member No.: 57234



I tried convert 6 channel .ac3 file to .flac
Result. The same error

QUOTE
1 out of 1 tracks converted with major problems.

Source: "D:\cinema\T2_Audio.ac3"
An error occurred while writing to file (The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters) : "D:\cinema\T2_Audio.flac"
Additional information:
Encoder stream format: 48000Hz / 6ch / 24bps
Command line: "C:\Program Files\FLAC\flac.exe" -s --ignore-chunk-sizes -8 - -o "T2_Audio.flac"
Working folder: D:\cinema\The Descent BD\

Conversion failed: The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters


This post has been edited by zanuda: Apr 15 2010, 22:25
Go to the top of the page
+Quote Post
john33
post Apr 15 2010, 22:52
Post #53


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Sorry, I confirm that directly converting the 6 channel .ac3 file to .ogg causes the same error on my test system which is configured the same as yours. However, if the file is decoded to a 6 channel wave file (via foobar) and then encoded to a .ogg file, it completes normally. That suggests to me that the problem lies somewhere in the chain prior to oggenc2 since the input to oggenc2 should be the same in both cases.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
tebasuna51
post Apr 19 2010, 20:02
Post #54





Group: Members
Posts: 57
Joined: 11-July 06
Member No.: 32807



QUOTE (john33 @ Apr 15 2010, 20:03) *
QUOTE (zanuda @ Apr 15 2010, 17:52) *

QUOTE
1 out of 1 tracks converted with major problems.
....
Command line: "E:\Soft\oggenc2.87-1.3.1-generic\oggenc2.exe" -s 1445268101 -Q -q5,000000 - -o "VTS_01_1 T80 3_2ch 384Kbps DELAY 66ms.ogg"
....
Conversion failed: The encoder has terminated prematurely with code 0 (0x00000000); please re-check parameters


I can confirm the same problem. Same set up converting a 6 channel 384kbps .ac3 file of approx 1 hour 56 mins, the conversion failed at approx 1 hour 2 mins with the same message.

Two ideas about the problem:

1) With Foobar2000 1.0 the method to send data to external encoders is using a WAV (with a WAVE_FORMAT_EXTENSIBLE header) with the length values (RIFF_length and DATA_length) filled with a value of 0xFFFFFFFF.
Then we need always, not only with big >4GB wav, use the appropriate parameter:
Oggenc2 --ignorelength
NeroAacEnc -ignorelength
Aften -readtoeof 1
Flac --ignore-chunk-sizes

2) I found some sync problems when use STDOUT-STDIN read method.
I'm not sure, but maybe is a OS problem.
Let me explain the workaround I use in my code applied to the code used in wav_read function in audio.c (oggenc2).

I think when you use, over STDIN:
CODE
long bytes_read = fread(buf, 1, samples*sampbyte*f->channels, f->f);

you can get bytes_read less than bytes requested without reach the end of file.
This finish the encode for oggenc2 but Foobar2000 still want send data to STDOUT.

For me work a code like this:

CODE
long bytes_read = 0;
long bytes_to_read = samples*sampbyte*f->channels;
long bytes_read_now = 1;

while ((bytes_read < bytes_to_read) && (bytes_read_now > 0))
{
    bytes_read_now = fread(buf[bytes_read], 1, bytes_to_read - bytes_read, f->f);
    bytes_read += bytes_read_now;
}

Maybe you can try this workaround to see if the problem is fixed.

This post has been edited by tebasuna51: Apr 19 2010, 20:40
Go to the top of the page
+Quote Post
john33
post Apr 19 2010, 21:58
Post #55


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Thanks for the suggestion, I'll give it a try and report back.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
john33
post Apr 20 2010, 10:42
Post #56


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



I tried this just now and I'm afraid that I get exactly the same problem at exactly the same point in the transcode. crying.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
robert
post Apr 20 2010, 11:26
Post #57


LAME developer


Group: Developer
Posts: 788
Joined: 22-September 01
Member No.: 5



At what point in the input data stream does the termination happen? At 0x7fffffff ? Some signed int problem maybe?
6 channels at 48 kHz sample rate, each sample 3 bytes (24 bits) : round about at 41.42 minutes ?
6 channels at 48 kHz sample rate, each sample 2 bytes (16 bits) : round about at 62.13 minutes ?
Go to the top of the page
+Quote Post
john33
post Apr 20 2010, 13:48
Post #58


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (robert @ Apr 20 2010, 11:26) *
At what point in the input data stream does the termination happen? At 0x7fffffff ? Some signed int problem maybe?
6 channels at 48 kHz sample rate, each sample 3 bytes (24 bits) : round about at 41.42 minutes ?
6 channels at 48 kHz sample rate, each sample 2 bytes (16 bits) : round about at 62.13 minutes ?

The last one. Edit: 1:02:08, to be precise

What seems odd to me though is that I can decode the 6 channel .ac3 file to 6 channel .wav using foobar convert and it completes just fine. I can then encode the 6 channel .wav file to 6 channel .ogg using foobar convert and that also completes fine. It is the .ac3 to .ogg transcode that fails.

This post has been edited by john33: Apr 20 2010, 14:00


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
tebasuna51
post Apr 20 2010, 14:44
Post #59





Group: Members
Posts: 57
Joined: 11-July 06
Member No.: 32807



The 1:02:08 is the limit 0xFFFFFFFF for a wav 48KHz, 6 chan, 24 bits

I have the same problem if use the standar encoder options for ogg in Foobar2000 v1.0.2.1:
...
Command line: "D:\Programa\Audio\Behappy\encoder\oggenc.exe" -s 1317992330 -Q -q5,000000 - -o "165min.ogg"
Conversion failed: The encoder has terminated prematurely with code 0 (0x00000000); please re-check parameters

I say before than the --ignorelength parameter is necessary. You need go to
File -> Preferences -> Tools -> Converter -> Output formats -> Add New:
Encoder: Custom
Encoder: x:\yourpath\oggenc2.exe
Extension: ogg
Parameters: --ignorelength -Q -q5 - -o %d
Format is: lossy
Highest BPS: 32
Encoder name: OGGenc2
Bitrate:
Settings: Q5

With these parameters I encode a 165 min ac3, 6 chan, 48KHz at 24 bits (the limit for 16 bits is 130 min):
File name : 165min
File extension : ogg
...
Duration : 02:45:28.832
Bit rate : 450 Kbps
Channel(s) : 6 channels
Sampling rate : 48.0 KHz
SamplingCount : 476583936
...

This post has been edited by tebasuna51: Apr 20 2010, 14:54
Go to the top of the page
+Quote Post
john33
post Apr 20 2010, 15:36
Post #60


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Thanks for your patience. wink.gif

My basic error was that I had left the default '%r' option in the codeline!! Correcting that and it completed as expected. smile.gif

So, in short, it's a matter of paying proper attention to what is included in the default custom codeline and amending it correctly, both things I failed to do when I should have!!


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
rt87
post May 17 2010, 06:33
Post #61





Group: Members
Posts: 89
Joined: 28-October 03
Member No.: 9505



aoTuV post-beta5.7 [20100516] (for tester)

Release Notes translated by Excite Japan.

The test version is opened to the public because it has stabilized very much. It doesn't test with 5.1 ch, and check that there is a heard environment by all means, please. A rough change point from the test version before is as follows.

・Libvorbis 1.3.1 and latest aoTuV are integrated.

・Enhanced new Noise Normalization.

・The dynamic stereo threshold change code renewal. (Became simpler. )

・The sorting application is changed to the method of agreement to new libvorbis 1.3.1. (1.3.1 The speed in total has neither last test version nor a big difference though it sped up based on. The algorithm is different. )

・The code to improve a specific problem is partially improved.

Additionally, the venc front end was made multichannel input correspondence. The wav file to 8ch is accepted. Only 5.1ch of a multichannel coupling is effective as well as libvorbis 1.3.1. This is a limitation of the library side.


--------------------
Sorry for my English.
Go to the top of the page
+Quote Post
HotshotGG
post May 17 2010, 17:55
Post #62





Group: Members
Posts: 1593
Joined: 24-March 02
From: Revere, MA
Member No.: 1607



Sweet! Thanks for the update I will have to test it out after and build it from the source here. Thanks for keeping a heads up.


--------------------
College student/IT Assistant
Go to the top of the page
+Quote Post
Zarggg
post May 19 2010, 16:09
Post #63





Group: Members
Posts: 560
Joined: 18-January 04
From: bethlehem.pa.us
Member No.: 11318



Yay! Can't wait for a new oggenc to go on Rarewares. smile.gif
Go to the top of the page
+Quote Post
towolf
post May 19 2010, 22:04
Post #64





Group: Members
Posts: 61
Joined: 2-April 03
Member No.: 5795



QUOTE (HotshotGG @ May 17 2010, 17:55) *
Sweet! Thanks for the update I will have to test it out after and build it from the source here. Thanks for keeping a heads up.


Source? Where? I only see an .exe in a .zip.
Go to the top of the page
+Quote Post
Lumar
post Aug 22 2010, 19:20
Post #65





Group: Members
Posts: 3
Joined: 22-August 10
Member No.: 83282



Hello i'm new in the forum so... i'll talk quick. I have a file wich contains raw PCM ... i want to convert the data in this mode:

Audio: 80 Kbps, 10000 Hz, 1 channels, 0x1 = MS PCM, , , Supported

so if anyone can help me just let me know here or join me on skype with skypename: uplink_ltd


Thank you!
Go to the top of the page
+Quote Post
forart.eu
post Aug 23 2010, 08:51
Post #66





Group: Members
Posts: 74
Joined: 10-December 09
From: italy
Member No.: 75798



QUOTE (Lumar @ Aug 22 2010, 20:20) *
Hello i'm new in the forum so... i'll talk quick. I have a file wich contains raw PCM ... i want to convert the data in this mode:

Audio: 80 Kbps, 10000 Hz, 1 channels, 0x1 = MS PCM, , , Supported

so if anyone can help me just let me know here or join me on skype with skypename: uplink_ltd


Thank you!


Well, well, i'm a mono user too !

BTW 10KHz seems too low for music content, IMHO (if you have voice recordings keep in consideration Speex instead).

Choose at least 22 KHz @ q0 (64 Kbps) to have realiable results.

The suggestion is to use Foobar2000 in combination with Stereo Tool (commandline) to correctly "collapse&encode" 44Khz PCM stereo to 22Khz Vorbis mono.

This post has been edited by forart.eu: Aug 23 2010, 08:53
Go to the top of the page
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2014 - 19:44