IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
DTS audio file only playing in 2ch
ghebert
post Jan 12 2010, 01:49
Post #1





Group: Members
Posts: 7
Joined: 29-August 09
Member No.: 72735



I have read many posts on many forums including here...I am begining to think there is no solution to this problem.

I am able to play DTS and Dolby 5.1 DVD's, also I am able to play DTS and Dolby 5.1 music files provided they are encoded in 5.1 channels. My problem is with DTS audio files that are encoded in 2ch .wav files that when burned to a cd will play in 5.1 on my DVD player but the file will play static in 2ch on my pc. I have tried foobar2000 (using spdif.dll, windows media player (enabled spdif in options), media player classic, winamp, vlc...I don't know if there is a setting I am overlooking or .dll/codec I forgot. I've tried renaming the extension from .wav to .dts and while there is actual music instead of static, unfortunately it is still 2ch.

Any thoughts?

Thanks.
Go to the top of the page
+Quote Post
andy o
post Jan 12 2010, 10:26
Post #2





Group: Members
Posts: 1309
Joined: 14-April 09
Member No.: 68950



The usual way is that you have to make an exclusive path (bit-perfect) into your receiver. Alternatively, I think foobar can decode these files too. What audio device and OS do you have? In foobar and windows Vista/7, it should just work with the WASAPI plugin which gives you exclusive mode.

This post has been edited by andy o: Jan 12 2010, 10:32
Go to the top of the page
+Quote Post
ghebert
post Jan 12 2010, 13:24
Post #3





Group: Members
Posts: 7
Joined: 29-August 09
Member No.: 72735



I am running win xp media center and for audio device, if you are referring to what sound card I am using I am using the SPDIF optical output on my motherboard going straight to my yamaha receiver. As wasapi seems to be for win vista/7 I would need an alternative option for win xp.
Go to the top of the page
+Quote Post
andy o
post Jan 12 2010, 17:15
Post #4





Group: Members
Posts: 1309
Joined: 14-April 09
Member No.: 68950



I'm not so sure about XP. Did you try setting XP to 2-channel, 16-bit 44.1 kHz output and then max all the volume sliders? I think that gives bit-perfect output in XP. Otherwise you might have to use something like ASIO or Kernel Streaming.

I'm pretty sure there's a plugin (at least) for foobar2000 that decodes these files though, but since the 5.1 is already decoded, you'd have to use analog or HDMI to pass 5.1 LPCM to the receiver.

This post has been edited by andy o: Jan 12 2010, 17:17
Go to the top of the page
+Quote Post
Alex B
post Jan 28 2010, 13:32
Post #5





Group: Members
Posts: 1303
Joined: 14-September 05
From: Helsinki, Finland
Member No.: 24472



QUOTE (ghebert @ Jan 12 2010, 14:24) *
I am running win xp media center and for audio device, if you are referring to what sound card I am using I am using the SPDIF optical output on my motherboard going straight to my yamaha receiver. As wasapi seems to be for win vista/7 I would need an alternative option for win xp.

I just noticed this thread.

AFAIK, only some recent on-board sound devices can output 44.1 kHz audio signal through SPDIF. I was a bit disappointed (though not actually surprised) when I realized that my new Asus M4A785TD-V EVO motherboard with VIA HD audio is still not able to do 44.1 KHz without resampling to 48 KHz (at least not when the standard ASUS device driver is used). I kind of hoped that a current on-board implementation would not have that problem.

In order to use SPDIF for transferring 44.1 kHz DTS audio in PCM format to an external DTS decoder on XP, you must

1. use a "bit perfect" player that can bypass Windows Kernel Mixer (e.g. foobar2000 using Kernel Streaming or ASIO, J. River Media Center using ASIO or some other player program that has either ASIO or Kernel Streaming support).

2. have a Sound Device that supports 44.1 KHz SPDIF output and has device drivers that support ASIO and/or Kernel Streaming.

This post has been edited by Alex B: Jan 28 2010, 13:33


--------------------
http://listening-tests.freetzi.com
Go to the top of the page
+Quote Post
Mark7
post Jan 28 2010, 15:49
Post #6





Group: Members
Posts: 189
Joined: 1-June 03
Member No.: 6945



So, what soundcard do you have? And what OS?

I agree with Alex B.

Most important is to set the output of your card from 48khz to 44.1.khz. If you can't change it to 44.1khz then don't bother trying anything else, it won't work.
Once it is set to 44.1khz then you can try the several different output with foobar: waveout/directsound/kernel/asio/wasapi.

Goodluck
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th August 2014 - 18:10