IPB

Welcome Guest ( Log In | Register )

24 Pages V  « < 4 5 6 7 8 > »   
Reply to this topicStart new topic
WMP Tag Plus - MPEG4, Vorbis and FLAC metadata support for WMP
misterdan
post Apr 21 2010, 05:20
Post #126





Group: Members
Posts: 4
Joined: 21-April 10
Member No.: 80031



I'm having a problem with WMP Tag Plus... the seek bar on WMP does not show up


As you can see in the above image, WMP is 3 minutes into the song and the seek bar is at the start position. Trying to click on any seek position starts the song at zero.

Is this a known problem?

Win 7 Pro, 32bit with madFlac.

Edit To be more specific: if I play the file from "library -> music -> artist -> NAME" and double click on the song, that is what happens. Non flac files work just fine with this method.

If I play the file from an automatic playlist, "Library -> playlists -> NAME" and then double click on the song, the playlist appears in the play tab, playing the flac file with the seek bar working just fine

This post has been edited by misterdan: Apr 21 2010, 05:24
Go to the top of the page
+Quote Post
teohhanhui
post Apr 21 2010, 06:14
Post #127





Group: Members
Posts: 34
Joined: 2-October 09
Member No.: 73639



QUOTE (misterdan @ Apr 21 2010, 12:20) *
I'm having a problem with WMP Tag Plus... the seek bar on WMP does not show up


As you can see in the above image, WMP is 3 minutes into the song and the seek bar is at the start position. Trying to click on any seek position starts the song at zero.

Is this a known problem?

Win 7 Pro, 32bit with madFlac.

Edit To be more specific: if I play the file from "library -> music -> artist -> NAME" and double click on the song, that is what happens. Non flac files work just fine with this method.

If I play the file from an automatic playlist, "Library -> playlists -> NAME" and then double click on the song, the playlist appears in the play tab, playing the flac file with the seek bar working just fine

Use Xiph.Org's DirectShow filters: http://xiph.org/dshow/

madFLAC is known to be problematic.
Go to the top of the page
+Quote Post
misterdan
post Apr 21 2010, 14:08
Post #128





Group: Members
Posts: 4
Joined: 21-April 10
Member No.: 80031



QUOTE (teohhanhui @ Apr 21 2010, 06:14) *
QUOTE (misterdan @ Apr 21 2010, 12:20) *
I'm having a problem with WMP Tag Plus... the seek bar on WMP does not show up


As you can see in the above image, WMP is 3 minutes into the song and the seek bar is at the start position. Trying to click on any seek position starts the song at zero.

Is this a known problem?

Win 7 Pro, 32bit with madFlac.

Edit To be more specific: if I play the file from "library -> music -> artist -> NAME" and double click on the song, that is what happens. Non flac files work just fine with this method.

If I play the file from an automatic playlist, "Library -> playlists -> NAME" and then double click on the song, the playlist appears in the play tab, playing the flac file with the seek bar working just fine

Use Xiph.Org's DirectShow filters: http://xiph.org/dshow/

madFLAC is known to be problematic.


I uninstalled madFlac, and when I was installing Xiph.Org's filters I realized it was already installed. re-installed to make sure there would be no problems... but I'm having the same problem as before
Go to the top of the page
+Quote Post
misterdan
post Apr 21 2010, 23:17
Post #129





Group: Members
Posts: 4
Joined: 21-April 10
Member No.: 80031



does the current version support windows media center?
Go to the top of the page
+Quote Post
Tim De Baets
post Apr 23 2010, 19:23
Post #130


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



QUOTE (misterdan @ Apr 21 2010, 14:08) *
I uninstalled madFlac, and when I was installing Xiph.Org's filters I realized it was already installed. re-installed to make sure there would be no problems... but I'm having the same problem as before

Not being able to seek is indeed a known problem with madFLAC, but I've only seen it happen on 64-bit systems. Are you sure that this is a 32-bit version of Windows 7?

For seeking to work correctly, the FLAC files need to have their length set in the library as well (just like in this screenshot). Is this the case?

Make sure that madFLAC is completely uninstalled. Do a full system search for "madflac.ax", and if the file is still found, unregister it with the following command:

regsvr32 /u madflac.ax

Then, download the 32-bit installer from http://xiph.org/dshow and run it. Reboot, and try to play the FLAC files again.

QUOTE (misterdan @ Apr 21 2010, 23:17) *
does the current version support windows media center?

Not directly; WMP Tag Plus doesn't run in Windows Media Center. However, Media Center uses exactly the same library as WMP, so it will show and play FLAC, OGG etc. files too, if WMP Tag Plus and the required DirectShow filters are installed.
Go to the top of the page
+Quote Post
misterdan
post Apr 29 2010, 17:41
Post #131





Group: Members
Posts: 4
Joined: 21-April 10
Member No.: 80031



QUOTE (Tim De Baets @ Apr 23 2010, 19:23) *
Not being able to seek is indeed a known problem with madFLAC, but I've only seen it happen on 64-bit systems. Are you sure that this is a 32-bit version of Windows 7?

100% positive. Win 7 pro 32 bit (MSDNAA version). also checked to see if I have madFLAC, via registry and search- nothing


QUOTE (Tim De Baets @ Apr 23 2010, 19:23) *
For seeking to work correctly, the FLAC files need to have their length set in the library as well (just like in this screenshot). Is this the case?

you have to manually set the length? length shows up in the autoplaylists but not in the library->music -> [section]

very weird that things work perfectly in the auto playlists but not in the normal library section
Go to the top of the page
+Quote Post
Tim De Baets
post Apr 30 2010, 00:22
Post #132


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



No, I meant that the length of the FLAC files should have been set by WMP. If this isn't the case, then you need to re-add them to the library. Make sure that WMP Tag Plus is still enabled, select the FLAC files, right-click, select Delete, Delete from library only, and click OK. Then go to Tools - Advanced and select Restore deleted library items.

When the files are re-added, their length should now be visible in the Music section as well, and they should be seekable when playing.
Go to the top of the page
+Quote Post
Pedrozo
post May 3 2010, 15:26
Post #133





Group: Members
Posts: 9
Joined: 3-May 10
From: Poland
Member No.: 80374



I have a question. Is it possible to rewind songs (FLAC, ape, ogg) in wmp12? When I try rewind an error pops up, and wmp12 turn off.
Go to the top of the page
+Quote Post
Fandango
post May 3 2010, 19:43
Post #134





Group: Members
Posts: 1548
Joined: 13-August 03
Member No.: 8353



Maybe your tape deck is broken?

Seriously a little bit more information would be helpful. Waht exactly do you mean? Seeking to the beginning of a track or just seeking back a few seconds?

Anyway I have no idea why WMP12 shouldn't be able to do that... faulty DirectShow Filters for those formats maybe? Then it's probably not WMP's fault but of whoever created the FLAC/APE/Vorbis decoder filters.
Go to the top of the page
+Quote Post
Pedrozo
post May 3 2010, 20:23
Post #135





Group: Members
Posts: 9
Joined: 3-May 10
From: Poland
Member No.: 80374



QUOTE (Fandango @ May 3 2010, 19:43) *
Maybe your tape deck is broken?

Seriously a little bit more information would be helpful. Waht exactly do you mean? Seeking to the beginning of a track or just seeking back a few seconds?

Anyway I have no idea why WMP12 shouldn't be able to do that... faulty DirectShow Filters for those formats maybe? Then it's probably not WMP's fault but of whoever created the FLAC/APE/Vorbis decoder filters.

More info:
System: Win7 x64
Player: WMP12 x32
Instaled codeks: Xiph.org 0.82.16930 64-bit
Red Light APE Directshow filter
WMP Plugins: WMP Tag Plus 1.2
Tag Support Plugin for Media Player

For example, if I play the FLAC file, the music going normal. But when I want scroll to 2:00 (for example), Then the player starts play from 0:00 again.

This post has been edited by Pedrozo: May 3 2010, 20:24
Go to the top of the page
+Quote Post
Tim De Baets
post May 4 2010, 09:58
Post #136


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



The symptoms you describe in your second post are totally different from the one in the first. What happened to the error in your first post?

Rewinding (seeking) FLAC and Vorbis in WMP is possible, but for it to work, the songs need to have their length set in the library (just like in this screenshot). Is this the case? If not, you need to re-add the songs to the library. Make sure that WMP Tag Plus is still enabled, select the songs, right-click, select Delete, Delete from library only, and click OK. Then go to Tools - Advanced and select Restore deleted library items.

WMP Tag Plus currently doesn't support the APE (Monkey's Audio) format, so seeking such files in WMP isn't possible yet.

By the way, it looks like "Tag Support Plugin for Media Player" is another tag support plug-in that you have installed. I recommend that you remove this one, to prevent conflicts with WMP Tag Plus.

This post has been edited by Tim De Baets: May 4 2010, 19:06
Go to the top of the page
+Quote Post
Pedrozo
post May 4 2010, 12:01
Post #137





Group: Members
Posts: 9
Joined: 3-May 10
From: Poland
Member No.: 80374



Re-add tracks to the library solved the problem. Thank you.
When will start work on the Ape in WMP Tag Plus plug-in?
Go to the top of the page
+Quote Post
Tim De Baets
post May 4 2010, 19:10
Post #138


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Glad to hear that the problem is solved. Work on APE tag support will probably start after the summer, although I can't promise anything. You might not even have to wait that long; the WMP Tag Plus Tag Support API is documented online, so any developer that is interested could write the APE support himself.
Go to the top of the page
+Quote Post
exponent
post May 8 2010, 09:56
Post #139





Group: Members
Posts: 29
Joined: 30-March 08
Member No.: 52408



Is there support for album art in WMP Tag Plus. It seems to be th lastr piece in thye puzzle for me.
Go to the top of the page
+Quote Post
Tim De Baets
post May 8 2010, 17:09
Post #140


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



WMP Tag Plus currently doesn't support album art. This will be added in the next major version, which will probably be released this autumn.
Go to the top of the page
+Quote Post
John Lockwood
post May 12 2010, 17:40
Post #141





Group: Members
Posts: 60
Joined: 21-May 06
Member No.: 31014



I have WMP12 in Windows 7 (32bit) successfully playing AAC and Apple Lossless tracks, however WMP is adding Apple Lossless tracks to "Other Media" and AAC tracks correctly to the Music section.

I tried installing WMP Tag Plus 1.2 and removing and re-adding the Apple Lossless tracks, but they still keep showing up in Other Media.

Help!

PS. As a suggested feature, could you add an option to prevent WMP from writing to tags. Historically, WMP has a bad habit of either corrupting files, or putting bad data in files. I use iTunes to manage the tags.
Go to the top of the page
+Quote Post
Tim De Baets
post May 13 2010, 15:45
Post #142


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



That's a known bug in WMP 12: lossless M4A tracks are always added to Other Media, regardless of whether WMP Tag Plus is installed (for example, see this thread at the Windows 7 Media forum). I'll see if I can work around it for the next major version of WMP Tag Plus, probably by replacing Windows 7's built-in MPEG-4 tag support with that of WMP Tag Plus.

I'm not sure if allowing to disable the writing of tags is really worth adding. Corrupting files is pretty unlikely, as it's not WMP that is actually writing the tags to file. Also, most automatic changes by WMP can be prevented by unchecking "Retrieve additional information from the Internet" in WMP's Options.
Go to the top of the page
+Quote Post
ThCam
post May 14 2010, 08:53
Post #143





Group: Members
Posts: 2
Joined: 14-May 10
Member No.: 80629



Hi,

I have WMP12 (on Windows 7 x64) showing up most of my flac files correctly using WMP Tag Plus 1.2. However WMP does a mess showing up different albums with same name, but different artists.
For example I have an album named "Greatest Hits" of artist "Bruce Springsteen", and an album named "Greatest Hits" of artist "Foo Fighters". When I change to album-view in WMP, WMP will show up both albums, which is correct. But when I double click on one of theses albums, WMP will show the tracks of both albums, which is wrong. I'm not sure what causes the problem.

- is it a problem with my tags? I only set artist tag and album tag
- is it a bug of WMP12?
- is it a bug of WMP tag plus?

Thank you for your help.

This post has been edited by ThCam: May 14 2010, 08:58
Go to the top of the page
+Quote Post
Tim De Baets
post May 14 2010, 21:43
Post #144


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



What's the Album Artist of the FLAC tracks? If the Album Artist column isn't visible, right-click a column header in the WMP library and select Choose columns to enable it. You may need to switch to Details view as well, by clicking the little arrow next to the Search field.

With what program were the FLAC files originally tagged? Could you please post a screenshot of WMP that shows what's wrong?
Go to the top of the page
+Quote Post
ThCam
post May 15 2010, 06:26
Post #145





Group: Members
Posts: 2
Joined: 14-May 10
Member No.: 80629



Ok, I found out what was wrong. I didn't set the albumartist tag. Now it works fine. So, do I always have to set both the artist and albumartist tag? I know that it is necessary for compilations, but I didn't know that it is necessary for albums.
Go to the top of the page
+Quote Post
Tim De Baets
post May 15 2010, 11:57
Post #146


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Yes, if you don't set Album Artist, and you have two albums with the same name, but of a different artist, WMP will show both albums as one single album.
Go to the top of the page
+Quote Post
John Lockwood
post May 17 2010, 12:36
Post #147





Group: Members
Posts: 60
Joined: 21-May 06
Member No.: 31014



QUOTE (Tim De Baets @ May 13 2010, 15:45) *
That's a known bug in WMP 12: lossless M4A tracks are always added to Other Media, regardless of whether WMP Tag Plus is installed (for example, see this thread at the Windows 7 Media forum). I'll see if I can work around it for the next major version of WMP Tag Plus, probably by replacing Windows 7's built-in MPEG-4 tag support with that of WMP Tag Plus.

I'm not sure if allowing to disable the writing of tags is really worth adding. Corrupting files is pretty unlikely, as it's not WMP that is actually writing the tags to file. Also, most automatic changes by WMP can be prevented by unchecking "Retrieve additional information from the Internet" in WMP's Options.


Thank you for the response. I really hope you can fix this as you can see from that other thread a lot of people have chosen Apple Lossless as the lossless format with best Mac/PC/iPod compatibility.

If you PM me at the appropriate point, I am happy to test this for you.

PS. I was the person who came up with the original solution for playing Apple Lossless in WMP and the first person in the world to do this, with the code being written by Milenko Mitrovic.
Go to the top of the page
+Quote Post
zeoh
post May 21 2010, 11:54
Post #148





Group: Members
Posts: 4
Joined: 21-May 10
Member No.: 80795



I am also for album cover and rating support. I really hope you could include it in the future update of this wonderful plugin. Actually, it is the organisation of the library and system of rating why I still use WMP. Otherwise I would use some other program.

Btw I have a guestion, it's just a little thing:



As you see on the picture WMP puts a group of files of the same album and album artist together (eventhough they are of diferent artists).
But it doesn't do that with the Flac files even they have the same tags (I use Mp3tag to write tags). So they are all over the place.

I assume this support is also not included in plugin. Would you consider supporting this feature in your future versions of plugin?

Thank you very much for a great job you're doing.
Go to the top of the page
+Quote Post
RcK17
post May 21 2010, 14:45
Post #149





Group: Members
Posts: 5
Joined: 21-May 10
Member No.: 80800



QUOTE (zeoh @ May 21 2010, 12:54) *
As you see on the picture WMP puts a group of files of the same album and album artist together (eventhough they are of diferent artists).
But it doesn't do that with the Flac files even they have the same tags (I use Mp3tag to write tags). So they are all over the place.

The FLAC album seems to be missing the 'AlbumArtist' tag, it is required for albums where there are different artists for songs.

QUOTE (zeoh @ May 21 2010, 12:54) *
I am also for album cover and rating support.

For album covers, you can add a 'folder.jpg' file in the album folder and it will be displayed in the library (not for now playing tracks though).
Go to the top of the page
+Quote Post
teohhanhui
post May 21 2010, 16:42
Post #150





Group: Members
Posts: 34
Joined: 2-October 09
Member No.: 73639



QUOTE (RcK17 @ May 21 2010, 21:45) *
For album covers, you can add a 'folder.jpg' file in the album folder and it will be displayed in the library (not for now playing tracks though).

No, it is displayed for the now playing track as well.
Go to the top of the page
+Quote Post

24 Pages V  « < 4 5 6 7 8 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th September 2014 - 07:55