IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Wavpack with CDex, I cant get this to work for the life of me.
PhyloBrag
post Aug 2 2006, 04:15
Post #1





Group: Members
Posts: 14
Joined: 3-June 03
Member No.: 6976



I've been trying to get this to work for some time now.
I'm using the string:
-b320x6 -w "artist=%a" -w "album=%b" -w "title=%t" -w "tracknumber=%tn" -w "date=%y" -w "genre=%g" - %2

and when wavpack.exe pops up to encode, it just sits there. no numbers. no nothing.

does anyone know what the problem is?
Go to the top of the page
+Quote Post
bryant
post Aug 2 2006, 04:31
Post #2


WavPack Developer


Group: Developer (Donating)
Posts: 1292
Joined: 3-January 02
From: San Francisco CA
Member No.: 900



QUOTE (PhyloBrag @ Aug 1 2006, 20:15) *
I've been trying to get this to work for some time now.
I'm using the string:
-b320x6 -w "artist=%a" -w "album=%b" -w "title=%t" -w "tracknumber=%tn" -w "date=%y" -w "genre=%g" - %2

and when wavpack.exe pops up to encode, it just sits there. no numbers. no nothing.

does anyone know what the problem is?

I have never used CDex, but the string you specify looks okay (assuming the audio is going to be piped into wavpack.exe). I would eliminate the "x6" until you have it working because that's going to make it slooow and I think that "year" is a better choice than "date" (at least it's more compatible with the plugins I made for WavPack).

When you say nothing happens, it sounds like it's just waiting for data. If it doesn't get a wav header it won't even display the 0% done message. Is there some option in CDex to tell it to use pipes?
Go to the top of the page
+Quote Post
PhyloBrag
post Aug 2 2006, 05:14
Post #3





Group: Members
Posts: 14
Joined: 3-June 03
Member No.: 6976



Ah, I got it. i had to append %1 %2 (file in file out)
the parameter i was using was meant for on-the-fly encoding only, and that never works for me anyway.

thanks for pointing me in a better direction of thought!
Go to the top of the page
+Quote Post
dutch109
post Aug 20 2006, 14:07
Post #4





Group: Members
Posts: 123
Joined: 20-June 06
Member No.: 32044



I have a problem with CDex 1.70b2 and WavPack 4.31, I use the following string :
CODE
-h -m -w "Artist=%a" -w "Title=%t" -w "Album=%b" -w "Year=%y" -w "Track=%tn" -w "Genre=%g" - %2

I checked "On-the-fly encoding" in CDex, and it doesn't work : I get an error from CDex (something like "can't send data to the encoder") and then CDex just crash. sad.gif
What am I doing wrong ?
I tried without on-the-fly encoding, and it works fine, but I REALLY need on-the-fly encoding because otherwise it's two times slower.


--------------------
Vorbis -q2/5 (Android/PC) & WavPack -hhx6
http://playnoise.com/
Go to the top of the page
+Quote Post
bryant
post Aug 20 2006, 18:02
Post #5


WavPack Developer


Group: Developer (Donating)
Posts: 1292
Joined: 3-January 02
From: San Francisco CA
Member No.: 900



QUOTE (dutch109 @ Aug 20 2006, 06:07) *
I have a problem with CDex 1.70b2 and WavPack 4.31, I use the following string :
CODE
-h -m -w "Artist=%a" -w "Title=%t" -w "Album=%b" -w "Year=%y" -w "Track=%tn" -w "Genre=%g" - %2

I checked "On-the-fly encoding" in CDex, and it doesn't work : I get an error from CDex (something like "can't send data to the encoder") and then CDex just crash. sad.gif
What am I doing wrong ?
I tried without on-the-fly encoding, and it works fine, but I REALLY need on-the-fly encoding because otherwise it's two times slower.

I think maybe CDex also needs the -i option to force WavPack to ignore the [incorrect] length in the wav header.

If that's not it you can try the "debug" mode of WavPack to see what it's complaining about.
Go to the top of the page
+Quote Post
dutch109
post Aug 20 2006, 19:39
Post #6





Group: Members
Posts: 123
Joined: 20-June 06
Member No.: 32044



I tried with -i and it works (I also had to check "send WAV header to stdin" in CDex).

Thank you very much bryant smile.gif


--------------------
Vorbis -q2/5 (Android/PC) & WavPack -hhx6
http://playnoise.com/
Go to the top of the page
+Quote Post
Andavari
post Aug 20 2006, 22:02
Post #7





Group: Members
Posts: 935
Joined: 3-June 02
From: USA
Member No.: 2204



Yeah CDex doesn't like on-the-fly checked when using a command line encoder. Also placing this at the end will let CDex know what the source file and destination file are: %1 %2


--------------------
Complexity of incoherent design.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 13:08