IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Could not access profile folder
Cesium
post Oct 1 2010, 06:03
Post #1





Group: Members
Posts: 7
Joined: 5-September 10
Member No.: 83636



I'm trying to start foobar2000, but I keep getting an error message that says:

QUOTE
foobar2000 encountered an error

Could not access profile folder


I tried reinstalling and Google, neither of those helped. Any ideas?
Go to the top of the page
+Quote Post
shakey_snake
post Oct 1 2010, 19:10
Post #2





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



Do you have a folder at the system location: %appdata%\foobar2000 ?

Do users have read permissions to that folder?

Or did you install fb2k in portable mode?
did you install it somewhere where users have read permissions?

This post has been edited by shakey_snake: Oct 1 2010, 19:11


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Cesium
post Oct 2 2010, 00:18
Post #3





Group: Members
Posts: 7
Joined: 5-September 10
Member No.: 83636



I do have a folder there. Users do have read permissions to the folder, or I think so. How can I check?

Fb2k was not installed inportable mode.

It is installed in the default directory.
Go to the top of the page
+Quote Post
Robertina
post Oct 2 2010, 05:34
Post #4





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



QUOTE (Cesium @ Oct 1 2010, 12:18) *
I do have a folder there. Users do have read permissions to the folder, or I think so. How can I check?

Right-click the folder in question, choose the security tab and check the permissions you have (or don't have)...

Edit: you also need write permissions for that folder, read permissions are not enough.

This post has been edited by Robertina: Oct 2 2010, 05:35
Go to the top of the page
+Quote Post
Cesium
post Oct 2 2010, 06:30
Post #5





Group: Members
Posts: 7
Joined: 5-September 10
Member No.: 83636



Yes, I have full control over all the permissions. All the things are checked for "Allow."
Go to the top of the page
+Quote Post
Robertina
post Oct 2 2010, 06:38
Post #6





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



What version of foobar do you use?
Did you an upgrade or a fresh installation?
Go to the top of the page
+Quote Post
Cesium
post Oct 2 2010, 06:51
Post #7





Group: Members
Posts: 7
Joined: 5-September 10
Member No.: 83636



Version 1.1. Did a full re-installation.
Go to the top of the page
+Quote Post
Robertina
post Oct 2 2010, 07:07
Post #8





Group: Members
Posts: 1306
Joined: 4-January 09
Member No.: 65169



May I suggest to deinstall foobar2000, to delete both the program folder and the %appdata%\foobar2000 folder and then to install it again? If I understand you correctly you have not been able to run foobar successfully till now so that I conclude you wouldn't lose any personal settings?

Also do you use any Security Suite which might block foobar's access to certain folders?
Go to the top of the page
+Quote Post
noway
post Jul 21 2012, 16:08
Post #9





Group: Members
Posts: 4
Joined: 13-July 12
Member No.: 101415



in version 1.1.14 beta 1 and 1.1.13 (haven't tested earlier ones)
same error "could not access profile folder" occurs when:
1) foobar is already running
2) you try to feed it some files, but executing it from the same physical location which is symbolically different, e.g. from a symlink or junction
and i figure it doesn't matter whether it's a portable installation or not

for test case:
1) install foobar at c:\bin\foobar\
2) mount c: as a subfolder on d: mountvol d:\mycdrive \\?\{volume c: guid goes here...}
2a) or otherwise: mklink /j d:\mycdrive c:\
3) make a symlink for easy /bin access: mklink /s d:\bin mycdrive\bin
now you have the same foobar in 3 symbolically different locations: c:\bin\foobar, d:\bin\foobar and d:\mycdrive\bin\foobar
4) start foobar from any of those locations
5) try to run it from any other without closing the first and you'll get this bug

and an obvious workaround is: to put the same symbolic location into all of your shortcuts, file associations, shell scripts, etc.
and it better be a physical location or the one with less reparse poins on its way
for the 2a) case this should be c:\bin\foobar, while for the 2) case any of d:\mycdrive\bin\foobar and c:\bin\foobar would probably do
Go to the top of the page
+Quote Post
Madrusnl
post Oct 18 2012, 22:58
Post #10





Group: Members
Posts: 2
Joined: 17-January 09
From: Amsterdam
Member No.: 65675



I have also had this problem (Windows 7 x64). I installed foobar2000 with elevated rights and "could access profile folder" appeared actually to be write access problem for normal user on the installation directory. I added the write permissions on this folder and - voila! - foobar2000 could start without any further problems. tongue.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th July 2014 - 06:24